Support STAGEDIR.
This commit is contained in:
parent
33fcdce510
commit
086a33ec88
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332937
13 changed files with 117 additions and 0 deletions
|
@ -17,6 +17,26 @@ USES= perl5
|
|||
USE_PERL5= configure
|
||||
NO_BUILD= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
# Created by: ijliao
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= PDFLib
|
||||
PORTVERSION= 0.14
|
||||
CATEGORIES= print perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= perl@FreeBSD.org
|
||||
COMMENT= More OO interface to pdflib_pl.pm
|
||||
|
||||
BUILD_DEPENDS= pdflib-perl>=0:${PORTSDIR}/print/pdflib-perl
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
|
||||
USES= perl5
|
||||
USE_PERL5= configure
|
||||
NO_BUILD= yes
|
||||
|
||||
MAN3= PDFLib.3
|
||||
|
||||
NO_STAGE= yes
|
||||
|
|
|
@ -1,2 +1,4 @@
|
|||
SHA256 (PDFLib-0.14.tar.gz) = aa8dd769d262441c6773f356ae9e5370c1f2b48c07e87bc38f1a587576652b32
|
||||
SIZE (PDFLib-0.14.tar.gz) = 27294
|
||||
SHA256 (PDFLib-0.14.tar.gz) = aa8dd769d262441c6773f356ae9e5370c1f2b48c07e87bc38f1a587576652b32
|
||||
SIZE (PDFLib-0.14.tar.gz) = 27294
|
||||
|
|
|
@ -15,3 +15,20 @@
|
|||
'VERSION_FROM' => 'PDFLib.pm', # finds $VERSION
|
||||
- 'PREREQ_PM' => { pdflib_pl => 4.0 },
|
||||
);
|
||||
--- Makefile.PL.orig 2001-06-04 13:38:11.000000000 +0000
|
||||
+++ Makefile.PL
|
||||
@@ -6,7 +6,7 @@ eval {
|
||||
require pdflib_pl;
|
||||
die unless $pdflib_pl::VERSION >= 4.0;
|
||||
};
|
||||
-if ($@) {
|
||||
+if (0) {
|
||||
die <<DEATH;
|
||||
|
||||
PDFLib requires the pdflib package from http://www.pdflib.com/ version
|
||||
@@ -20,5 +20,4 @@ DEATH
|
||||
WriteMakefile(
|
||||
'NAME' => 'PDFLib',
|
||||
'VERSION_FROM' => 'PDFLib.pm', # finds $VERSION
|
||||
- 'PREREQ_PM' => { pdflib_pl => 4.0 },
|
||||
);
|
||||
|
|
|
@ -1 +1,2 @@
|
|||
A cleaner API than pdflib_pl.pm, which is a very low-level (non-OO) interface.
|
||||
A cleaner API than pdflib_pl.pm, which is a very low-level (non-OO) interface.
|
||||
|
|
|
@ -1,3 +1,7 @@
|
|||
%%PERL5_MAN3%%/PDFLib.3.gz
|
||||
%%SITE_PERL%%/PDFLib.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/PDFLib/.packlist
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PDFLib
|
||||
%%SITE_PERL%%/PDFLib.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/PDFLib/.packlist
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/PDFLib
|
||||
|
|
|
@ -7,6 +7,22 @@ CATEGORIES= print perl5
|
|||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= perl@FreeBSD.org
|
||||
COMMENT= Produce PostScript files from Perl
|
||||
|
||||
USES= perl5
|
||||
USE_PERL5= configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
# Created by: tobez
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= PostScript-Simple
|
||||
PORTVERSION= 0.07
|
||||
CATEGORIES= print perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= perl@FreeBSD.org
|
||||
COMMENT= PostScript::Simple - Produce PostScript files from Perl
|
||||
|
||||
|
|
|
@ -1,2 +1,4 @@
|
|||
SHA256 (PostScript-Simple-0.07.tar.gz) = 69cb6cf22c8ea87d8504b04166c71b73aa736ba76075964842102496c59c33f5
|
||||
SIZE (PostScript-Simple-0.07.tar.gz) = 41874
|
||||
SHA256 (PostScript-Simple-0.07.tar.gz) = 69cb6cf22c8ea87d8504b04166c71b73aa736ba76075964842102496c59c33f5
|
||||
SIZE (PostScript-Simple-0.07.tar.gz) = 41874
|
||||
|
|
|
@ -10,3 +10,15 @@ or "in", etc) and are the same as those used in TeX. The default unit is
|
|||
a bp, or a PostScript point, unlike TeX.
|
||||
|
||||
WWW: http://search.cpan.org/dist/PostScript-Simple/
|
||||
PostScript::Simple allows you to have a simple method of writing
|
||||
PostScript files from Perl. It has graphics primitives that allow lines,
|
||||
curves, circles, polygons and boxes to be drawn. Text can be added to
|
||||
the page using standard PostScript fonts.
|
||||
|
||||
The images can be single page EPS files, or multipage PostScript files.
|
||||
The image size can be set by using a recognised paper size ("A4", for
|
||||
example) or by giving dimensions. The units used can be specified ("mm"
|
||||
or "in", etc) and are the same as those used in TeX. The default unit is
|
||||
a bp, or a PostScript point, unlike TeX.
|
||||
|
||||
WWW: http://search.cpan.org/dist/PostScript-Simple/
|
||||
|
|
|
@ -1,3 +1,12 @@
|
|||
%%PERL5_MAN3%%/PostScript::Simple.3.gz
|
||||
%%PERL5_MAN3%%/PostScript::Simple::EPS.3.gz
|
||||
%%SITE_PERL%%/PostScript/Simple.pm
|
||||
%%SITE_PERL%%/PostScript/Simple/EPS.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/PostScript/Simple/.packlist
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PostScript/Simple
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PostScript
|
||||
@dirrmtry %%SITE_PERL%%/PostScript/Simple
|
||||
@dirrmtry %%SITE_PERL%%/PostScript
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/PostScript/Simple/.packlist
|
||||
%%SITE_PERL%%/PostScript/Simple.pm
|
||||
%%SITE_PERL%%/PostScript/Simple/EPS.pm
|
||||
|
|
|
@ -7,6 +7,22 @@ CATEGORIES= print perl5
|
|||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= perl@FreeBSD.org
|
||||
COMMENT= Produce PostScript files from Perl
|
||||
|
||||
USES= perl5
|
||||
USE_PERL5= configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
# Created by: Fernan Aguero <fernan.aguero@gmail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= PostScript
|
||||
PORTVERSION= 0.06
|
||||
CATEGORIES= print perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= perl@FreeBSD.org
|
||||
COMMENT= PostScript - Produce PostScript files from Perl
|
||||
|
||||
|
|
|
@ -1,2 +1,4 @@
|
|||
SHA256 (PostScript-0.06.tar.gz) = 64aa477ebf153710e4cd1251a0fa6f964ac34fcd3d9993e299e28064f9eec589
|
||||
SIZE (PostScript-0.06.tar.gz) = 19506
|
||||
SHA256 (PostScript-0.06.tar.gz) = 64aa477ebf153710e4cd1251a0fa6f964ac34fcd3d9993e299e28064f9eec589
|
||||
SIZE (PostScript-0.06.tar.gz) = 19506
|
||||
|
|
|
@ -2,3 +2,7 @@ PostScript allows you to write PostScript files from Perl.
|
|||
It has graphics primitives that allow lines, circles and boxes to be drawn.
|
||||
|
||||
WWW: http://search.cpan.org/dist/PostScript/
|
||||
PostScript allows you to write PostScript files from Perl.
|
||||
It has graphics primitives that allow lines, circles and boxes to be drawn.
|
||||
|
||||
WWW: http://search.cpan.org/dist/PostScript/
|
||||
|
|
|
@ -1,3 +1,15 @@
|
|||
%%PERL5_MAN3%%/PostScript::Elements.3.gz
|
||||
%%PERL5_MAN3%%/PostScript::Metrics.3.gz
|
||||
%%PERL5_MAN3%%/PostScript::TextBlock.3.gz
|
||||
%%SITE_PERL%%/PostScript/Document.pm
|
||||
%%SITE_PERL%%/PostScript/Elements.pm
|
||||
%%SITE_PERL%%/PostScript/Metrics.pm
|
||||
%%SITE_PERL%%/PostScript/TextBlock.pm
|
||||
%%SITE_PERL%%/PostScript/example.pl
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/PostScript/Metrics/.packlist
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PostScript/Metrics
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PostScript
|
||||
@dirrmtry %%SITE_PERL%%/PostScript
|
||||
%%SITE_PERL%%/PostScript/Document.pm
|
||||
%%SITE_PERL%%/PostScript/Elements.pm
|
||||
%%SITE_PERL%%/PostScript/TextBlock.pm
|
||||
|
|
Loading…
Reference in a new issue