Upgrade to 1.4.

PR:		3457 (plus many private mails)
Submitted by:	Sandro Sigala <ssigala@globalnet.it>
This commit is contained in:
Satoshi Asami 1997-06-15 10:07:12 +00:00
parent a077bdd1fe
commit 08aa64d648
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6940
5 changed files with 17 additions and 113 deletions

View file

@ -1,21 +1,20 @@
# New ports collection makefile for: cutils
# Version required: 1.3.2
# Version required: 1.4
# Date created: 26 November 1996
# Whom: Sandro Sigala
#
# $Id: Makefile,v 1.4 1996/12/24 11:11:43 max Exp $
# $Id: Makefile,v 1.5 1997/04/30 03:17:57 asami Exp $
#
DISTNAME= cutils-1.3.2
DISTNAME= cutils-1.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MAINTAINER= ssigala@globalnet.it
HAS_CONFIGURE= yes
MANCOMPRESSED= yes
GNU_CONFIGURE= yes
MAN1= cdecl.1 cundecl.1 chilight.1 cinfo.1 cinfoc.1 cinfodc.1 \
cobfusc.1 yyextract.1 yyref.1
cobfusc.1 cunloop.1 yyextract.1 yyref.1
MAN5= cinfodb.5
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (cutils-1.3.2.tar.gz) = 1d825b607cd22a7fdccb8c70be0c3c81
MD5 (cutils-1.4.tar.gz) = d024951fc4cc2ab5d83de6d2b580c116

View file

@ -1,104 +1,10 @@
--- ./src/cdecl/cdecl.c.org Thu Nov 14 07:27:45 1996
+++ ./src/cdecl/cdecl.c Tue Mar 25 03:11:57 1997
@@ -31,6 +31,10 @@
--- ./src/cinfo/cinfo/cinfo.c.org Wed Mar 26 05:58:10 1997
+++ ./src/cinfo/cinfo/cinfo.c Sun Jun 15 01:46:08 1997
@@ -31,6 +31,7 @@
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <string.h>
#include <err.h>
--- ./src/cinfo/cinfo/cinfo.c.org Thu Nov 14 07:27:49 1996
+++ ./src/cinfo/cinfo/cinfo.c Tue Mar 25 03:16:33 1997
@@ -32,6 +32,10 @@
#include <ctype.h>
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <string.h>
#include <err.h>
+#include <sys/types.h>
#include <dirent.h>
--- ./src/cinfo/cinfoc/cinfoc.c.org Tue Nov 26 06:55:25 1996
+++ ./src/cinfo/cinfoc/cinfoc.c Tue Mar 25 03:11:57 1997
@@ -31,6 +31,10 @@
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <string.h>
#include <unistd.h>
#include <err.h>
--- ./src/cinfo/cinfodc/cinfodc.c.org Tue Nov 26 06:55:26 1996
+++ ./src/cinfo/cinfodc/cinfodc.c Tue Mar 25 03:11:57 1997
@@ -31,6 +31,10 @@
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <err.h>
#include "version.h"
--- ./src/chilight/chilight.c.org Sun Dec 8 06:07:28 1996
+++ ./src/chilight/chilight.c Tue Mar 25 03:11:57 1997
@@ -31,6 +31,10 @@
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <string.h>
#include <err.h>
--- ./src/cundecl/cundecl.c.org Thu Nov 14 07:27:54 1996
+++ ./src/cundecl/cundecl.c Tue Mar 25 03:11:57 1997
@@ -31,6 +31,10 @@
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <string.h>
#include <err.h>
--- ./src/yyextract/yyextract.c.org Thu Nov 14 07:27:57 1996
+++ ./src/yyextract/yyextract.c Tue Mar 25 03:11:58 1997
@@ -31,6 +31,10 @@
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <string.h>
#include <err.h>
--- ./src/yyref/yyref.c.org Thu Nov 14 07:27:58 1996
+++ ./src/yyref/yyref.c Tue Mar 25 03:11:58 1997
@@ -31,6 +31,10 @@
#include <stdio.h>
#include <stdlib.h>
+/* needed for getopt() declarations */
+#if defined(__FreeBSD__) && __FreeBSD__ >= 3
+#include <unistd.h>
+#endif
#include <string.h>
#include <err.h>

View file

@ -5,12 +5,9 @@ cinfo, cinfoc and cinfodc - C language documentation tools
cdecl and cundecl - decode and encode C type declarations
cobfusc - make a C source file unreadable but compilable
chilight - highlight C source files with colors
cunloop - unloop C loops
yyextract - extract grammar rules from yacc grammar
yyref - yacc grammar reference program
Experimental stuff not compiled by default:
safealloc - simple malloc(), free() and friends checking utility
scc - Small C Compiler
Sandro Sigala
ssigala@globalnet.it

View file

@ -5,6 +5,7 @@ bin/cinfo
bin/cinfoc
bin/cinfodc
bin/cobfusc
bin/cunloop
bin/yyextract
bin/yyref
man/man1/cdecl.1.gz
@ -14,9 +15,10 @@ man/man1/cinfo.1.gz
man/man1/cinfoc.1.gz
man/man1/cinfodc.1.gz
man/man1/cobfusc.1.gz
man/man1/cunloop.1.gz
man/man1/yyextract.1.gz
man/man1/yyref.1.gz
man/man5/cinfodb.5.gz
lib/cinfo/stdc.cinfo.db
lib/cinfo/stdclib.cinfo.db
lib/cinfo/unix.cinfo.db
share/cutils/cinfo/stdc.cinfo.db
share/cutils/cinfo/stdclib.cinfo.db
share/cutils/cinfo/unix.cinfo.db