New port: cad/horizon-eda: EDA package for printed circuit board design
This commit is contained in:
parent
fc03c50eee
commit
08b224b002
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=544311
6 changed files with 72 additions and 0 deletions
|
@ -44,6 +44,7 @@
|
|||
SUBDIR += graywolf
|
||||
SUBDIR += gspiceui
|
||||
SUBDIR += gtkwave
|
||||
SUBDIR += horizon-eda
|
||||
SUBDIR += ifcopenshell
|
||||
SUBDIR += impact
|
||||
SUBDIR += irsim
|
||||
|
|
41
cad/horizon-eda/Makefile
Normal file
41
cad/horizon-eda/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= horizon-eda
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.2.1
|
||||
CATEGORIES= cad
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES= b40e3ed3f92c4b28af307135223ecf05eacecc82.patch:-p1 # backport the build failure fix
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= EDA package for printed circuit board design
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/boost/optional.hpp:devel/boost-libs \
|
||||
cppzmq>0:net/cppzmq \
|
||||
glm>0:math/glm
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||
libepoxy.so:graphics/libepoxy \
|
||||
libgit2.so:devel/libgit2 \
|
||||
libpodofo.so:graphics/podofo \
|
||||
libTKSTEP.so:cad/opencascade \
|
||||
libuuid.so:misc/e2fsprogs-libuuid \
|
||||
libzip.so:archivers/libzip \
|
||||
libzmq.so:net/libzmq4
|
||||
|
||||
USES= compiler:c++17-lang gmake gnome localbase pkgconfig python:build sqlite
|
||||
USE_GITHUB= yes
|
||||
GH_PROJECT= horizon
|
||||
USE_GNOME= atkmm gdkpixbuf2 gtkmm30 librsvg2
|
||||
|
||||
BINARY_ALIAS= python3=${PYTHON_CMD}
|
||||
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
post-install:
|
||||
cd ${STAGEDIR}${PREFIX}/bin && ${STRIP_CMD} horizon-imp horizon-eda
|
||||
|
||||
.include <bsd.port.mk>
|
5
cad/horizon-eda/distinfo
Normal file
5
cad/horizon-eda/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
TIMESTAMP = 1596747687
|
||||
SHA256 (horizon-eda-horizon-v1.2.1_GH0.tar.gz) = 3c0d66afeec55cf7fffbb25a467f7aac1576a5f93fec1f461d7f8a3e20072365
|
||||
SIZE (horizon-eda-horizon-v1.2.1_GH0.tar.gz) = 2933726
|
||||
SHA256 (b40e3ed3f92c4b28af307135223ecf05eacecc82.patch) = 3d0e9a50346931f842b856c0e1defaf6b6b9cce57ed134393f8e0bc9db1f22d3
|
||||
SIZE (b40e3ed3f92c4b28af307135223ecf05eacecc82.patch) = 795
|
11
cad/horizon-eda/files/patch-Makefile
Normal file
11
cad/horizon-eda/files/patch-Makefile
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.orig 2020-08-06 20:40:55 UTC
|
||||
+++ Makefile
|
||||
@@ -657,7 +657,7 @@ endif
|
||||
LIBS_ALL = $(LIBS_COMMON) gtkmm-3.0 epoxy cairomm-pdf-1.0 librsvg-2.0 libzmq libgit2 libcurl glm
|
||||
|
||||
OPTIMIZE = -fdata-sections -ffunction-sections
|
||||
-DEBUGFLAGS = -g3
|
||||
+#DEBUGFLAGS = -g3
|
||||
CXXFLAGS += $(DEBUGFLAGS) $(DEFINES) $(OPTIMIZE) $(shell $(PKG_CONFIG) --cflags $(LIBS_ALL)) -MP -MMD -pthread -Wall -Wshadow -std=c++17 -O3
|
||||
CFLAGS = $(filter-out -std=%,$(CXXFLAGS)) -std=c99
|
||||
LDFLAGS += -lm -lpthread
|
5
cad/horizon-eda/pkg-descr
Normal file
5
cad/horizon-eda/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
Horizon EDA is an Electronic Design Automation package supporting an integrated
|
||||
end-to-end workflow for printed circuit board design including parts management
|
||||
and schematic entry.
|
||||
|
||||
WWW: https://horizon-eda.org/
|
9
cad/horizon-eda/pkg-plist
Normal file
9
cad/horizon-eda/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/horizon-eda
|
||||
bin/horizon-imp
|
||||
share/applications/org.horizon_eda.HorizonEDA.desktop
|
||||
share/icons/hicolor/16x16/apps/org.horizon_eda.HorizonEDA.png
|
||||
share/icons/hicolor/256x256/apps/org.horizon_eda.HorizonEDA.png
|
||||
share/icons/hicolor/32x32/apps/org.horizon_eda.HorizonEDA.png
|
||||
share/icons/hicolor/64x64/apps/org.horizon_eda.HorizonEDA.png
|
||||
share/icons/hicolor/scalable/apps/org.horizon_eda.HorizonEDA.svg
|
||||
share/metainfo/org.horizon_eda.HorizonEDA.metainfo.xml
|
Loading…
Reference in a new issue