New port:
Barman: backup and recovery manager for PostgreSQL. Barman is an open-source administration tool for disaster recovery of PostgreSQL servers written in Python. It allows your organisation to perform remote backups of multiple servers in business critical environments and helps DBAs during the recovery phase. WWW: http://www.pgbarman.org/
This commit is contained in:
parent
0f1c879e37
commit
08e16cd8b2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=373768
6 changed files with 73 additions and 0 deletions
|
@ -536,6 +536,7 @@
|
|||
SUBDIR += pgadmin3
|
||||
SUBDIR += pgagent
|
||||
SUBDIR += pgbadger
|
||||
SUBDIR += pgbarman
|
||||
SUBDIR += pgbouncer
|
||||
SUBDIR += pgdbf
|
||||
SUBDIR += pgespresso
|
||||
|
|
43
databases/pgbarman/Makefile
Normal file
43
databases/pgbarman/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
# Created by: MAtthew Seaman
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= barman
|
||||
DISTVERSION= 1.3.3
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= SF/${PKGNAMEPREFIX}${PORTNAME}/${DISTVERSION}
|
||||
PKGNAMEPREFIX= pg
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} barman-tutorial.en.pdf
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= matthew@FreeBSD.org
|
||||
COMMENT= Backup and recovery manager for PostgreSQL
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync \
|
||||
${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2 \
|
||||
${PYTHON_PKGNAMEPREFIX}dateutil>=2.1:${PORTSDIR}/devel/py-dateutil \
|
||||
${PYTHON_PKGNAMEPREFIX}argh>0:${PORTSDIR}/devel/py-argh
|
||||
|
||||
USERS= barman
|
||||
GROUPS= barman
|
||||
|
||||
USES= python pgsql
|
||||
WANT_PGSQL= client
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
PORTDOCS= barman-tutorial.en.pdf
|
||||
|
||||
post-extract:
|
||||
${CP} ${DISTDIR}/${PORTDOCS} ${WRKDIR}/
|
||||
|
||||
post-patch:
|
||||
${SED} -i -e "s@%%PREFIX%%@${PREFIX}@" ${WRKSRC}/barman/config.py
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
|
||||
${MKDIR} ${STAGEDIR}${ETCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/barman.conf ${STAGEDIR}${ETCDIR}/barman.conf.sample
|
||||
|
||||
.include <bsd.port.mk>
|
4
databases/pgbarman/distinfo
Normal file
4
databases/pgbarman/distinfo
Normal file
|
@ -0,0 +1,4 @@
|
|||
SHA256 (barman-1.3.3.tar.gz) = 3e3af2fec16ac2836965a4c135d9ef4959ed690fb40ef06571d03ff526448468
|
||||
SIZE (barman-1.3.3.tar.gz) = 111462
|
||||
SHA256 (barman-tutorial.en.pdf) = f05666353ba61d8faeed70fcb32a6bc46fa4450dce6af9df462c2efeffad6734
|
||||
SIZE (barman-tutorial.en.pdf) = 276813
|
13
databases/pgbarman/files/patch-barman_config.py
Normal file
13
databases/pgbarman/files/patch-barman_config.py
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- barman/config.py.orig 2014-12-02 14:47:11 UTC
|
||||
+++ barman/config.py
|
||||
@@ -341,8 +341,8 @@ class Config(object):
|
||||
"""
|
||||
CONFIG_FILES = [
|
||||
'~/.barman.conf',
|
||||
- '/etc/barman.conf',
|
||||
- '/etc/barman/barman.conf',
|
||||
+ '%%PREFIX%%/etc/barman.conf',
|
||||
+ '%%PREFIX%%/etc/barman/barman.conf',
|
||||
]
|
||||
|
||||
_QUOTE_RE = re.compile(r"""^(["'])(.*)\1$""")
|
11
databases/pgbarman/pkg-descr
Normal file
11
databases/pgbarman/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
|
||||
Barman: backup and recovery manager for PostgreSQL.
|
||||
|
||||
Barman is an open-source administration tool for disaster recovery of
|
||||
PostgreSQL servers written in Python.
|
||||
|
||||
It allows your organisation to perform remote backups of multiple
|
||||
servers in business critical environments and helps DBAs during the
|
||||
recovery phase.
|
||||
|
||||
WWW: http://www.pgbarman.org/
|
1
databases/pgbarman/pkg-plist
Normal file
1
databases/pgbarman/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
@sample %%ETCDIR%%/barman.conf.sample
|
Loading…
Reference in a new issue