Add gtkjournal.
Gtk+ Journal is a Journal/Diary application written using the C++ bindings for Gtk+-2 (gtkmm). It uses SQlite to store your entries, and the OpenSSL implementations of the BlowFish and SHA-1 algorithms to keep your data safe.
This commit is contained in:
parent
036c49626a
commit
092fd95ac0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100345
6 changed files with 71 additions and 0 deletions
|
@ -39,6 +39,7 @@
|
|||
SUBDIR += gnotime
|
||||
SUBDIR += goats
|
||||
SUBDIR += gtimer
|
||||
SUBDIR += gtkjournal
|
||||
SUBDIR += gtodo
|
||||
SUBDIR += gucharmap
|
||||
SUBDIR += gworkspace
|
||||
|
|
35
deskutils/gtkjournal/Makefile
Normal file
35
deskutils/gtkjournal/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: gtkjournal
|
||||
# Date created: 08 February 2004
|
||||
# Whom: Adam Weinberger <adamw@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gtkjournal
|
||||
PORTVERSION= 0.3.4.pre1
|
||||
CATEGORIES= deskutils gnome
|
||||
MASTER_SITES= http://linuxhelp.homeunix.com/gtkjournal/files/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
|
||||
|
||||
MAINTAINER= adamw@FreeBSD.org
|
||||
COMMENT= Gtk+-2 journal/diary
|
||||
|
||||
LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2 \
|
||||
sqlite:${PORTSDIR}/databases/sqlite
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
USE_BZIP2= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_OPENSSL= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "54,\$$d" ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
2
deskutils/gtkjournal/distinfo
Normal file
2
deskutils/gtkjournal/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (gtkjournal-0.3.4pre1.tar.bz2) = c0b349138de08c64bca3387300d37a12
|
||||
SIZE (gtkjournal-0.3.4pre1.tar.bz2) = 24045
|
18
deskutils/gtkjournal/files/patch-Makefile
Normal file
18
deskutils/gtkjournal/files/patch-Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.orig Wed Feb 4 18:17:43 2004
|
||||
+++ Makefile Sun Feb 8 01:06:06 2004
|
||||
@@ -4,11 +4,11 @@
|
||||
## @version: 1.0
|
||||
##
|
||||
|
||||
-CXX = g++
|
||||
-PREFIX = /usr
|
||||
+#CXX = g++
|
||||
+#PREFIX = /usr
|
||||
INCLUDE = `pkg-config gtkmm-2.0 --cflags` -I./
|
||||
-LIBS = `pkg-config gtkmm-2.0 --libs` -lcrypto -lsqlite
|
||||
-CXXFLAGS = -pipe -ansi -pedantic
|
||||
+LIBS = ${LDFLAGS} `pkg-config gtkmm-2.0 --libs` -lcrypto -lsqlite
|
||||
+CXXFLAGS = ${CFLAGS} -pipe
|
||||
SRCS = gjournal/journalfile.cpp aolib/gui/informationdialog.cpp aolib/bfcryptfile.cpp sqlitem/sqlitemanager.cpp \
|
||||
sqlitem/sqliteresult.cpp aolib/gui/logindialog.cpp gjournal/globals.cpp gjournal/journalwindow.cpp aolib/datefuncs.cpp main.cpp
|
||||
OBJS = gjournal/journalfile.o aolib/gui/informationdialog.o aolib/bfcryptfile.o sqlitem/sqlitemanager.o \
|
10
deskutils/gtkjournal/files/patch-gjournal::journalwindow.hpp
Normal file
10
deskutils/gtkjournal/files/patch-gjournal::journalwindow.hpp
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- gjournal/journalwindow.hpp.orig Sun Feb 8 00:09:23 2004
|
||||
+++ gjournal/journalwindow.hpp Sun Feb 8 00:09:41 2004
|
||||
@@ -19,6 +19,7 @@
|
||||
#ifndef JOURNAL_WINDOW_HPP
|
||||
#define JOURNAL_WINDOW_HPP
|
||||
|
||||
+#include <libgen.h>
|
||||
#include <gtkmm.h>
|
||||
#include <iostream>
|
||||
#include <map>
|
5
deskutils/gtkjournal/pkg-descr
Normal file
5
deskutils/gtkjournal/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
Gtk+ Journal is a Journal/Diary application written using the C++ bindings for
|
||||
Gtk+-2 (gtkmm). It uses SQlite to store your entries, and the OpenSSL
|
||||
implementations of the BlowFish and SHA-1 algorithms to keep your data safe.
|
||||
|
||||
WWW: http://linuxhelp.homeunix.com/cgi-bin/rblh/index.rb?handler=downloads&d=GtkJournal
|
Loading…
Reference in a new issue