mail/mailagent: add missing patches in last commit
This commit is contained in:
parent
f3826383ab
commit
09409b4f1c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=358579
4 changed files with 79 additions and 0 deletions
20
mail/mailagent/files/patch-agent-examples-Makefile
Normal file
20
mail/mailagent/files/patch-agent-examples-Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- agent/examples/Makefile.orig 2014-06-20 11:31:53.597110451 -0300
|
||||
+++ agent/examples/Makefile 2014-06-20 11:32:15.393108703 -0300
|
||||
@@ -54,7 +54,7 @@
|
||||
install::
|
||||
@for dir in $(PRIVLIB)/examples; do \
|
||||
case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
|
||||
+ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
|
||||
done
|
||||
|
||||
deinstall::
|
||||
@@ -63,7 +63,7 @@
|
||||
install:: $(FILES)
|
||||
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
for i in $(FILES); do \
|
||||
- (set -x; $(INSTALL) -c -m 444 $$i $(PRIVLIB)/examples); \
|
||||
+ (set -x; $(INSTALL) -c -m 444 $$i $(INSTALL_PREFIX)$(PRIVLIB)/examples); \
|
||||
done
|
||||
|
||||
deinstall::
|
20
mail/mailagent/files/patch-agent-files-Makefile
Normal file
20
mail/mailagent/files/patch-agent-files-Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- agent/files/Makefile.orig 2014-06-20 11:29:40.559119965 -0300
|
||||
+++ agent/files/Makefile 2014-06-20 11:30:00.539568981 -0300
|
||||
@@ -58,7 +58,7 @@
|
||||
install::
|
||||
@for dir in $(PRIVLIB); do \
|
||||
case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
|
||||
+ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
|
||||
done
|
||||
|
||||
deinstall::
|
||||
@@ -67,7 +67,7 @@
|
||||
install:: $(FILES)
|
||||
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
for i in $(FILES); do \
|
||||
- (set -x; $(INSTALL) -c -m 444 $$i $(PRIVLIB)); \
|
||||
+ (set -x; $(INSTALL) -c -m 444 $$i $(INSTALL_PREFIX)$(PRIVLIB)); \
|
||||
done
|
||||
|
||||
deinstall::
|
20
mail/mailagent/files/patch-agent-files-help-Makefile
Normal file
20
mail/mailagent/files/patch-agent-files-help-Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- agent/files/help/Makefile.orig 2014-06-20 11:30:51.718114891 -0300
|
||||
+++ agent/files/help/Makefile 2014-06-20 11:31:10.122113536 -0300
|
||||
@@ -99,7 +99,7 @@
|
||||
install::
|
||||
@for dir in $(PRIVLIB) $(PRIVLIB)/help; do \
|
||||
case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
|
||||
+ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
|
||||
done
|
||||
|
||||
deinstall::
|
||||
@@ -108,7 +108,7 @@
|
||||
install:: $(FILES)
|
||||
@case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
for i in $(FILES); do \
|
||||
- (set -x; $(INSTALL) -c -m 444 $$i $(PRIVLIB)/help); \
|
||||
+ (set -x; $(INSTALL) -c -m 444 $$i $(INSTALL_PREFIX)$(PRIVLIB)/help); \
|
||||
done
|
||||
|
||||
deinstall::
|
19
mail/mailagent/files/patch-agent-filter-Makefile
Normal file
19
mail/mailagent/files/patch-agent-filter-Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- agent/filter/Makefile.orig 2014-06-20 11:27:19.802128926 -0300
|
||||
+++ agent/filter/Makefile 2014-06-20 11:29:16.092184615 -0300
|
||||
@@ -124,14 +124,14 @@
|
||||
install::
|
||||
@for dir in $(PRIVLIB); do \
|
||||
case '${MFLAGS}' in *[i]*) set +e;; esac; \
|
||||
- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
|
||||
+ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
|
||||
done
|
||||
|
||||
deinstall::
|
||||
$(RM) -r $(PRIVLIB)
|
||||
|
||||
install:: filter
|
||||
- $(INSTALL) -c -s -m 555 filter $(PRIVLIB)
|
||||
+ $(INSTALL) -c -s -m 555 filter $(INSTALL_PREFIX)$(PRIVLIB)
|
||||
|
||||
deinstall::
|
||||
$(RM) $(PRIVLIB)/filter
|
Loading…
Reference in a new issue