o support Compaq C on Alpha.

PR:		30162
Submitted by:	maintainer

o remove extra empty directory.
This commit is contained in:
FUJISHIMA Satsuki 2001-09-24 21:10:28 +00:00
parent 76e2cc16db
commit 09cb637473
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48166
4 changed files with 62 additions and 0 deletions

View file

@ -0,0 +1,22 @@
$FreeBSD$
--- configure.in.orig Sun Jul 22 19:43:15 2001
+++ configure.in Tue Aug 28 17:00:19 2001
@@ -136,13 +136,13 @@
AC_SUBST(FLaC__USIZE64)
SAVE_CFLAGS="$CFLAGS"
-CFLAGS='-I$(top_builddir) -I$(srcdir)/include -I $(top_srcdir)/include -Wall -W'
+CFLAGS='-I$(top_builddir) -I$(srcdir)/include -I $(top_srcdir)/include'
if test x$debug = xtrue; then
CFLAGS="$CFLAGS -g -O0 -DDEBUG"
else
- CFLAGS="$CFLAGS -O3 -DNDEBUG"
+ CFLAGS="$CFLAGS -DNDEBUG"
if test x$GCC = xyes; then
- CFLAGS="$CFLAGS -fomit-frame-pointer -funroll-loops -finline-functions -Winline -DFLaC__INLINE=__inline__"
+ CFLAGS="$CFLAGS -DFLaC__INLINE=__inline__"
fi
fi
CFLAGS="$CFLAGS $SAVE_CFLAGS"

View file

@ -0,0 +1,12 @@
$FreeBSD$
--- src/flac/Makefile.am.orig Tue Aug 28 15:58:11 2001
+++ src/flac/Makefile.am Tue Aug 28 15:58:19 2001
@@ -29,5 +29,4 @@
encode.h \
file.h
-flac_LDFLAGS = -lm
-flac_LDADD = $(top_builddir)/src/libFLAC/libFLAC.la
+flac_LDADD = $(top_builddir)/src/libFLAC/libFLAC.la -lm

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- src/test_streams/Makefile.am.orig Tue Aug 28 16:00:17 2001
+++ src/test_streams/Makefile.am Tue Aug 28 16:00:28 2001
@@ -20,6 +20,6 @@
noinst_PROGRAMS = test_streams
test_streams_SOURCES = \
main.c
-test_streams_LDFLAGS = -lm
+test_streams_LDADD = -lm
CLEANFILES = $(wildcard *.raw)

View file

@ -0,0 +1,15 @@
$FreeBSD$
--- src/test_unit/Makefile.am.orig Tue Aug 28 16:21:54 2001
+++ src/test_unit/Makefile.am Tue Aug 28 16:22:05 2001
@@ -19,8 +19,7 @@
INCLUDES = -I$(top_srcdir)/src/libFLAC/include
noinst_PROGRAMS = test_unit
-test_unit_LDFLAGS = -lm
-test_unit_LDADD = $(top_builddir)/src/libFLAC/libFLAC.la
+test_unit_LDADD = $(top_builddir)/src/libFLAC/libFLAC.la -lm
test_unit_SOURCES = \
bitbuffer.c \
main.c \