- Fix foomaticrip to use correct location for pdftops

- Bump PORTREV
This commit is contained in:
Kris Moore 2014-05-19 18:06:13 +00:00
parent 9221b33bbc
commit 09dd54b92c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=354566
2 changed files with 23 additions and 4 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= foomatic-filters
PORTVERSION= 4.0.17
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/foomatic/
@ -72,6 +72,7 @@ RUN_DEPENDS+= mpage:${PORTSDIR}/print/mpage
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|${SH}|g' ${WRKSRC}/foomaticrip.c
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/foomaticrip.c
@${REINPLACE_CMD} -e '/filter.conf/ s|if|#if|g' ${WRKSRC}/Makefile.in
post-install:

View file

@ -1,6 +1,24 @@
--- foomaticrip.c.orig 2014-04-26 11:32:42.578342305 +0400
+++ foomaticrip.c 2014-04-26 11:44:16.016294870 +0400
@@ -1197,7 +1197,8 @@ int main(int argc, char** argv)
--- foomaticrip.c.orig 2012-07-02 10:50:46.000000000 -0400
+++ foomaticrip.c 2014-05-19 10:28:46.588515788 -0400
@@ -180,7 +180,7 @@
"/opt/cups/filter:"
"/usr/lib/cups/filter";
-char modern_shell[64] = "/bin/bash";
+char modern_shell[64] = "/bin/sh";
void config_set_option(const char *key, const char *value)
{
@@ -1061,7 +1061,7 @@
Ghostscript is not available. */
if (spooler == SPOOLER_CUPS)
snprintf(pdf2ps_cmd, PATH_MAX,
- "pdftops '%s' '%s' '%s' '%s' '%s' '%s'",
+ "%%LOCALBASE%%/libexec/cups/filter/pdftops '%s' '%s' '%s' '%s' '%s' '%s'",
job->id, job->user, job->title, "1", job->optstr->data,
filename);
else
@@ -1197,7 +1197,8 @@
debug = 1;
if (debug) {