Add a patch for vga_cursor.
This commit is contained in:
parent
183c9d8b3d
commit
0a549fc8d6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=27282
3 changed files with 121 additions and 6 deletions
|
@ -1,6 +1,16 @@
|
|||
--- src/vga.c.orig Sun Jan 26 18:05:00 1997
|
||||
+++ src/vga.c Mon Jan 31 14:09:55 2000
|
||||
@@ -382,7 +382,7 @@
|
||||
--- src/vga.c.orig Sun Apr 14 16:40:40 1996
|
||||
+++ src/vga.c Sun Apr 2 19:03:41 2000
|
||||
@@ -205,7 +205,8 @@
|
||||
regText.seq[i] = PortInb(VGASEQ_DATA);
|
||||
}
|
||||
regText.mis = PortInb(VGAMISC_IN);
|
||||
-
|
||||
+
|
||||
+ PortOutb(PortInb(VGAMISC_IN)|0x01, VGAMISC_OUT);
|
||||
VgaSetRegisters(®Graph);
|
||||
|
||||
/* save font data in plane 2 */
|
||||
@@ -369,7 +370,7 @@
|
||||
/* if (!code) return;*/
|
||||
VgaSetColor(fc);
|
||||
if (bc & 0x8) *(vcls - dInfo.glineByte) = 0;
|
||||
|
@ -9,9 +19,18 @@
|
|||
if (*code) {
|
||||
VgaOutByte(*code);
|
||||
*gram = *gram;
|
||||
@@ -620,7 +620,11 @@
|
||||
Perror("ioctl CONSOLE_IO_ENABLE");
|
||||
return FAILURE;
|
||||
@@ -437,7 +438,7 @@
|
||||
|
||||
void VgaCursor(struct cursorInfo *ci)
|
||||
{
|
||||
- char *gram;
|
||||
+ volatile char *gram;
|
||||
u_char x;
|
||||
int bottom = cursorBtm + 1 <= dInfo.glineChar ?
|
||||
cursorBtm + 1 : dInfo.glineChar;
|
||||
@@ -607,7 +608,11 @@
|
||||
Perror("ioctl CONSOLE_IO_ENABLE");
|
||||
return FAILURE;
|
||||
}
|
||||
+#if (__FreeBSD__ <= 3)
|
||||
if ((devMem = open("/dev/vga", O_RDWR|O_NDELAY) ) < 0) {
|
||||
|
|
22
chinese/big5con/files/patch-ag
Normal file
22
chinese/big5con/files/patch-ag
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- big5con.cfg.orig Sun Apr 2 18:43:27 2000
|
||||
+++ big5con.cfg Sun Apr 2 18:43:42 2000
|
||||
@@ -157,7 +157,7 @@
|
||||
1200
|
||||
# Mouse device file name
|
||||
MouseDev:
|
||||
- /dev/mouse
|
||||
+ /dev/sysmouse
|
||||
|
||||
# Use hard scroll
|
||||
HardScroll:
|
||||
--- big5con.mk.orig Sun Apr 2 18:43:25 2000
|
||||
+++ big5con.mk Sun Apr 2 18:43:35 2000
|
||||
@@ -29,7 +29,7 @@
|
||||
-DXCIN_DIR=\"$(XCIN_DIR)\" $(ALT_META) $(EXTRA_OPTS)
|
||||
CC = gcc
|
||||
#CFLAGS = -O2 -m486 $(OPTS)
|
||||
-CFLAGS += -O2 $(OPTS)
|
||||
+CFLAGS += $(OPTS)
|
||||
LD = gcc $(CFLAGS)
|
||||
RM = rm -f
|
||||
INSTALL = install -c
|
74
chinese/big5con/files/patch-ah
Normal file
74
chinese/big5con/files/patch-ah
Normal file
|
@ -0,0 +1,74 @@
|
|||
--- lib/coding.c.orig Sun Apr 2 18:56:03 2000
|
||||
+++ lib/coding.c Sun Apr 2 18:56:36 2000
|
||||
@@ -140,13 +140,13 @@
|
||||
|
||||
i = 0;
|
||||
while (fSRegs[i].registry) {
|
||||
- if (!strcasecmp(fSRegs[i].registry, reg))
|
||||
+ if (!strncasecmp(fSRegs[i].registry, reg, strlen(reg)))
|
||||
return(i|CHR_SFLD);
|
||||
i ++;
|
||||
}
|
||||
i = 0;
|
||||
while (fDRegs[i].registry) {
|
||||
- if (!strcasecmp(fDRegs[i].registry, reg))
|
||||
+ if (!strncasecmp(fDRegs[i].registry, reg, strlen(reg)))
|
||||
return(i|CHR_DFLD);
|
||||
i ++;
|
||||
}
|
||||
--- lib/font.c.orig Sun Apr 2 18:56:50 2000
|
||||
+++ lib/font.c Sun Apr 2 18:57:54 2000
|
||||
@@ -35,6 +35,7 @@
|
||||
struct shmid_ds shmseg;
|
||||
|
||||
shmkey = ftok(CONFIG_NAME, fnum);
|
||||
+ shmkey = 5000 + (fnum & 0x7F);
|
||||
if ((shmid = shmget(shmkey, sizeof(struct fontInfo), 0444)) < 0)
|
||||
return;
|
||||
shmctl(shmid, IPC_STAT, &shmseg);
|
||||
@@ -50,6 +51,7 @@
|
||||
int shmid;
|
||||
|
||||
shmkey = ftok(CONFIG_NAME, fnum);
|
||||
+ shmkey = 5000 + (fnum & 0x7F);
|
||||
if ((shmid = shmget(shmkey, sizeof(struct fontInfo), 0444)) < 0) return(0);
|
||||
return((u_char*)shmat(shmid, 0, SHM_RDONLY));
|
||||
}
|
||||
--- fld/fld.c.orig Sun Apr 2 18:59:37 2000
|
||||
+++ fld/fld.c Sun Apr 2 19:01:18 2000
|
||||
@@ -55,7 +55,7 @@
|
||||
int shmid;
|
||||
struct shmid_ds shmseg;
|
||||
|
||||
- shmkey = ftok(CONFIG_NAME, fnum);
|
||||
+ shmkey = 5000 + (fnum & 0x7F);
|
||||
if ((shmid = shmget(shmkey, sizeof(struct fontInfo), 0444)) < 0)
|
||||
return;
|
||||
shmctl(shmid, IPC_STAT, &shmseg);
|
||||
@@ -70,7 +70,7 @@
|
||||
extern int forceLoad;
|
||||
|
||||
if (forceLoad) return(EOF);
|
||||
- shmkey = ftok(SHMEM_NAME, fnum);
|
||||
+ shmkey = 5000 + (fnum & 0x7F);
|
||||
if (shmget(shmkey, 1, 0444) == EOF) return(EOF);
|
||||
return(0);
|
||||
}
|
||||
@@ -82,7 +82,7 @@
|
||||
int shmid;
|
||||
u_char *shmbuff;
|
||||
|
||||
- shmkey = ftok(SHMEM_NAME, fi->type);
|
||||
+ shmkey = 5000 + (fi->type & 0x0000007F);
|
||||
shmid = shmget(shmkey, fi->size+sizeof(struct fontInfo),
|
||||
IPC_CREAT|0666);
|
||||
fprintf( stderr,"%ld\n",fi->size+sizeof(struct fontInfo) );
|
||||
@@ -120,7 +120,7 @@
|
||||
int shmid;
|
||||
struct fontInfo *fi;
|
||||
|
||||
- shmkey = ftok(CONFIG_NAME, fnum);
|
||||
+ shmkey = 5000 + (fnum & 0x7F);
|
||||
if ((shmid = shmget(shmkey, sizeof(struct fontInfo), 0444)) < 0)
|
||||
return(0);
|
||||
fi = (struct fontInfo*)shmat(shmid, 0, SHM_RDONLY);
|
Loading…
Reference in a new issue