Add fusefs-unionfs 0.14, FUSE based implementation of the well-known
unionfs. PR: ports/100382 Submitted by: Gea-Suan Lin <gslin at gslin.org>
This commit is contained in:
parent
315060a534
commit
0a5d49084a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168042
5 changed files with 66 additions and 0 deletions
|
@ -187,6 +187,7 @@
|
|||
SUBDIR += fusefs-kmod
|
||||
SUBDIR += fusefs-libs
|
||||
SUBDIR += fusefs-sshfs
|
||||
SUBDIR += fusefs-unionfs
|
||||
SUBDIR += fusefs-wdfs
|
||||
SUBDIR += fuser
|
||||
SUBDIR += fvcool
|
||||
|
|
40
sysutils/fusefs-unionfs/Makefile
Normal file
40
sysutils/fusefs-unionfs/Makefile
Normal file
|
@ -0,0 +1,40 @@
|
|||
# New ports collection makefile for: fusefs-unionfs
|
||||
# Date created: 2006-07-16
|
||||
# Whom: Gea-Suan Lin <gslin@gslin.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= unionfs
|
||||
PORTVERSION= 0.14
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://podgorny.cz/unionfs-fuse/releases/
|
||||
PKGNAMEPREFIX= fusefs-
|
||||
DISTNAME= unionfs-fuse-${PORTVERSION}
|
||||
|
||||
MAINTAINER= gslin@gslin.org
|
||||
COMMENT= FUSE based implementation of the well-known unionfs
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
|
||||
|
||||
PLIST_FILES= bin/unionfs
|
||||
|
||||
USE_BZIP2= yes
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC} && \
|
||||
${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
|
||||
-D_FILE_OFFSET_BITS=64 -DFUSE_USE_VERSION=25 \
|
||||
-o unionfs *.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse)
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/unionfs ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 600000 # Inherited from fusefs-kmod
|
||||
IGNORE= requires FreeBSD 6.x or above
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
sysutils/fusefs-unionfs/distinfo
Normal file
3
sysutils/fusefs-unionfs/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (unionfs-fuse-0.14.tar.bz2) = 7730e9b99830f50a2c8f884e5a8c0870
|
||||
SHA256 (unionfs-fuse-0.14.tar.bz2) = dd32cd853e650c742f87ee5f4aa92892e74add38e72bf9b518dec6783249fe0d
|
||||
SIZE (unionfs-fuse-0.14.tar.bz2) = 6025
|
16
sysutils/fusefs-unionfs/files/patch-unionfs.c
Normal file
16
sysutils/fusefs-unionfs/files/patch-unionfs.c
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- unionfs.c.orig Sun Jul 16 19:02:07 2006
|
||||
+++ unionfs.c Sun Jul 16 19:05:45 2006
|
||||
@@ -189,9 +189,13 @@
|
||||
if (stats_enabled && strcmp(path, STATS_FILENAME) == 0) return 0;
|
||||
|
||||
int res;
|
||||
+#if FUSE_USE_VERSION >= 26
|
||||
if (isdatasync) {
|
||||
res = fdatasync(fi->fh);
|
||||
} else {
|
||||
+#else
|
||||
+ {
|
||||
+#endif
|
||||
res = fsync(fi->fh);
|
||||
}
|
||||
|
6
sysutils/fusefs-unionfs/pkg-descr
Normal file
6
sysutils/fusefs-unionfs/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
This is my effort to create a unionfs filesystem implementation which
|
||||
is probably slower but way more flexible than the current in-kernel
|
||||
unionfs solution. Currently it's almost fully usable, the only problem
|
||||
is new file/directory creation which I will fix soon...
|
||||
|
||||
WWW: http://podgorny.cz/moin/UnionFsFuse
|
Loading…
Reference in a new issue