add an optional patch which reverses the mouse workspace changing

direction.

PR:		ports/113269
Submitted by:	ehaupt
This commit is contained in:
Oliver Lehmann 2007-06-19 04:53:44 +00:00
parent 9fdd561279
commit 0a9efdebd9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=193842
3 changed files with 23 additions and 3 deletions

View file

@ -18,7 +18,7 @@ COMMENT= XFce 4 window manager
CONFIGURE_ARGS= --enable-xinerama
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@ -29,7 +29,8 @@ USE_XFCE= configenv libmcs libutil libgui mcsmanager panel
USE_XLIB= yes
OPTIONS= COMPOSITE "Support the experimental X11 Composite extension" on \
STARTUP "Enable startup notification support" on
STARTUP "Enable startup notification support" on \
REVMOUSE "Reverse mouse workspace changing direction" off
.include <bsd.port.pre.mk>
@ -46,6 +47,10 @@ CONFIGURE_ARGS+=--enable-startup-notification
CONFIGURE_ARGS+=--disable-startup-notification
.endif
.if defined(WITH_REVMOUSE)
EXTRA_PATCHES= ${FILESDIR}/extrapatch-src__events.c
.endif
post-patch:
@${REINPLACE_CMD} -e 's|\(#define ShapeInput 2\);|\1|' \
${WRKSRC}/src/frame.c

View file

@ -0,0 +1,16 @@
--- src/events.c.orig Mon Apr 2 21:48:20 2007
+++ src/events.c Tue Jun 19 06:49:58 2007
@@ -860,11 +860,11 @@
if (ev->button == Button4)
{
- workspaceSwitch (screen_info, screen_info->current_ws - 1, NULL, TRUE, ev->time);
+ workspaceSwitch (screen_info, screen_info->current_ws + 1, NULL, TRUE, ev->time);
}
else if (ev->button == Button5)
{
- workspaceSwitch (screen_info, screen_info->current_ws + 1, NULL, TRUE, ev->time);
+ workspaceSwitch (screen_info, screen_info->current_ws - 1, NULL, TRUE, ev->time);
}
}

View file

@ -1320,4 +1320,3 @@ share/xfwm4/defaults
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable
@dirrmtry share/themes