Update skkinput3 to 3.0_1 after a repocopy from japanese/skkinput.
PR: ports/41808 Submitted by: KOMATSU Shinichiro <koma2@jiro.c.u-tokyo.ac.jp>
This commit is contained in:
parent
d4831b3f42
commit
0ad0d6fd2a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66249
11 changed files with 79 additions and 169 deletions
|
@ -347,6 +347,7 @@
|
|||
SUBDIR += skk10-elisp-emacs20
|
||||
SUBDIR += skkfep
|
||||
SUBDIR += skkinput
|
||||
SUBDIR += skkinput3
|
||||
SUBDIR += skkserv
|
||||
SUBDIR += slirc
|
||||
SUBDIR += slrn
|
||||
|
|
|
@ -1,31 +1,46 @@
|
|||
# New ports collection makefile for: skkinput
|
||||
# Date created: 28 Jan 1998
|
||||
# Whom: Murata Shuuichirou <mrt@mickey.ai.kyutech.ac.jp>
|
||||
# New ports collection makefile for: skkinput3
|
||||
# Date created: Aug 14 2002
|
||||
# Whom: KOMATSU Shinichiro <koma2@jiro.c.u-tokyo.ac.jp>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= skkinput
|
||||
PORTVERSION= 2.03
|
||||
PORTNAME= skkinput3
|
||||
PORTVERSION= ${SRCVERSION}.${PATCHLEVEL}
|
||||
CATEGORIES= japanese x11
|
||||
MASTER_SITES= http://member.nifty.ne.jp/Tatari_SAKAMOTO/
|
||||
MASTER_SITES= http://downloads.sourceforge.jp/skkinput3/857/
|
||||
DISTNAME= skkinput-${SRCVERSION}_${PATCHLEVEL}
|
||||
|
||||
MAINTAINER= yasuf@big.or.jp
|
||||
MAINTAINER= koma2@jiro.c.u-tokyo.ac.jp
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/sbin/skkserv:${PORTSDIR}/japanese/skkserv
|
||||
USE_IMAKE= yes
|
||||
|
||||
USE_IMAKE= yes
|
||||
MANLANG= ja
|
||||
MAN1= skkinput.1
|
||||
MANCOMPRESSED= yes
|
||||
NO_INSTALL_MANPAGES= yes
|
||||
|
||||
DOCS= *.jis skkinput.doc myeval/skkinputlisp.doc dot.skkinput
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/skkinput
|
||||
@( cd ${WRKSRC} ; \
|
||||
${INSTALL_DATA} ${DOCS} ${PREFIX}/share/doc/skkinput )
|
||||
# sanity check
|
||||
.if defined(WITH_DBSKKD) && defined(WITH_RSKKSERV)
|
||||
.error Cannot define both WITH_DBSKKD and WITH_RSKKSERV simultaneously.
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.if defined(WITH_DBSKKD) || exists(${LOCALBASE}/libexec/dbskkd-cdb) && !defined(WITH_RSKKSERV)
|
||||
RUN_DEPENDS= ${LOCALBASE}/libexec/dbskkd-cdb:${PORTSDIR}/japanese/dbskkd-cdb
|
||||
.elif defined(WITH_RSKKSERV) || exists(${LOCALBASE}/libexec/rskkserv) && !defined(WITH_DBSKKD)
|
||||
RUN_DEPENDS= ${LOCALBASE}/libexec/rskkserv:${PORTSDIR}/japanese/rskkserv
|
||||
.else
|
||||
RUN_DEPENDS= ${LOCALBASE}/sbin/skkserv:${PORTSDIR}/japanese/skkserv
|
||||
.endif
|
||||
|
||||
SRCVERSION= 3.0
|
||||
PATCHLEVEL= 1
|
||||
|
||||
DOCS= *.jis dot.skkinput
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC}; ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (skkinput-2.03.tar.gz) = 74c08620e8e916a3d56f3bb3e85a5d62
|
||||
MD5 (skkinput-3.0_1.tar.gz) = 5c082ae83bf6dd0b806cdad98b1ae6af
|
||||
|
|
13
japanese/skkinput3/files/patch-Imakefile
Normal file
13
japanese/skkinput3/files/patch-Imakefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Imakefile.orig Sun Jul 21 02:47:26 2002
|
||||
+++ Imakefile Wed Aug 14 15:48:59 2002
|
||||
@@ -23,8 +23,8 @@
|
||||
SRCS = main.c
|
||||
OBJS = main.o
|
||||
|
||||
-ComplexProgramTarget(skkinput)
|
||||
-InstallAppDefaults(Skkinput)
|
||||
+ComplexProgramTargetNoMan(skkinput3)
|
||||
+/* InstallAppDefaults(Skkinput) */
|
||||
|
||||
ELISP_FILES = init.el skk.el skk-startup.el skk-trial.el
|
||||
|
15
japanese/skkinput3/files/patch-Skkinput.conf
Normal file
15
japanese/skkinput3/files/patch-Skkinput.conf
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- Skkinput.conf.orig Sat Aug 10 00:47:48 2002
|
||||
+++ Skkinput.conf Wed Aug 14 15:54:45 2002
|
||||
@@ -1,10 +1,10 @@
|
||||
/* skk.el, init.el install directory
|
||||
*/
|
||||
-ELISP_DIR = $(LIBDIR)/skkinput
|
||||
+ELISP_DIR = $(LIBDIR)/skkinput3
|
||||
|
||||
/* Skkinput3 Window uses these fonts.
|
||||
*/
|
||||
-#define Default_FontSet -*-fixed-medium-r-normal--16-*-*-*-*-*-iso8859-1,-misc-fixed-medium-r-normal--16-*-*-*-*-*-jisx0201.1976-0,-misc-fixed-medium-r-normal--16-*-*-*-*-*-jisc6226.1978-0,-misc-fixed-medium-r-normal--16-*-*-*-*-*-jisx0208.1983-0,-misc-fixed-medium-r-normal--16-*-*-*-*-*-jisx0212.1990-0
|
||||
+#define Default_FontSet -alias-fixed-medium-r-normal--16-*-*-*-*-*-iso8859-1,-*-fixed-medium-r-normal--16-*-*-*-*-*-iso8859-1,-alias-fixed-medium-r-normal--16-*-*-*-*-*-jisx0201.1976-0,-*-fixed-medium-r-normal--16-*-*-*-*-*-jisx0201.1976-0,-alias-fixed-medium-r-normal--16-*-*-*-*-*-jisx0208.1983-0,-*-fixed-medium-r-normal--16-*-*-*-*-*-jisx0208.1983-0,-alias-fixed-medium-r-normal--16-*-*-*-*-*-jisx0213.2000-1,-*-fixed-medium-r-normal--16-*-*-*-*-*-jisx0213.2000-1
|
||||
|
||||
/* Skkinput3 supports these protocols:
|
||||
*/
|
|
@ -1,10 +0,0 @@
|
|||
--- Imakefile.org Wed Jan 28 19:19:42 1998
|
||||
+++ Imakefile Wed Jan 28 19:19:55 1998
|
||||
@@ -1,5 +1,7 @@
|
||||
XCOMM $ Imakefile for skkinput,v 0.10 96/10/16 12:45 $
|
||||
|
||||
+MANDIR = ${PREFIX}/man/ja/man1
|
||||
+
|
||||
/* SKK Server Address */
|
||||
#define SkkServer localhost
|
||||
|
|
@ -1,111 +0,0 @@
|
|||
--- imattr.c.orig Tue Mar 3 20:58:22 1998
|
||||
+++ imattr.c Fri Mar 19 14:24:12 1999
|
||||
@@ -127,6 +127,11 @@
|
||||
static int getFontSet( IMIC *, unsigned int, int, int, char *, int ) ;
|
||||
static int getLineSpace( IMIC *, unsigned int, int, int, char *, int ) ;
|
||||
static int getCursor( IMIC *, unsigned int, int, int, char *, int ) ;
|
||||
+
|
||||
+#ifndef ORIGINAL
|
||||
+static int setFilterEvents( IMIC *, char *, int, int, int, int );
|
||||
+static int getFilterEvents( IMIC *, unsigned int, int, int, char *, int );
|
||||
+#endif
|
||||
|
||||
static ICAttribute icAttributes[] = {
|
||||
{ XNInputStyle, TYPE_CARD32, OP_C|OP_G,
|
||||
@@ -135,6 +140,8 @@
|
||||
setClientWindow, getClientWindow },
|
||||
{ XNFocusWindow, TYPE_WINDOW, OP_C|OP_S|OP_G,
|
||||
setFocusWindow, getFocusWindow },
|
||||
+ { XNFilterEvents, TYPE_CARD32, OP_C|OP_S|OP_G,
|
||||
+ setFilterEvents, getFilterEvents },
|
||||
{ XNPreeditAttributes, TYPE_NESTED_LIST, OP_C|OP_S|OP_G,
|
||||
setPreeditAttributes, getPreeditAttributes },
|
||||
{ XNStatusAttributes, TYPE_NESTED_LIST, OP_C|OP_S|OP_G,
|
||||
@@ -495,6 +502,26 @@
|
||||
return 0 ;
|
||||
}
|
||||
|
||||
+#ifndef ORIGINAL
|
||||
+/* ARGSUSED */
|
||||
+static int
|
||||
+setFilterEvents
|
||||
+( IMIC *icp, char *value, int len, int order, int nest, int op )
|
||||
+{
|
||||
+ unsigned long filter_events;
|
||||
+
|
||||
+ CHECK_ICATTR_SIZE(4, IMBadSomething);
|
||||
+
|
||||
+ filter_events = (unsigned long)getC32(value, order);
|
||||
+
|
||||
+ if (!(icp->common_attr.set_mask & ATTR_MASK_FILTER_EVENTS) ||
|
||||
+ filter_events != icp->common_attr.filter_events) {
|
||||
+ icp->common_attr.change_mask |= ATTR_MASK_FILTER_EVENTS;
|
||||
+ }
|
||||
+ return 0;
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
/* ARGSUSED */
|
||||
static int setPreeditAttributes
|
||||
( IMIC *icp, char *value, int len, int order, int nest, int op )
|
||||
@@ -1061,6 +1088,35 @@
|
||||
}
|
||||
}
|
||||
|
||||
+#ifndef ORIGINAL
|
||||
+/* ARGSUSED */
|
||||
+static int
|
||||
+getFilterEvents
|
||||
+( IMIC *icp, unsigned int id, int nest, int offset,
|
||||
+ char *data, int len )
|
||||
+{
|
||||
+ IMConnection *conn = icp->im->connection;
|
||||
+
|
||||
+ if (!(icp->common_attr.set_mask & ATTR_MASK_FILTER_EVENTS)) {
|
||||
+ /* fill default value */
|
||||
+ fillCommonDefault(icp, (unsigned long)ATTR_MASK_FILTER_EVENTS);
|
||||
+ }
|
||||
+
|
||||
+ if (icp->common_attr.set_mask & ATTR_MASK_FILTER_EVENTS) {
|
||||
+ IMPutC16(conn, id); /* attribute ID */
|
||||
+ IMPutC16(conn, 4); /* value length */
|
||||
+ IMPutC32(conn, icp->common_attr.filter_events);
|
||||
+ }
|
||||
+ else {
|
||||
+ /* no default is available */
|
||||
+ IMCancelRequest(conn, offset);
|
||||
+ IMSendError(conn, IMBadSomething, icp->im->id, icp->id,
|
||||
+ "filter events not specified yet");
|
||||
+ return -1;
|
||||
+ }
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
/* ARGSUSED */
|
||||
static int getArea
|
||||
( IMIC *icp, unsigned int id, int nest,
|
||||
@@ -1383,6 +1439,12 @@
|
||||
icp->focus_profile = icp->client_profile ;
|
||||
}
|
||||
}
|
||||
+#ifndef ORIGINAL
|
||||
+ if (mask & ATTR_MASK_FILTER_EVENTS) {
|
||||
+ ap->filter_events = NoEventMask;
|
||||
+ ap->set_mask |= ATTR_MASK_FILTER_EVENTS;
|
||||
+ }
|
||||
+#endif
|
||||
}
|
||||
|
||||
static int getNaturalLineSpace( IMIC *icp )
|
||||
@@ -1520,6 +1582,11 @@
|
||||
SENDERROR( IMBadFocusWindow, "invalid focus window ID" ) ;
|
||||
}
|
||||
}
|
||||
+#ifndef ORIGINAL
|
||||
+ if (mask & ATTR_MASK_FILTER_EVENTS) {
|
||||
+ SENDERROR(IMBadSomething, "filter events not support");
|
||||
+ }
|
||||
+#endif
|
||||
|
||||
return ret ;
|
||||
#undef SENDERROR
|
|
@ -1,13 +0,0 @@
|
|||
--- im.h.orig Tue Mar 3 21:08:33 1998
|
||||
+++ im.h Fri Mar 19 14:10:22 1999
|
||||
@@ -148,6 +148,10 @@
|
||||
XIMStyle input_style ;
|
||||
Window client ; /* client window */
|
||||
Window focus ; /* focus window */
|
||||
+#ifndef ORIGINAL
|
||||
+#define ATTR_MASK_FILTER_EVENTS (1<<3)
|
||||
+ unsigned long filter_events; /* Event mask that IM need */
|
||||
+#endif
|
||||
} IMCommonAttributes;
|
||||
|
||||
typedef struct {
|
|
@ -1 +1 @@
|
|||
A SKK-like Japanese input method for X11
|
||||
An SKK-like Japanese input method for X11
|
||||
|
|
|
@ -6,5 +6,7 @@ sends a request to skkinput. Skkinput receives the request, does
|
|||
kana-kanji conversion, and sends the converted text back to the
|
||||
client.
|
||||
|
||||
The port was done by Murata Shuuichirou <mrt@mickey.ai.kyutech.ac.jp>.
|
||||
It requires skk server.
|
||||
From version 3.0, skkinput becomes an emacs-lisp like interpreter,
|
||||
and uses skk.el in skk-8.6 as an conversion engine.
|
||||
|
||||
WWW: http://sourceforge.jp/projects/skkinput3/
|
||||
|
|
|
@ -1,12 +1,10 @@
|
|||
bin/skkinput
|
||||
lib/X11/app-defaults/Skkinput
|
||||
share/doc/skkinput/BUGS.jis
|
||||
share/doc/skkinput/CHANGES.jis
|
||||
share/doc/skkinput/FAQ.jis
|
||||
share/doc/skkinput/PROGRAM.jis
|
||||
share/doc/skkinput/README.jis
|
||||
share/doc/skkinput/TODO.jis
|
||||
share/doc/skkinput/dot.skkinput
|
||||
share/doc/skkinput/skkinput.doc
|
||||
share/doc/skkinput/skkinputlisp.doc
|
||||
@dirrm share/doc/skkinput
|
||||
bin/skkinput3
|
||||
lib/X11/skkinput3/init.el
|
||||
lib/X11/skkinput3/skk.el
|
||||
lib/X11/skkinput3/skk-startup.el
|
||||
lib/X11/skkinput3/skk-trial.el
|
||||
@dirrm lib/X11/skkinput3
|
||||
%%PORTDOCS%%share/doc/skkinput3/README-lisp.jis
|
||||
%%PORTDOCS%%share/doc/skkinput3/README.jis
|
||||
%%PORTDOCS%%share/doc/skkinput3/dot.skkinput
|
||||
%%PORTDOCS%%@dirrm share/doc/skkinput3
|
||||
|
|
Loading…
Reference in a new issue