WWW front end for mail archives.
This commit is contained in:
Seiichirou Hiraoka 1999-03-31 11:48:28 +00:00
parent a44712165e
commit 0aea03c7c3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17493
9 changed files with 377 additions and 0 deletions

42
japanese/mhonarc/Makefile Normal file
View file

@ -0,0 +1,42 @@
# New ports collection makefile for: MHonArc
# Version required: 2.3.3
# Date created: 17 March 1999
# Whom: Seiichirou Hiraoka
#
# $Id$
#
DISTNAME= MHonArc2.3.3
PKGNAME= ja-mhonarc-2.3.3
CATEGORIES= japanese www
MASTER_SITES= http://www.oac.uci.edu/indiv/ehood/tar/ \
ftp://hhobel.phl.univie.ac.at/MHonArc/ \
ftp://contrib.redhat.com/noarch/ \
ftp://ftp.plig.org/pub/CPAN/authors/id/EHOOD/ \
http://www.perl.com/CPAN/authors/id/EHOOD/ \
http://www.shiratori.riec.tohoku.ac.jp/~p-katoh/Hack/Docs/mhonarc-jp/ \
http://www.flathill.gr.jp/~flathill/distfiles/
DISTFILES= MHonArc2.3.3.tar.gz iso2022.pl
MAINTAINER= flathill@FreeBSD.ORG
EXTRACT_ONLY= MHonArc2.3.3.tar.gz
Y2K= http://www.oac.uci.edu/indiv/ehood/MHonArc/doc/faq/general.html#y2k
USE_PERL5= Yes
NO_BUILD= Yes
.include <bsd.port.pre.mk>
pre-install:
${CP} ${DISTDIR}/iso2022.pl ${WRKSRC}/lib/
do-install:
cd ${WRKSRC} && ${PERL5} install.me -prefix ${PREFIX} -batch
${MKDIR} ${PREFIX}/share/examples/MHonArc
${INSTALL_DATA} ${FILESDIR}/mhonarc.rc.sample ${PREFIX}/share/examples/MHonArc/
post-install:
${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (MHonArc2.3.3.tar.gz) = e2cb627565ae0be7508d37ff987c3fb4
MD5 (iso2022.pl) = 10830009d28cf7a6918aa24ebbbac500

View file

@ -0,0 +1,18 @@
<DECODEHEADS>
<MIMEARGS>
text/plain:default=iso-2022-jp
</MIMEARGS>
<CHARSETCONVERTERS>
iso-2022-jp; iso_2022::str2sgml; iso2022.pl
plain; iso_2022::str2sgml; iso2022.pl
</CHARSETCONVERTERS>
<MsgPgBegin>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML//EN">
<HTML>
<HEAD>
<TITLE>$SUBJECTNA$</TITLE>
<LINK REV="made" HREF="mailto:$FROMADDR$">
</HEAD>
<BODY>
</MsgPgBegin>

View file

@ -0,0 +1,32 @@
--- install.me.orig Sun Nov 8 21:01:53 1998
+++ install.me Tue Mar 2 12:02:55 1999
@@ -263,7 +263,7 @@
exit !$ret;
}
- my $cfg_prefix = $Config{'prefix'};
+ my $cfg_prefix = "/usr/local";
$DefValues{'binpath'} = $Config{'installbin'};
$DefValues{'libpath'} = $Config{'installsitelib'};
$DefValues{'manpath'} = $Config{'installman1dir'};
@@ -271,9 +271,9 @@
$DefValues{'binpath'} =~ s/^\Q$cfg_prefix/$OptValues{'prefix'}/o;
$DefValues{'libpath'} =~ s/^\Q$cfg_prefix/$OptValues{'prefix'}/o;
$DefValues{'manpath'} =~ s/^\Q$cfg_prefix/$OptValues{'prefix'}/o;
- $DefValues{'docpath'} = join($DIRSEP, $OptValues{'prefix'}, 'doc');
+ $DefValues{'docpath'} = join($DIRSEP, $OptValues{'prefix'}, 'share/doc');
} else {
- $DefValues{'docpath'} = join($DIRSEP, $cfg_prefix, 'doc');
+ $DefValues{'docpath'} = join($DIRSEP, $cfg_prefix, 'share/doc');
}
$DefValues{'manpath'} =~ s|(${DIRSEPRX}man)${DIRSEPRX}.*|$1|;
@@ -294,6 +294,8 @@
\%Files);
$DefValues{'docpath'} .= $DIRSEP . $Files{'name'}[0]
+ if $Files{'name'}[0];
+ $DefValues{'libpath'} .= $DIRSEP . $Files{'name'}[0]
if $Files{'name'}[0];
$dobin = defined($Files{'bin'}) && scalar(@{$Files{'bin'}}) &&
!$OptValues{'nobin'};

View file

@ -0,0 +1,10 @@
--- FILELIST.orig Wed Mar 17 18:36:19 1999
+++ FILELIST Wed Mar 17 18:36:49 1999
@@ -4,6 +4,7 @@
bin:mha-dbrecover
lib:lib/base64.pl
lib:lib/ewhutil.pl
+lib:lib/iso2022.pl
lib:lib/iso8859.pl
lib:lib/mhamain.pl
lib:lib/mhdb.pl

View file

@ -0,0 +1 @@
WWW front end for mail archives.

View file

@ -0,0 +1,10 @@
MHonArc can process mail messages to create a set of indexed html pages.
Threaded and chronological indices can be generated, and messages can be added
incrementally to an existing archive. A `standalone' mode is also supported
for quick conversions of individual messages to HTML without adding them to
the index. MIME attachments in mail messages are handled. MHTML is
also supported.
The program is highly customizable and is well documented. See URL
"http://www.oac.uci.edu/indiv/ehood/mhonarc.doc.html" for more information.

View file

@ -0,0 +1,10 @@
-----
How to process japanese.
1. Make resource file.
Sample resource file is installed in
/usr/local/share/examples/MHonArc/mhonarc.rc.sample
2. Use -rcfile option and specify resource file
when you excute mknmz.
-----

252
japanese/mhonarc/pkg-plist Normal file
View file

@ -0,0 +1,252 @@
bin/mhonarc
bin/mha-dbedit
bin/mha-dbrecover
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/base64.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/ewhutil.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/iso2022.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/iso8859.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhamain.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhdb.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhdysub.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhexternal.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhfile.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhidxrc.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhindex.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhinit.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhmimetypes.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhmsgfile.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhnote.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhnull.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhopt.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhrcfile.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhrcvars.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhrmm.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhscan.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhsingle.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhthread.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhtime.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhtxttsv.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhtxtenrich.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhtxthtml.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhtxtplain.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhtxtsetext.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhusage.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/mhutil.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/osinit.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/qprint.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/readmail.pl
lib/perl5/site_perl/%%PERL_VER%%/MHonArc/rfc822.pl
share/doc/MHonArc/app-bugs.html
share/doc/MHonArc/app-diagnos.html
share/doc/MHonArc/app-utilsprg.html
share/doc/MHonArc/blank.gif
share/doc/MHonArc/bug.gif
share/doc/MHonArc/contacts.html
share/doc/MHonArc/faq/about.html
share/doc/MHonArc/faq/envs.html
share/doc/MHonArc/faq/faq.html
share/doc/MHonArc/faq/usage.html
share/doc/MHonArc/faq/general.html
share/doc/MHonArc/faq/indexpgs.html
share/doc/MHonArc/faq/mime.html
share/doc/MHonArc/faq/threads.html
share/doc/MHonArc/faq/monicon.gif
share/doc/MHonArc/faq/archives.html
share/doc/MHonArc/faq/msgpgs.html
share/doc/MHonArc/faq/monsmall_t.gif
share/doc/MHonArc/faq.gif
share/doc/MHonArc/home.gif
share/doc/MHonArc/index.html
share/doc/MHonArc/intro.html
share/doc/MHonArc/layout.html
share/doc/MHonArc/mhonarc.html
share/doc/MHonArc/monicon.gif
share/doc/MHonArc/next.gif
share/doc/MHonArc/prev.gif
share/doc/MHonArc/quickstart.html
share/doc/MHonArc/rcvars.html
share/doc/MHonArc/resources/mimefilters.html
share/doc/MHonArc/resources/tprevpglink.html
share/doc/MHonArc/resources/add.html
share/doc/MHonArc/resources/authorbegin.html
share/doc/MHonArc/resources/authorend.html
share/doc/MHonArc/resources/authsort.html
share/doc/MHonArc/resources/botlinks.html
share/doc/MHonArc/resources/conlen.html
share/doc/MHonArc/resources/daybegin.html
share/doc/MHonArc/resources/charsetconverters.html
share/doc/MHonArc/resources/dayend.html
share/doc/MHonArc/resources/dbfile.html
share/doc/MHonArc/resources/decodeheads.html
share/doc/MHonArc/resources/definederived.html
share/doc/MHonArc/resources/definevar.html
share/doc/MHonArc/resources/defrcfile.html
share/doc/MHonArc/resources/doc.html
share/doc/MHonArc/resources/docurl.html
share/doc/MHonArc/resources/editidx.html
share/doc/MHonArc/resources/excs.html
share/doc/MHonArc/resources/expireage.html
share/doc/MHonArc/resources/expiredate.html
share/doc/MHonArc/resources/fieldorder.html
share/doc/MHonArc/resources/fieldsbeg.html
share/doc/MHonArc/resources/fieldsend.html
share/doc/MHonArc/resources/fieldstyles.html
share/doc/MHonArc/resources/fldbeg.html
share/doc/MHonArc/resources/fldend.html
share/doc/MHonArc/resources/folrefs.html
share/doc/MHonArc/resources/footer.html
share/doc/MHonArc/resources/force.html
share/doc/MHonArc/resources/genidx.html
share/doc/MHonArc/resources/gmtdatefmt.html
share/doc/MHonArc/resources/headbodysep.html
share/doc/MHonArc/resources/header.html
share/doc/MHonArc/resources/icons.html
share/doc/MHonArc/resources/idxfname.html
share/doc/MHonArc/resources/idxlabel.html
share/doc/MHonArc/resources/idxpgbegin.html
share/doc/MHonArc/resources/idxpgend.html
share/doc/MHonArc/resources/idxprefix.html
share/doc/MHonArc/resources/idxsize.html
share/doc/MHonArc/resources/include.html
share/doc/MHonArc/resources/labelbeg.html
share/doc/MHonArc/resources/labelend.html
share/doc/MHonArc/resources/labelstyles.html
share/doc/MHonArc/resources/listbegin.html
share/doc/MHonArc/resources/listend.html
share/doc/MHonArc/resources/litemplate.html
share/doc/MHonArc/resources/localdatefmt.html
share/doc/MHonArc/resources/lockdelay.html
share/doc/MHonArc/resources/locktries.html
share/doc/MHonArc/resources/mailto.html
share/doc/MHonArc/resources/mailtourl.html
share/doc/MHonArc/resources/main.html
share/doc/MHonArc/resources/maxsize.html
share/doc/MHonArc/resources/mhpattern.html
share/doc/MHonArc/resources/mimeargs.html
share/doc/MHonArc/resources/modtime.html
share/doc/MHonArc/resources/months.html
share/doc/MHonArc/resources/monthsabr.html
share/doc/MHonArc/resources/msgfoot.html
share/doc/MHonArc/resources/msggmtdatefmt.html
share/doc/MHonArc/resources/msghead.html
share/doc/MHonArc/resources/msglocaldatefmt.html
share/doc/MHonArc/resources/msgpgbegin.html
share/doc/MHonArc/resources/msgpgend.html
share/doc/MHonArc/resources/msgsep.html
share/doc/MHonArc/resources/multipg.html
share/doc/MHonArc/resources/news.html
share/doc/MHonArc/resources/nextbutton.html
share/doc/MHonArc/resources/nextbuttonia.html
share/doc/MHonArc/resources/nextlink.html
share/doc/MHonArc/resources/nextlinkia.html
share/doc/MHonArc/resources/nextpglink.html
share/doc/MHonArc/resources/nextpglinkia.html
share/doc/MHonArc/resources/otherindexes.html
share/doc/MHonArc/resources/outdir.html
share/doc/MHonArc/resources/perlinc.html
share/doc/MHonArc/resources/prevbutton.html
share/doc/MHonArc/resources/prevbuttonia.html
share/doc/MHonArc/resources/prevlink.html
share/doc/MHonArc/resources/prevlinkia.html
share/doc/MHonArc/resources/quiet.html
share/doc/MHonArc/resources/prevpglink.html
share/doc/MHonArc/resources/prevpglinkia.html
share/doc/MHonArc/resources/rmm.html
share/doc/MHonArc/resources/rcfile.html
share/doc/MHonArc/resources/reverse.html
share/doc/MHonArc/resources/scan.html
share/doc/MHonArc/resources/single.html
share/doc/MHonArc/resources/sort.html
share/doc/MHonArc/resources/subjectbegin.html
share/doc/MHonArc/resources/subjectend.html
share/doc/MHonArc/resources/subjectheader.html
share/doc/MHonArc/resources/subsort.html
share/doc/MHonArc/resources/tfoot.html
share/doc/MHonArc/resources/thead.html
share/doc/MHonArc/resources/thread.html
share/doc/MHonArc/resources/tidxfname.html
share/doc/MHonArc/resources/tidxlabel.html
share/doc/MHonArc/resources/tidxpgbegin.html
share/doc/MHonArc/resources/tidxpgend.html
share/doc/MHonArc/resources/tidxprefix.html
share/doc/MHonArc/resources/timezones.html
share/doc/MHonArc/resources/title.html
share/doc/MHonArc/resources/tlevels.html
share/doc/MHonArc/resources/tliend.html
share/doc/MHonArc/resources/tlinone.html
share/doc/MHonArc/resources/tlinoneend.html
share/doc/MHonArc/resources/tlitxt.html
share/doc/MHonArc/resources/tnextbutton.html
share/doc/MHonArc/resources/tnextbuttonia.html
share/doc/MHonArc/resources/tnextlink.html
share/doc/MHonArc/resources/tnextlinkia.html
share/doc/MHonArc/resources/tnextpglink.html
share/doc/MHonArc/resources/tnextpglinkia.html
share/doc/MHonArc/resources/toplinks.html
share/doc/MHonArc/resources/tprevbutton.html
share/doc/MHonArc/resources/tprevbuttonia.html
share/doc/MHonArc/resources/tprevlink.html
share/doc/MHonArc/resources/tprevlinkia.html
share/doc/MHonArc/resources/tprevpglinkia.html
share/doc/MHonArc/resources/treverse.html
share/doc/MHonArc/resources/tsingletxt.html
share/doc/MHonArc/resources/tsubjectbeg.html
share/doc/MHonArc/resources/tsubjectend.html
share/doc/MHonArc/resources/tsublistbeg.html
share/doc/MHonArc/resources/tsublistend.html
share/doc/MHonArc/resources/ttitle.html
share/doc/MHonArc/resources/ttopbegin.html
share/doc/MHonArc/resources/ttopend.html
share/doc/MHonArc/resources/umask.html
share/doc/MHonArc/resources/weekdays.html
share/doc/MHonArc/resources/weekdaysabr.html
share/doc/MHonArc/resources/tcontbegin.html
share/doc/MHonArc/resources/tcontend.html
share/doc/MHonArc/resources/tindentbegin.html
share/doc/MHonArc/resources/tindentend.html
share/doc/MHonArc/resources/defrcname.html
share/doc/MHonArc/resources/gzipexe.html
share/doc/MHonArc/resources/gzipfiles.html
share/doc/MHonArc/resources/gziplinks.html
share/doc/MHonArc/resources/htmlext.html
share/doc/MHonArc/resources/msgprefix.html
share/doc/MHonArc/resources/tsort.html
share/doc/MHonArc/resources/tsubsort.html
share/doc/MHonArc/resources/folupbegin.html
share/doc/MHonArc/resources/folupend.html
share/doc/MHonArc/resources/foluplitxt.html
share/doc/MHonArc/resources/msgbodyend.html
share/doc/MHonArc/resources/refsbegin.html
share/doc/MHonArc/resources/refsend.html
share/doc/MHonArc/resources/refslitxt.html
share/doc/MHonArc/resources/datefields.html
share/doc/MHonArc/resources/archive.html
share/doc/MHonArc/resources/fromfields.html
share/doc/MHonArc/resources/usinglastpg.html
share/doc/MHonArc/resources/msgidlink.html
share/doc/MHonArc/resources/subjectarticlerxp.html
share/doc/MHonArc/resources/subjectreplyrxp.html
share/doc/MHonArc/resources/tslice.html
share/doc/MHonArc/resources/tslicebeg.html
share/doc/MHonArc/resources/tsliceend.html
share/doc/MHonArc/resources/afs.html
share/doc/MHonArc/resources/annotate.html
share/doc/MHonArc/resources/lock.html
share/doc/MHonArc/resources/lockfile.html
share/doc/MHonArc/resources/note.html
share/doc/MHonArc/resources/notedir.html
share/doc/MHonArc/resources/noteia.html
share/doc/MHonArc/resources/notetext.html
share/doc/MHonArc/resources/subjectstripcode.html
share/doc/MHonArc/resources/msgpgs.html
share/doc/MHonArc/resources/uselocaltime.html
share/doc/MHonArc/resources.html
share/doc/MHonArc/ssbg75.jpg
share/doc/MHonArc/stampwb2.gif
share/doc/MHonArc/up.gif
share/examples/MHonArc/mhonarc.rc.sample
@dirrm lib/perl5/site_perl/%%PERL_VER%%/MHonArc
@dirrm share/doc/MHonArc/faq
@dirrm share/doc/MHonArc/resources
@dirrm share/doc/MHonArc
@dirrm share/examples/MHonArc