devel/electron25: update to 25.8.0
Changelog: https://github.com/electron/electron/releases/tag/v25.8.0 Reported by: GitHub (watch releases) MFH: 2023Q3 Security: 970dcbe0-a947-41a4-abe9-7aaba87f41fe
This commit is contained in:
parent
ad1d79583b
commit
0b15a88279
5 changed files with 13 additions and 13 deletions
|
@ -223,7 +223,7 @@ REACTIVEOBJC_VER= 74ab5baccc6f7202c8ac69a8d1e152c29dc1ea76
|
|||
# See ${WRKSRC}/electron/DEPS for MANTLE_VER
|
||||
MANTLE_VER= 78d3966b3c331292ea29ec38661b25df0a245948
|
||||
|
||||
YARN_TIMESTAMP= 1692875487
|
||||
YARN_TIMESTAMP= 1693653500
|
||||
|
||||
.include "Makefile.version"
|
||||
.include <bsd.port.pre.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
ELECTRON_VER= 25.7.0
|
||||
ELECTRON_VER= 25.8.0
|
||||
ELECTRON_VER_MAJOR= ${ELECTRON_VER:C/\..*//}
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
TIMESTAMP = 1692875668
|
||||
TIMESTAMP = 1693653845
|
||||
SHA256 (electron/chromium-114.0.5735.289.tar.xz) = 12dee4e585dab6e7dc2117f4ee40484a947ac7a6b5a33c87dfae7cbf8b8799b0
|
||||
SIZE (electron/chromium-114.0.5735.289.tar.xz) = 1413670648
|
||||
SHA256 (electron/de0af8ec3401004cd1a420ab25892880330464c8) = 401097f07b4feb3e03ce7c2412e978b32aea5334f4fbaf26f873e60e8bb92647
|
||||
SIZE (electron/de0af8ec3401004cd1a420ab25892880330464c8) = 8880520
|
||||
SHA256 (electron/336e775eec536b2d785cc80eff6ac39051931286) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
|
||||
SIZE (electron/336e775eec536b2d785cc80eff6ac39051931286) = 32624734
|
||||
SHA256 (electron/electron-yarn-cache-25.7.0.tar.xz) = b770dbca14131c47a392e0c41af0f190d9eca447b1674829ddb0b0b07ea98b0b
|
||||
SIZE (electron/electron-yarn-cache-25.7.0.tar.xz) = 41289416
|
||||
SHA256 (electron/electron-electron-v25.7.0_GH0.tar.gz) = 76956fbeb6ecaac18e9baa1cf8b09c4382e7265e68a349bdeadea072d4fdfaaa
|
||||
SIZE (electron/electron-electron-v25.7.0_GH0.tar.gz) = 11301990
|
||||
SHA256 (electron/electron-yarn-cache-25.8.0.tar.xz) = 13b30b4549d4c47c8821f629b1340a8dea0a5f4830033b04808b8b07e80d506d
|
||||
SIZE (electron/electron-yarn-cache-25.8.0.tar.xz) = 41289472
|
||||
SHA256 (electron/electron-electron-v25.8.0_GH0.tar.gz) = c3f1c4b7de1ffc53ee6f1fddf26943b9c051f748934c76c6bdc098385870b40f
|
||||
SIZE (electron/electron-electron-v25.8.0_GH0.tar.gz) = 11312518
|
||||
SHA256 (electron/nodejs-node-v18.15.0_GH0.tar.gz) = 33c4b5b77c98398a3c0d99a146f602d164e014ff3a5713697beef1a971faf573
|
||||
SIZE (electron/nodejs-node-v18.15.0_GH0.tar.gz) = 111925667
|
||||
SHA256 (electron/nodejs-nan-16fa32231e2ccd89d2804b3f765319128b20c4ac_GH0.tar.gz) = 3807ae6a1e451a29f068540472f100f9718d457c60ac62f2f8469d1d57475d39
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- electron/shell/browser/api/electron_api_web_contents.cc.orig 2023-08-02 12:53:47 UTC
|
||||
--- electron/shell/browser/api/electron_api_web_contents.cc.orig 2023-08-30 15:08:12 UTC
|
||||
+++ electron/shell/browser/api/electron_api_web_contents.cc
|
||||
@@ -154,11 +154,11 @@
|
||||
#include "ui/base/cocoa/defaults_utils.h"
|
||||
|
@ -32,7 +32,7 @@
|
|||
// Update font settings.
|
||||
static const gfx::FontRenderParams params(
|
||||
gfx::GetFontRenderParams(gfx::FontRenderParamsQuery(), nullptr));
|
||||
@@ -2630,7 +2630,7 @@ void WebContents::ForcefullyCrashRenderer() {
|
||||
@@ -2643,7 +2643,7 @@ void WebContents::ForcefullyCrashRenderer() {
|
||||
|
||||
content::RenderProcessHost* rph = rwh->GetProcess();
|
||||
if (rph) {
|
||||
|
@ -41,7 +41,7 @@
|
|||
// A generic |CrashDumpHungChildProcess()| is not implemented for Linux.
|
||||
// Instead we send an explicit IPC to crash on the renderer's IO thread.
|
||||
rph->ForceCrash();
|
||||
@@ -3301,7 +3301,7 @@ void WebContents::CopyImageAt(int x, int y) {
|
||||
@@ -3314,7 +3314,7 @@ void WebContents::CopyImageAt(int x, int y) {
|
||||
void WebContents::Focus() {
|
||||
// Focusing on WebContents does not automatically focus the window on macOS
|
||||
// and Linux, do it manually to match the behavior on Windows.
|
||||
|
@ -50,7 +50,7 @@
|
|||
if (owner_window())
|
||||
owner_window()->Focus(true);
|
||||
#endif
|
||||
@@ -4115,7 +4115,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
|
||||
@@ -4128,7 +4128,7 @@ ui::ImageModel WebContents::GetDevToolsWindowIcon() {
|
||||
}
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- electron/spec/api-browser-window-spec.ts.orig 2023-08-16 14:00:49 UTC
|
||||
--- electron/spec/api-browser-window-spec.ts.orig 2023-08-30 15:08:12 UTC
|
||||
+++ electron/spec/api-browser-window-spec.ts
|
||||
@@ -65,7 +65,7 @@ describe('BrowserWindow module', () => {
|
||||
}).not.to.throw();
|
||||
|
@ -144,7 +144,7 @@
|
|||
// Not implemented on Linux.
|
||||
afterEach(closeAllWindows);
|
||||
|
||||
@@ -6214,7 +6214,7 @@ describe('BrowserWindow module', () => {
|
||||
@@ -6250,7 +6250,7 @@ describe('BrowserWindow module', () => {
|
||||
describe('"transparent" option', () => {
|
||||
afterEach(closeAllWindows);
|
||||
|
||||
|
|
Loading…
Reference in a new issue