Update from 2.2.12 to latest bugfix release 2.2.13.

<ChangeLog>

* [BUGFIX] Fixed issue 593 (BRPOPLPUSH related crash).
* [BUGFIX] Fixed an issue with the networking layer that may
  prevent Redis from sending the whole reply back to client
  under extreme conditions.

</ChangeLog>
This commit is contained in:
Sergey A. Osokin 2011-09-14 06:39:19 +00:00
parent 7301aac766
commit 0b43809cb1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=281756
3 changed files with 9 additions and 10 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= redis
PORTVERSION= 2.2.12
PORTREVISION= 1
PORTVERSION= 2.2.13
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE

View file

@ -1,2 +1,2 @@
SHA256 (redis-2.2.12.tar.gz) = 9e2a4133b920fc4eed731c9cd3a9d0b60e701179ea98b2944ab434e7b1d0db03
SIZE (redis-2.2.12.tar.gz) = 455240
SHA256 (redis-2.2.13.tar.gz) = e6353c022bc6442d61f196ca411348a6a3ab61cfa30f629c2c954d759710d370
SIZE (redis-2.2.13.tar.gz) = 455330

View file

@ -1,6 +1,6 @@
--- src/Makefile.orig 2010-12-24 09:29:14.000000000 +0300
+++ src/Makefile 2010-12-24 09:31:51.000000000 +0300
@@ -9,6 +9,9 @@
--- src/Makefile.orig 2011-09-14 10:32:32.000000000 +0400
+++ src/Makefile 2011-09-14 10:34:08.000000000 +0400
@@ -22,6 +22,9 @@
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
CCLINK?= -ldl -lnsl -lsocket -lm -lpthread
DEBUG?= -g -ggdb
@ -10,12 +10,12 @@
else
CFLAGS?= -std=c99 -pedantic $(OPTIMIZATION) -Wall -W $(ARCH) $(PROF)
CCLINK?= -lm -pthread
@@ -19,9 +22,9 @@
@@ -32,9 +35,9 @@
CCLINK+= -ltcmalloc
CFLAGS+= -DUSE_TCMALLOC
endif
-CCOPT= $(CFLAGS) $(CCLINK) $(ARCH) $(PROF)
+CCOPT= $(CFLAGS) $(CCLINK) $(PROF)
-CCOPT= $(CFLAGS) $(ARCH) $(PROF)
+CCOPT= $(CFLAGS) $(PROF)
-PREFIX= /usr/local
+PREFIX?= $(PREFIX)