- Remove databases/akonadi-google: it was merged into

deskutils/kdepim4-runtime.
This commit is contained in:
Alberto Villa 2013-03-24 01:09:57 +00:00
parent 65fd175fad
commit 0b4f959a99
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315087
7 changed files with 1 additions and 120 deletions

1
MOVED
View file

@ -4181,3 +4181,4 @@ editors/openoffice-3-devel|editors/openoffice-devel|2013-03-21|Renamed to match
devel/geany-plugin-gdb||2013-03-21|Removed from geany plugins distribution
www/kompozer||2013-03-22|Has expired: Dead upstream
graphics/fpc-fpvectorial||2013-03-23|Removed from freepascal packages distribution
databases/akonadi-google||2013-03-24|Merged into deskutils/kdepim4-runtime

View file

@ -13,7 +13,6 @@
SUBDIR += adodb
SUBDIR += adodb5
SUBDIR += akonadi
SUBDIR += akonadi-google
SUBDIR += akonadi-googledata
SUBDIR += animenfo-client
SUBDIR += animenfo-client-gtk

View file

@ -1,35 +0,0 @@
# New ports collection Makefile for: akonadi-google
# Date created: 10 April 2012
# Whom: Alberto Villa <avilla@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= akonadi-google
PORTVERSION= 0.3.1
PORTREVISION= 2
CATEGORIES= databases kde
MASTER_SITES= http://www.progdan.cz/wp-content/uploads/
DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= avilla@FreeBSD.org
COMMENT= Akonadi resources for accessing Google services
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_KDE4= kdehier kdelibs kdeprefix pimlibs automoc4
USE_QT4= dbus gui network webkit xml \
moc_build qmake_build rcc_build uic_build
USES= cmake
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
pre-configure:
${REINPLACE_CMD} -e '/pkgconfig/ s/$${LIB_INSTALL_DIR}/libdata/' \
${WRKSRC}/libkgoogle/CMakeLists.txt
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (akonadi-google-0.3.1.tar.gz) = bba88dbddb6fd14e75bea3cc08a1a66615a3a079299cac4c243d8ab86ef7aec0
SIZE (akonadi-google-0.3.1.tar.gz) = 87677

View file

@ -1,40 +0,0 @@
commit a5ab37f15f39217cf631f8d61b2ea21305b81490
Author: Dan Vrátil <dan@progdan.cz>
Date: Wed Jun 6 00:36:46 2012 +0200
Parse OAuth code from page title instead of body
The OAuth code used for obtaining access tokens is provided
in webpage <title> as a string. The title is guaranteed not to change
syntax, while the body of the page, from which we were parsing the token
before, can change anytime, which breaks the authentication process.
BUG: 301240
FIXED-IN: 0.4.1
diff --git a/libkgapi/ui/authwidget_p.cpp b/libkgapi/ui/authwidget_p.cpp
index 57d914c..55e77cb 100644
--- ./libkgoogle/authdialog.cpp
+++ ./libkgoogle/authdialog.cpp
@@ -147,13 +147,18 @@ void AuthWidgetPrivate::webviewFinished()
}
if (url.host() == "accounts.google.com" && url.path() == "/o/oauth2/approval") {
- QWebElement el = m_webiew->page()->mainFrame()->findFirstElement("textarea");
- if (el.isNull()) {
+ QString title = m_webiew->title();
+ QString token;
+
+ if (title.startsWith(QLatin1String("success"), Qt::CaseInsensitive)) {
+ int pos = title.indexOf(QLatin1String("code="));
+ /* Skip the 'code=' string as well */
+ token = title.mid (pos + 5);
+ } else {
emitError(KGoogle::AuthError, i18n("Parsing token page failed."));
return;
}
- QString token = el.toInnerXml();
if (token.isEmpty()) {
emitError(KGoogle::AuthError, i18n("Failed to obtain token."));
return;

View file

@ -1,5 +0,0 @@
Akonadi Google is a set of Akonadi resources providing access to
various Google services like Google Contacts or Google Calendar from
KDE-Pim applications.
WWW: http://progdan.cz/category/akonadi-google

View file

@ -1,37 +0,0 @@
bin/akonadi_googlecalendar_resource
bin/akonadi_googlecontacts_resource
include/libkgoogle/accessmanager.h
include/libkgoogle/account.h
include/libkgoogle/auth.h
include/libkgoogle/common.h
include/libkgoogle/fetchlistjob.h
include/libkgoogle/libkgoogle_export.h
include/libkgoogle/object.h
include/libkgoogle/objects/accountinfo.h
include/libkgoogle/objects/calendar.h
include/libkgoogle/objects/contact.h
include/libkgoogle/objects/contactsgroup.h
include/libkgoogle/objects/event.h
include/libkgoogle/objects/task.h
include/libkgoogle/objects/tasklist.h
include/libkgoogle/reply.h
include/libkgoogle/request.h
include/libkgoogle/service.h
include/libkgoogle/services/accountinfo.h
include/libkgoogle/services/calendar.h
include/libkgoogle/services/contacts.h
include/libkgoogle/services/tasks.h
include/libkgoogle/ui/accountscombo.h
lib/libkgoogle.so
lib/libkgoogle.so.0
lib/libkgoogle.so.0.3.1
libdata/pkgconfig/libkgoogle.pc
share/akonadi/agents/googlecalendarresource.desktop
share/akonadi/agents/googlecontactsresource.desktop
share/apps/cmake/modules/FindLibKGoogle.cmake
@dirrmtry share/akonadi/agents
@dirrmtry share/akonadi
@dirrm include/libkgoogle/ui
@dirrm include/libkgoogle/services
@dirrm include/libkgoogle/objects
@dirrm include/libkgoogle