Import of dc20pack.

Dc20pack can control a Kodak DC20/25 digital camera via the embedded
serial port.  Pictures are initially downloaded in the camera's native format
but can be converted to targa format.

Note that I did not test this personally as I don't own a DC20/25 :).
The submitter says that it works, though.

PR:		12909
Submitted by:	Maurice Castro <maurice@serc.rmit.edu.au>
This commit is contained in:
Chris Piazza 1999-09-09 01:43:30 +00:00
parent 9a96eee19a
commit 0b530eecbb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21463
7 changed files with 94 additions and 0 deletions

View file

@ -0,0 +1,27 @@
# New ports collection makefile for: dc20pack
# Version required: 1.0
# Date created: Jul 31 1999
# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
#
# $FreeBSD$
#
DISTNAME= dc20pack-1.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/graphics/capture
EXTRACT_SUFX= .tgz
MAINTAINER= maurice@serc.rmit.edu.au
WRKSRC= ${WRKDIR}
post-extract:
@ /usr/bin/find ${WRKSRC} -type f | xargs /usr/bin/perl -pi -e 's/\r//g'
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/dc20dump ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/dc20term ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/dc2totga ${PREFIX}/bin
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (dc20pack-1.0.tgz) = 1d11684987fbb82c046105173e8a5709

View file

@ -0,0 +1,44 @@
*** dc20_hif.c.orig Sun Aug 1 13:55:41 1999
--- dc20_hif.c Sun Aug 1 13:57:21 1999
***************
*** 15,21 ****
unsigned char sts_res= 0, sts_bat= 0;
unsigned char sts_pic_cnt= 0, sts_pic_rem= 0;
unsigned char dc_type= 0x25;
! unsigned char com_dev[128]= "/dev/ttyS0";
/* LOCAL VARIABLES ****************************************/
--- 15,21 ----
unsigned char sts_res= 0, sts_bat= 0;
unsigned char sts_pic_cnt= 0, sts_pic_rem= 0;
unsigned char dc_type= 0x25;
! unsigned char com_dev[128]= "/dev/cuaa0";
/* LOCAL VARIABLES ****************************************/
***************
*** 146,156 ****
{
switch (com_nr)
{
! case 1: strcpy(com_dev, "/dev/ttyS0") ; break;
! case 2: strcpy(com_dev, "/dev/ttyS1") ; break;
! case 3: strcpy(com_dev, "/dev/ttyS2") ; break;
! case 4: strcpy(com_dev, "/dev/ttyS3") ; break;
! default: strcpy(com_dev, "/dev/ttyS0") ; break;
}
if ((com_hdl = open(com_dev, O_RDWR)) == -1)
--- 146,156 ----
{
switch (com_nr)
{
! case 1: strcpy(com_dev, "/dev/cuaa0") ; break;
! case 2: strcpy(com_dev, "/dev/cuaa1") ; break;
! case 3: strcpy(com_dev, "/dev/cuaa2") ; break;
! case 4: strcpy(com_dev, "/dev/cuaa3") ; break;
! default: strcpy(com_dev, "/dev/cuaa0") ; break;
}
if ((com_hdl = open(com_dev, O_RDWR)) == -1)

View file

@ -0,0 +1,15 @@
--- Makefile.orig Wed Sep 8 18:38:19 1999
+++ Makefile Wed Sep 8 18:38:34 1999
@@ -1,10 +1,10 @@
all: dc20term dc2totga
dc20term: dc20_ui.o dc20_hif.o
- gcc -o $@ dc20_ui.o dc20_hif.o
+ ${CC} ${CFLAGS} -o $@ dc20_ui.o dc20_hif.o
dc2totga: dc2totga.c
- gcc -O3 -o dc2totga dc2totga.c -lm
+ ${CC} ${CFLAGS} -o dc2totga dc2totga.c -lm
clean:
rm -f dc20_ui.o dc20_hif.o dc2totga.o dc20term dc2totga

View file

@ -0,0 +1 @@
Digital camera control and download tool for Kodak DC20/25 camera

View file

@ -0,0 +1,3 @@
dc20pack can control your Kodak DC20/25 digital camera via the embedded serial
port. Pictures are initially downloaded in the camera's native format but
can be converted to targa format.

View file

@ -0,0 +1,3 @@
bin/dc20term
bin/dc20dump
bin/dc2totga