Add cpige, a shoutcast stream ripper.
cPige records an audio stream, separating into individual "Artist - Track.mp3" files. It can also record on an hour-by-hour basis. WWW: http://ed.zehome.com/?page=cpige
This commit is contained in:
parent
088726d0ab
commit
0bb8b61e9b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=132399
5 changed files with 41 additions and 0 deletions
|
@ -67,6 +67,7 @@
|
|||
SUBDIR += cmp3
|
||||
SUBDIR += cmt
|
||||
SUBDIR += coverhunter
|
||||
SUBDIR += cpige
|
||||
SUBDIR += cplay
|
||||
SUBDIR += crip
|
||||
SUBDIR += csound
|
||||
|
|
21
audio/cpige/Makefile
Normal file
21
audio/cpige/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# New ports collection makefile for: cpige
|
||||
# Date created: 27 March, 2005
|
||||
# Whom: Adam Weinberger <adamw@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cpige
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://ed.zehome.com/cpige/
|
||||
|
||||
MAINTAINER= adamw@FreeBSD.org
|
||||
COMMENT= Icecast/Shoutcast stream ripper
|
||||
|
||||
PORTFILES= bin/${PORTNAME}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
2
audio/cpige/distinfo
Normal file
2
audio/cpige/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (cpige-1.0.tar.gz) = 8e3a704adf5de6918d0606603cab66ff
|
||||
SIZE (cpige-1.0.tar.gz) = 16509
|
12
audio/cpige/files/patch-Makefile
Normal file
12
audio/cpige/files/patch-Makefile
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- Makefile.orig Sun Mar 27 14:57:32 2005
|
||||
+++ Makefile Sun Mar 27 14:57:58 2005
|
||||
@@ -1,6 +1,6 @@
|
||||
-CC=gcc
|
||||
-CLIBS=
|
||||
-CFLAGS=-Wall
|
||||
+CC?=gcc
|
||||
+CLIBS=${LDFLAGS}
|
||||
+CFLAGS+=-Wall
|
||||
|
||||
all: debug
|
||||
$(CC) $(CLIBS) $(CFLAGS) debug.o cpige.c -o cpige
|
5
audio/cpige/pkg-descr
Normal file
5
audio/cpige/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
cPige records an audio stream, separating into individual
|
||||
"Artist - Track.mp3" files. It can also record on an
|
||||
hour-by-hour basis.
|
||||
|
||||
WWW: http://ed.zehome.com/?page=cpige
|
Loading…
Reference in a new issue