Update math/cminpack to 1.3.6
PR: 217366 Submitted by: maintainer Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9813
This commit is contained in:
parent
925e119f01
commit
0bbb5eef1e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=435243
5 changed files with 9 additions and 21 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cminpack
|
||||
PORTVERSION= 1.3.5
|
||||
PORTVERSION= 1.3.6
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= math
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1464767219
|
||||
SHA256 (devernay-cminpack-v1.3.5_GH0.tar.gz) = a3ab4be6c8a8bab36c6ac7d4322fb0b9c4347a8096fd6c96d1686dc30e4b1afe
|
||||
SIZE (devernay-cminpack-v1.3.5_GH0.tar.gz) = 312932
|
||||
TIMESTAMP = 1487969746
|
||||
SHA256 (devernay-cminpack-v1.3.6_GH0.tar.gz) = 3c07fd21308c96477a2c900032e21d937739c233ee273b4347a0d4a84a32d09f
|
||||
SIZE (devernay-cminpack-v1.3.6_GH0.tar.gz) = 313459
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2014-05-28 09:24:45 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -58,6 +58,8 @@ set (cminpack_hdrs
|
||||
|
||||
add_library (cminpack ${LIB_TYPE} ${cminpack_srcs})
|
||||
|
||||
+TARGET_LINK_LIBRARIES(cminpack m)
|
||||
+
|
||||
install (TARGETS cminpack
|
||||
LIBRARY DESTINATION ${CMINPACK_LIB_INSTALL_DIR} COMPONENT library
|
||||
ARCHIVE DESTINATION ${CMINPACK_LIB_INSTALL_DIR} COMPONENT library
|
|
@ -1,11 +1,10 @@
|
|||
--- cmake/CMakeLists.txt.orig 2014-02-26 18:22:04 UTC
|
||||
--- cmake/CMakeLists.txt.orig 2017-02-24 21:33:00 UTC
|
||||
+++ cmake/CMakeLists.txt
|
||||
@@ -3,6 +3,6 @@ set(PKG_EXTERNAL_DEPS "")
|
||||
set(pkg_conf_file ${CMAKE_CURRENT_BINARY_DIR}/cminpack.pc)
|
||||
@@ -11,6 +11,6 @@ if (USE_BLAS AND BLAS_FOUND)
|
||||
endif()
|
||||
configure_file(cminpack.pc.in ${pkg_conf_file} @ONLY)
|
||||
install(FILES ${pkg_conf_file}
|
||||
- DESTINATION ${CMINPACK_LIB_INSTALL_DIR}/pkgconfig/ COMPONENT pkgconfig)
|
||||
+ DESTINATION libdata/pkgconfig/ COMPONENT pkgconfig)
|
||||
|
||||
-install(FILES FindCMinpack.cmake DESTINATION ${CMAKE_ROOT}/Modules)
|
||||
+install(FILES FindCMinpack.cmake DESTINATION share/cmake/Modules)
|
||||
install(FILES CMinpackConfig.cmake DESTINATION share/cmake/CMinpack)
|
||||
|
|
|
@ -2,7 +2,7 @@ include/cminpack-1/cminpack.h
|
|||
include/cminpack-1/minpack.h
|
||||
lib/libcminpack_s.a
|
||||
libdata/pkgconfig/cminpack.pc
|
||||
share/cmake/Modules/FindCMinpack.cmake
|
||||
share/cmake/CMinpack/CMinpackConfig.cmake
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkdrv.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chkdrv_.c
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cmpfiles.c
|
||||
|
|
Loading…
Reference in a new issue