net/ntp: Fix untracked gettext dependency & lots more
ntp links against gettext (libintl) if it is installed on the system: - Add an NLS OPTION to explicitly enable, disable and track libintl dependency - Add DEBUG and THREADS OPTIONS. Keep the latter enabled by OPTIONS_DEFAULT to preserve compatibility with existing behaviour. - Explicitly pass OpenSSL include / library dir paths to configure - Unsilence install command - Enable verbose building (--disable-silent-rules) - Use TOUCH variable instead of hardcoded command - Add TEST_TARGET to enable test suite - Patch sntp tests to ensure they link correctly to threading library - Pet portlint (*_DEPENDS order, group USE{S} sections, sort OPTIONS) Approved by: cy (maintainer) Differential Revision: D4812 MFH: 2016Q1
This commit is contained in:
parent
c1ccfecf6f
commit
0bd48c5d88
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=405439
2 changed files with 35 additions and 8 deletions
|
@ -3,6 +3,7 @@
|
||||||
|
|
||||||
PORTNAME= ntp
|
PORTNAME= ntp
|
||||||
PORTVERSION= 4.2.8p4
|
PORTVERSION= 4.2.8p4
|
||||||
|
PORTREVISION= 1
|
||||||
CATEGORIES= net ipv6
|
CATEGORIES= net ipv6
|
||||||
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
|
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
|
||||||
http://archive.ntp.org/ntp4/ntp-4.2/ \
|
http://archive.ntp.org/ntp4/ntp-4.2/ \
|
||||||
|
@ -12,12 +13,16 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/P/p/:S/.r/-RC/}
|
||||||
MAINTAINER= cy@FreeBSD.org
|
MAINTAINER= cy@FreeBSD.org
|
||||||
COMMENT= The Network Time Protocol Distribution
|
COMMENT= The Network Time Protocol Distribution
|
||||||
|
|
||||||
|
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
|
||||||
|
|
||||||
CONFLICTS= ntp-rc-* ntp-devel-*
|
CONFLICTS= ntp-rc-* ntp-devel-*
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
|
||||||
OPTIONS_SUB= yes
|
|
||||||
USES= cpe pathfix shebangfix libedit libtool pkgconfig
|
USES= cpe pathfix shebangfix libedit libtool pkgconfig
|
||||||
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
|
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
CONFIGURE_ARGS= --disable-silent-rules
|
||||||
|
|
||||||
|
TEST_TARGET= check
|
||||||
|
|
||||||
SHEBANG_FILES= scripts/ntptrace/ntptrace.in \
|
SHEBANG_FILES= scripts/ntptrace/ntptrace.in \
|
||||||
scripts/ntp-wait/ntp-wait.in \
|
scripts/ntp-wait/ntp-wait.in \
|
||||||
|
@ -26,20 +31,32 @@ perl_OLD_CMD= @PATH_PERL@
|
||||||
|
|
||||||
.include "Makefile.inc"
|
.include "Makefile.inc"
|
||||||
|
|
||||||
PERL_UTILS_USES= perl5
|
OPTIONS_DEFINE+= DEBUG NLS THREADS
|
||||||
|
OPTIONS_DEFAULT+= THREADS
|
||||||
|
OPTIONS_SUB= yes
|
||||||
|
|
||||||
SSL_USE= OPENSSL=yes
|
DEBUG_CONFIGURE_ENABLE= debugging
|
||||||
SSL_CONFIGURE_OFF= --without-crypto
|
|
||||||
|
|
||||||
IPV6_CONFIGURE_ENABLE= ipv6
|
IPV6_CONFIGURE_ENABLE= ipv6
|
||||||
|
|
||||||
|
NLS_CONFIGURE_ENABLE= nls
|
||||||
|
NLS_CONFIGURE_OFF= ac_cv_lib_intl_gettext=no
|
||||||
|
NLS_USES= gettext-runtime
|
||||||
|
|
||||||
NTP_SIGND_CONFIGURE_ENABLE= ntp-signd
|
NTP_SIGND_CONFIGURE_ENABLE= ntp-signd
|
||||||
|
|
||||||
NTPSNMPD_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
|
NTPSNMPD_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
|
||||||
NTPSNMPD_CONFIGURE_OFF= --without-ntpsnmpd
|
NTPSNMPD_CONFIGURE_OFF= --without-ntpsnmpd
|
||||||
|
|
||||||
|
PERL_UTILS_USES= perl5
|
||||||
|
|
||||||
|
SSL_USE= OPENSSL=yes
|
||||||
SSL_CONFIGURE_ON= --with-openssl-incdir=${OPENSSLINC} \
|
SSL_CONFIGURE_ON= --with-openssl-incdir=${OPENSSLINC} \
|
||||||
--with-openssl-libdir=${OPENSSLLIB}
|
--with-openssl-libdir=${OPENSSLLIB}
|
||||||
|
SSL_CONFIGURE_OFF= --without-crypto
|
||||||
|
|
||||||
|
THREADS_CONFIGURE_ENABLE= thread-support
|
||||||
|
THREADS_CONFIGURE_WITH= threads
|
||||||
|
|
||||||
.for D in ${NTP_DRIVERS}
|
.for D in ${NTP_DRIVERS}
|
||||||
${D}_CONFIGURE_ON= --enable-${D}
|
${D}_CONFIGURE_ON= --enable-${D}
|
||||||
|
@ -47,12 +64,12 @@ ${D}_CONFIGURE_ON= --enable-${D}
|
||||||
|
|
||||||
# XXX Temporary hack. Remember to remove this next commit.
|
# XXX Temporary hack. Remember to remove this next commit.
|
||||||
post-extract:
|
post-extract:
|
||||||
@/usr/bin/touch ${WRKSRC}/scripts/build/checkHtmlFileDates
|
@${TOUCH} ${WRKSRC}/scripts/build/checkHtmlFileDates
|
||||||
@${CHMOD} +x ${WRKSRC}/scripts/build/checkHtmlFileDates
|
@${CHMOD} +x ${WRKSRC}/scripts/build/checkHtmlFileDates
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||||
@${INSTALL_DATA} ${WRKSRC}/conf/* ${STAGEDIR}${EXAMPLESDIR}
|
${INSTALL_DATA} ${WRKSRC}/conf/* ${STAGEDIR}${EXAMPLESDIR}
|
||||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
@${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
|
@${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
|
||||||
@cd ${WRKSRC}/html && ${FIND} . -print | \
|
@cd ${WRKSRC}/html && ${FIND} . -print | \
|
||||||
|
|
10
net/ntp/files/patch-sntp_tests_Makefile.in
Normal file
10
net/ntp/files/patch-sntp_tests_Makefile.in
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- sntp/tests/Makefile.in.orig 2015-10-27 12:47:07 UTC
|
||||||
|
+++ sntp/tests/Makefile.in
|
||||||
|
@@ -791,6 +791,7 @@ LDADD = \
|
||||||
|
$(base_LDADD) \
|
||||||
|
$(top_builddir)/unity/libunity.a \
|
||||||
|
$(LIBM) \
|
||||||
|
+ $(PTHREAD_LIBS) \
|
||||||
|
$(NULL)
|
||||||
|
|
||||||
|
AM_CFLAGS = $(CFLAGS_NTP)
|
Loading…
Reference in a new issue