x11-wm/jewel: Mark DEPRECATED
- Update WWW - Last upstream release was in 2004 - Set EXPIRATION_DATE 2024-01-19 - Refresh patches
This commit is contained in:
parent
4b8839af1a
commit
0bfbe35807
20 changed files with 87 additions and 86 deletions
|
@ -6,11 +6,14 @@ MASTER_SITES= http://mjr.towers.org.uk/comp/
|
|||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Window manager based on aewm++
|
||||
WWW= http://www.mjr.dsl.pipex.com/xwinman.html #jewel
|
||||
WWW= https://mjr.towers.org.uk/xwinman.html #jewel
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
DEPRECATED= Last upstream release was in 2004
|
||||
EXPIRATION_DATE= 2024-01-19
|
||||
|
||||
USES= compiler gmake xorg
|
||||
USE_CXXSTD= c++14
|
||||
USE_XORG= x11 xext xpm
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Makefile.orig 2005-01-03 22:54:59.000000000 +0100
|
||||
+++ Makefile 2013-09-28 12:52:00.901277718 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
--- Makefile.orig 2005-01-03 21:54:59 UTC
|
||||
+++ Makefile
|
||||
@@ -12,7 +12,7 @@ CFLAGS = -g -O2 -Wall
|
||||
CC = g++
|
||||
CFLAGS = -g -O2 -Wall
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
export XROOT = $(prefix)
|
||||
DESTDIR =
|
||||
INCLUDES = -I$(XROOT)/include
|
||||
@@ -51,7 +51,7 @@
|
||||
@@ -51,7 +51,7 @@ $(SUBDIRS):
|
||||
$(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
|
||||
|
||||
$(SUBDIRS):
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- basemenu.hh.orig Mon Aug 19 17:53:47 2002
|
||||
+++ basemenu.hh Tue Apr 8 19:53:56 2003
|
||||
--- basemenu.hh.orig 2005-01-03 21:54:59 UTC
|
||||
+++ basemenu.hh
|
||||
@@ -24,6 +24,8 @@
|
||||
#ifndef _BASEMENU_HH_
|
||||
#define _BASEMENU_HH_
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- goodies/appbar/image.cc.orig 2013-09-26 16:59:32.000000000 +0200
|
||||
+++ goodies/appbar/image.cc 2013-09-26 17:00:23.000000000 +0200
|
||||
@@ -24,6 +24,7 @@
|
||||
#endif
|
||||
|
||||
#include "image.hh"
|
||||
+#include <cstdlib>
|
||||
|
||||
#ifndef MIN
|
||||
# define MIN(a, b) ((a < b) ? a : b)
|
|
@ -1,10 +0,0 @@
|
|||
--- goodies/setrootimage/image.cc.orig 2013-09-26 17:16:12.000000000 +0200
|
||||
+++ goodies/setrootimage/image.cc 2013-09-26 17:16:27.000000000 +0200
|
||||
@@ -24,6 +24,7 @@
|
||||
#endif
|
||||
|
||||
#include "image.hh"
|
||||
+#include <cstdlib>
|
||||
|
||||
#ifndef MIN
|
||||
# define MIN(a, b) ((a < b) ? a : b)
|
|
@ -1,10 +0,0 @@
|
|||
--- goodies/setrootimage/image.hh.orig 2007-12-06 21:28:22.000000000 +0100
|
||||
+++ goodies/setrootimage/image.hh 2007-12-06 21:34:53.000000000 +0100
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <cstdio>
|
||||
|
||||
#include <list>
|
||||
+using namespace std;
|
||||
|
||||
class BImageControl;
|
||||
class BImage;
|
|
@ -1,5 +1,5 @@
|
|||
--- goodies/appbar/icon.cc.orig 2007-12-06 21:09:37.000000000 +0100
|
||||
+++ goodies/appbar/icon.cc 2007-12-06 21:15:12.000000000 +0100
|
||||
--- goodies/appbar/icon.cc.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/appbar/icon.cc
|
||||
@@ -35,7 +35,7 @@
|
||||
|
||||
#include "icon.hh"
|
||||
|
@ -9,7 +9,7 @@
|
|||
"16 16 16 1",
|
||||
" c None",
|
||||
". c #323232",
|
||||
@@ -101,7 +101,7 @@
|
||||
@@ -101,7 +101,7 @@ Icon::Icon(Display *d, Window parent)
|
||||
|
||||
if(! XpmCreatePixmapFromData(dpy,
|
||||
icon_win,
|
||||
|
@ -18,7 +18,7 @@
|
|||
&icon_pixmap,
|
||||
&icon_pixmap_mask,
|
||||
&icon_pixmap_attr)==XpmSuccess)
|
||||
@@ -165,7 +165,7 @@
|
||||
@@ -165,7 +165,7 @@ bool Icon::loadPixmap(std::string iconFilename)
|
||||
|
||||
if(! XpmCreatePixmapFromData(dpy,
|
||||
icon_win,
|
|
@ -1,5 +1,5 @@
|
|||
--- goodies/appbar/icon.hh.orig 2007-12-06 21:10:35.000000000 +0100
|
||||
+++ goodies/appbar/icon.hh 2007-12-06 21:12:21.000000000 +0100
|
||||
--- goodies/appbar/icon.hh.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/appbar/icon.hh
|
||||
@@ -43,8 +43,6 @@
|
||||
#include <X11/extensions/shape.h>
|
||||
#include <stdlib.h>
|
10
x11-wm/jewel/files/patch-goodies_appbar_image.cc
Normal file
10
x11-wm/jewel/files/patch-goodies_appbar_image.cc
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- goodies/appbar/image.cc.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/appbar/image.cc
|
||||
@@ -24,6 +24,7 @@
|
||||
#endif
|
||||
|
||||
#include "image.hh"
|
||||
+#include <cstdlib>
|
||||
|
||||
#ifndef MIN
|
||||
# define MIN(a, b) ((a < b) ? a : b)
|
|
@ -1,5 +1,5 @@
|
|||
--- goodies/appbar/main.cc.orig 2007-12-06 20:48:09.000000000 +0100
|
||||
+++ goodies/appbar/main.cc 2007-12-06 20:48:46.000000000 +0100
|
||||
--- goodies/appbar/main.cc.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/appbar/main.cc
|
||||
@@ -33,6 +33,9 @@
|
||||
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
*/
|
|
@ -1,6 +1,6 @@
|
|||
--- goodies/appbar/scanner.cc.orig 2007-12-06 20:49:35.000000000 +0100
|
||||
+++ goodies/appbar/scanner.cc 2007-12-06 20:50:28.000000000 +0100
|
||||
@@ -156,7 +156,7 @@
|
||||
--- goodies/appbar/scanner.cc.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/appbar/scanner.cc
|
||||
@@ -156,7 +156,7 @@ void Scanner::concat(int type)
|
||||
{
|
||||
s_token.empty();
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
{
|
||||
s_token += character;
|
||||
|
||||
@@ -177,7 +177,7 @@
|
||||
@@ -177,7 +177,7 @@ void Scanner::getNextToken(bool spaces)
|
||||
if (!spaces) {
|
||||
char_class[' ']=whitespace;
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
|||
{
|
||||
if( inputFile.eof() ) return;
|
||||
|
||||
@@ -192,7 +192,7 @@
|
||||
@@ -192,7 +192,7 @@ void Scanner::getNextToken(bool spaces)
|
||||
}
|
||||
}
|
||||
|
|
@ -1,21 +1,20 @@
|
|||
--- goodies/fspanel/Makefile.orig 2005-01-03 22:54:58.000000000 +0100
|
||||
+++ goodies/fspanel/Makefile 2013-09-26 17:14:21.000000000 +0200
|
||||
@@ -1,8 +1,10 @@
|
||||
--- goodies/fspanel/Makefile.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/fspanel/Makefile
|
||||
@@ -1,7 +1,9 @@
|
||||
-CC = gcc
|
||||
-C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I$(XROOT)/include -m386 -malign-loops=2 -malign-jumps=2 -malign-functions=2
|
||||
+CC ?= gcc
|
||||
+C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I$(XROOT)/include -falign-functions=2 --std=c++14
|
||||
L_FLAGS = -O1 -Xlinker -s -L$(XROOT)/lib -lX11 -lXpm
|
||||
PROGNAME = fspanel
|
||||
|
||||
+all: $(PROGNAME)
|
||||
+
|
||||
+all: $(PROGNAME)
|
||||
|
||||
$(PROGNAME): Makefile fspanel.c fspanel.h icon.xpm
|
||||
$(CC) $(C_FLAGS) $(L_FLAGS) fspanel.c -o $(PROGNAME)
|
||||
@ls -l $(PROGNAME)
|
||||
@@ -14,4 +16,4 @@
|
||||
@@ -14,4 +16,4 @@ uninstall:
|
||||
cp -r $(PROGNAME) $(DESTDIR)$(prefix)/bin
|
||||
|
||||
|
||||
uninstall:
|
||||
- rm $(DESTDIR)$(prefix)/bin/$(PROGNAME)
|
||||
\ No newline at end of file
|
|
@ -1,6 +1,6 @@
|
|||
--- goodies/fspanel/fspanel.c.orig 2005-01-03 22:54:58.000000000 +0100
|
||||
+++ goodies/fspanel/fspanel.c 2013-09-26 17:27:52.000000000 +0200
|
||||
@@ -179,7 +179,7 @@
|
||||
--- goodies/fspanel/fspanel.c.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/fspanel/fspanel.c
|
||||
@@ -179,7 +179,7 @@ void turn_off_strut()
|
||||
XDeleteProperty(dd, win, net_wm_strut);
|
||||
}
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
{
|
||||
Atom type_ret;
|
||||
int format_ret;
|
||||
@@ -195,7 +195,7 @@
|
||||
@@ -195,7 +195,7 @@ void *get_prop_data (Window win, Atom prop, Atom type,
|
||||
if (items)
|
||||
*items = items_ret;
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
|||
}
|
||||
|
||||
void get_task_hinticon (task *tk)
|
||||
@@ -393,7 +393,8 @@
|
||||
@@ -393,7 +393,8 @@ void scale_icon (task *tk)
|
||||
|
||||
void scale_icon (task *tk)
|
||||
{
|
||||
|
@ -28,7 +28,7 @@
|
|||
Pixmap pix, mk = None;
|
||||
XGCValues gcv;
|
||||
GC mgc=None;
|
||||
@@ -746,7 +747,7 @@
|
||||
@@ -746,7 +747,7 @@ taskbar *gui_create_taskbar (void)
|
||||
|
||||
XMapWindow (dd, win);
|
||||
|
||||
|
@ -37,7 +37,7 @@
|
|||
tb->win = win;
|
||||
|
||||
return tb;
|
||||
@@ -760,10 +761,10 @@
|
||||
@@ -760,10 +761,10 @@ void add_task (taskbar * tb, Window win, int focus)
|
||||
if (tb->my_desktop != find_desktop (win) || is_hidden (win))
|
||||
return;
|
||||
|
||||
|
@ -50,7 +50,7 @@
|
|||
tk->iconified = is_iconified (win);
|
||||
|
||||
get_task_kdeicon (tk);
|
||||
@@ -1075,7 +1076,7 @@
|
||||
@@ -1075,7 +1076,7 @@ void handle_propertynotify (taskbar * tb, Window win,
|
||||
/* window's title changed */
|
||||
if (tk->name)
|
||||
XFree (tk->name);
|
|
@ -1,6 +1,6 @@
|
|||
--- goodies/fspanel/fspanel.h.orig 2013-09-26 17:22:27.000000000 +0200
|
||||
+++ goodies/fspanel/fspanel.h 2013-09-26 17:22:37.000000000 +0200
|
||||
@@ -55,7 +55,7 @@
|
||||
--- goodies/fspanel/fspanel.h.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/fspanel/fspanel.h
|
||||
@@ -55,7 +55,7 @@ void set_top_strut();
|
||||
|
||||
void set_bottom_strut();
|
||||
void set_top_strut();
|
|
@ -1,5 +1,5 @@
|
|||
--- goodies/setrootimage/Makefile.orig 2013-09-26 17:15:12.000000000 +0200
|
||||
+++ goodies/setrootimage/Makefile 2013-09-26 17:16:58.000000000 +0200
|
||||
--- goodies/setrootimage/Makefile.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/setrootimage/Makefile
|
||||
@@ -1,5 +1,5 @@
|
||||
-CC = g++
|
||||
-CFLAGS = -g -O2 -Wall
|
10
x11-wm/jewel/files/patch-goodies_setrootimage_image.cc
Normal file
10
x11-wm/jewel/files/patch-goodies_setrootimage_image.cc
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- goodies/setrootimage/image.cc.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/setrootimage/image.cc
|
||||
@@ -24,6 +24,7 @@
|
||||
#endif
|
||||
|
||||
#include "image.hh"
|
||||
+#include <cstdlib>
|
||||
|
||||
#ifndef MIN
|
||||
# define MIN(a, b) ((a < b) ? a : b)
|
10
x11-wm/jewel/files/patch-goodies_setrootimage_image.hh
Normal file
10
x11-wm/jewel/files/patch-goodies_setrootimage_image.hh
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- goodies/setrootimage/image.hh.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/setrootimage/image.hh
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <cstdio>
|
||||
|
||||
#include <list>
|
||||
+using namespace std;
|
||||
|
||||
class BImageControl;
|
||||
class BImage;
|
|
@ -1,5 +1,5 @@
|
|||
--- goodies/setrootimage/setrootimage.cc.orig 2007-12-06 21:20:21.000000000 +0100
|
||||
+++ goodies/setrootimage/setrootimage.cc 2007-12-06 21:24:15.000000000 +0100
|
||||
--- goodies/setrootimage/setrootimage.cc.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/setrootimage/setrootimage.cc
|
||||
@@ -31,6 +31,9 @@
|
||||
* Released under the GNU GPL license
|
||||
* www.gnu.org
|
||||
|
@ -10,7 +10,7 @@
|
|||
#include <X11/Xlib.h>
|
||||
#include <X11/xpm.h>
|
||||
#include <stdlib.h>
|
||||
@@ -56,10 +59,11 @@
|
||||
@@ -56,10 +59,11 @@ BColor parseCommandlineColor(char* the_color)
|
||||
temp_blue[1] = the_color[i];
|
||||
}
|
||||
|
||||
|
@ -24,7 +24,7 @@
|
|||
return color;
|
||||
}
|
||||
|
||||
@@ -86,10 +90,10 @@
|
||||
@@ -86,10 +90,10 @@ int main (int argc, char * argv[])
|
||||
Pixmap root_pix = None;
|
||||
BColor to, from;
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- goodies/xsession//Makefile.orig 2007-12-06 22:50:47.000000000 +0100
|
||||
+++ goodies/xsession//Makefile 2007-12-06 22:51:06.000000000 +0100
|
||||
@@ -1,10 +1,12 @@
|
||||
--- goodies/xsession/Makefile.orig 2005-01-03 21:54:58 UTC
|
||||
+++ goodies/xsession/Makefile
|
||||
@@ -1,9 +1,11 @@ CC = gcc
|
||||
# Taken from fspanel Makefile by MJR
|
||||
|
||||
CC = gcc
|
||||
|
@ -8,9 +8,8 @@
|
|||
+C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I$(XROOT)/include -falign-functions=2
|
||||
L_FLAGS = -O1 -Xlinker -s -L$(XROOT)/lib -lX11 -lXpm
|
||||
PROGNAME = xsession
|
||||
|
||||
+all: $(PROGNAME)
|
||||
+
|
||||
+all: $(PROGNAME)
|
||||
|
||||
$(PROGNAME): Makefile xsession.c
|
||||
$(CC) $(C_FLAGS) $(L_FLAGS) xsession.c -o $(PROGNAME)
|
||||
@ls -l $(PROGNAME)
|
|
@ -1,6 +1,6 @@
|
|||
--- windowmanager.cc.orig 2007-12-06 20:41:35.000000000 +0100
|
||||
+++ windowmanager.cc 2007-12-06 20:47:01.000000000 +0100
|
||||
@@ -51,24 +51,24 @@
|
||||
--- windowmanager.cc.orig 2005-01-03 21:54:59 UTC
|
||||
+++ windowmanager.cc
|
||||
@@ -51,24 +51,24 @@ WindowManager::WindowManager(int argc, char** argv)
|
||||
// Set the global window manager object to this please =)
|
||||
wm = this;
|
||||
|
||||
|
@ -39,7 +39,7 @@
|
|||
|
||||
// These macro's are nice to test values passed in
|
||||
// the command line arguments
|
||||
@@ -1557,21 +1557,21 @@
|
||||
@@ -1557,21 +1557,21 @@ void WindowManager::focusNextWindowInStackingOrder()
|
||||
// find the client in the list...
|
||||
it = find(clientList->begin(), clientList->end(), c);
|
||||
|
||||
|
@ -66,7 +66,7 @@
|
|||
} while (cycles < clientList->size() && (shouldSkipThisWindow((*it)->getAppWindow()) || (*it)->isIconified() || (*it)->belongsToWhichDesktop() != currentDesktop));
|
||||
|
||||
#ifdef DEBUG
|
||||
@@ -1588,7 +1588,7 @@
|
||||
@@ -1588,7 +1588,7 @@ void WindowManager::focusNextWindowInStackingOrder()
|
||||
|
||||
// if we found a suitable "next client", raise and focus
|
||||
// it; otherwise, leave focus where it is
|
||||
|
|
Loading…
Reference in a new issue