- Remove USE_AUTOTOOLS=libtool

- Add USE_AUTOTOOLS=libtoolize (and others) because the configure script
  hasn't been generated with the same version of libtool as the bundled
  ltmain.sh script
- Remove -fPIC and --with-pic
This commit is contained in:
Tijl Coosemans 2014-09-11 20:57:56 +00:00
parent 6b66f82264
commit 0bfc0ed369
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=367980
15 changed files with 93 additions and 106 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= rrdtool
PORTVERSION= 1.0.50
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= databases
MASTER_SITES= http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.0.x/
PKGNAMESUFFIX= 10
@ -16,15 +16,16 @@ MAKE_ENV= PERL=${PERL}
CONFLICTS= rrdtool12-* rrdtool-1.*
USES= pkgconfig perl5 libtool
USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
AUTOMAKE_ARGS= -a -c -f
USE_PERL5= build run fixpacklist
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib \
--program-transform-name=''
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --enable-local-zlib
CONFIGURE_ENV= PERL=${PERL} PERL_MAKE_OPTIONS="PREFIX=${PREFIX}"
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS:= ${CFLAGS:N-ffast-math}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
@ -33,22 +34,6 @@ LATIN2_DESC= ISO-8859-2 fonts support
LATIN2_CONFIGURE_ENABLE= latin2
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
CONFIGURE_ARGS+=--with-pic
.endif
.if ${ARCH} == "ia64"
BROKEN= Does not build on ia64
.endif
post-install:
.if !defined(BATCH)
@${ECHO_MSG} ""
@${ECHO_MSG} "############################################################################"
@${ECHO_MSG} "# See ${PREFIX}/share/examples/rrdtool for some demonstration code #"
@${ECHO_MSG} "############################################################################"
.endif
BROKEN_ia64= Does not build on ia64
.include <bsd.port.mk>

View file

@ -1,6 +1,6 @@
--- Makefile.in.orig Sun Aug 8 12:40:15 2004
+++ Makefile.in Wed Mar 16 21:26:50 2005
@@ -701,21 +701,7 @@
--- Makefile.am.orig 2004-08-04 15:20:32 UTC
+++ Makefile.am
@@ -33,21 +33,7 @@
# lets schedule the perl stuff for installation
# the special call to install-sh is because the -d switch is not portable
# mac os X has its perl module in bundles so it seems
@ -21,9 +21,9 @@
- fi
+install-data-local: site-perl-inst
# rules for building the perl module
@@ -795,8 +781,8 @@
# use relaxed rules when building dists
@@ -137,8 +123,8 @@
site-perl-inst: site-perl-install
site-perl-install: all perl-piped/Makefile perl-shared/Makefile

View file

@ -1,20 +0,0 @@
--- ./configure.orig 2014-07-23 22:31:53.000000000 +0200
+++ ./configure 2014-07-23 22:32:14.000000000 +0200
@@ -24873,17 +24873,12 @@
echo "${ECHO_T}and out again" >&6
echo $ECHO_N "ordering CD from http://people.ee.ethz.ch/~oetiker/wish $ac_c" 1>&6
-sleep 1
echo $ECHO_N ".$ac_c" 1>&6
-sleep 2
echo $ECHO_N ".$ac_c" 1>&6
-sleep 1
echo $ECHO_N ".$ac_c" 1>&6
-sleep 3
echo $ECHO_N ".$ac_c" 1>&6
echo $ECHO_N ".$ac_c" 1>&6
echo $ECHO_N ".$ac_c" 1>&6
-sleep 2
echo "$as_me:$LINENO: result: just kidding ;-)" >&5
echo "${ECHO_T} just kidding ;-)" >&6
echo

View file

@ -0,0 +1,25 @@
--- configure.ac.orig 2005-04-25 20:46:33 UTC
+++ configure.ac
@@ -393,22 +393,6 @@
chmod +x examples/*.cgi examples/*.pl contrib/*/*.pl]],[[]])
AC_OUTPUT
-AC_MSG_CHECKING(in)
-AC_MSG_RESULT(and out again)
-
-echo $ECHO_N "ordering CD from http://people.ee.ethz.ch/~oetiker/wish $ac_c" 1>&6
-sleep 1
-echo $ECHO_N ".$ac_c" 1>&6
-sleep 2
-echo $ECHO_N ".$ac_c" 1>&6
-sleep 1
-echo $ECHO_N ".$ac_c" 1>&6
-sleep 3
-echo $ECHO_N ".$ac_c" 1>&6
-echo $ECHO_N ".$ac_c" 1>&6
-echo $ECHO_N ".$ac_c" 1>&6
-sleep 2
-AC_MSG_RESULT([ just kidding ;-)])
echo
echo "----------------------------------------------------------------"
echo "Config is DONE!"

View file

@ -0,0 +1,10 @@
--- contrib/Makefile.am.orig 2002-02-26 10:21:19 UTC
+++ contrib/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
SUBDIRS = trytime
-contribdir = $(prefix)/contrib
+contribdir = $(prefix)/share/examples/rrdtool
contrib_DATA = README
EXTRA_DIST = rrdview log2rrd rrd-file-icon rrdproc rrdlastds add_ds killspike rrdfetchnames snmpstats rrdexplorer php3 php4

View file

@ -1,11 +0,0 @@
--- ./contrib/Makefile.in.orig 2005-04-25 22:47:51.000000000 +0200
+++ ./contrib/Makefile.in 2014-08-31 16:52:48.000000000 +0200
@@ -195,7 +195,7 @@
target_os = @target_os@
target_vendor = @target_vendor@
SUBDIRS = trytime
-contribdir = $(prefix)/contrib
+contribdir = $(prefix)/share/examples/rrdtool
contrib_DATA = README
EXTRA_DIST = rrdview log2rrd rrd-file-icon rrdproc rrdlastds add_ds killspike rrdfetchnames snmpstats rrdexplorer php3 php4
all: all-recursive

View file

@ -0,0 +1,11 @@
--- contrib/trytime/Makefile.am.orig 2003-11-30 22:00:24 UTC
+++ contrib/trytime/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to produce Makefile.in
AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/gd1.3
EXTRA_DIST = trytime.c
-contribdir = $(prefix)/contrib/trytime
+contribdir = $(prefix)/share/examples/rrdtool/trytime
contrib_DATA = README trytime.c
bin_PROGRAMS = trytime
trytime_SOURCES = trytime.c

View file

@ -1,11 +0,0 @@
--- ./contrib/trytime/Makefile.in.orig 2005-04-25 22:47:51.000000000 +0200
+++ ./contrib/trytime/Makefile.in 2014-08-31 16:52:48.000000000 +0200
@@ -209,7 +209,7 @@
target_vendor = @target_vendor@
AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/gd1.3
EXTRA_DIST = trytime.c
-contribdir = $(prefix)/contrib/trytime
+contribdir = $(prefix)/share/examples/rrdtool/trytime
contrib_DATA = README trytime.c
trytime_SOURCES = trytime.c
trytime_LDADD = ../../src/librrd.la

View file

@ -0,0 +1,14 @@
--- doc/Makefile.am.orig 2005-04-25 21:02:27 UTC
+++ doc/Makefile.am
@@ -25,9 +25,9 @@
EXTRA_DIST= $(POD) $(HTML) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
# some install rules
-idocdir = $(prefix)/doc
+idocdir = $(prefix)/share/doc/rrdtool
idoc_DATA = $(POD) $(TXT)
-ihtmldir = $(prefix)/html
+ihtmldir = $(prefix)/share/doc/rrdtool/html
ihtml_DATA = $(HTML)
imandir = $(mandir)/man1
iman_DATA = $(MAN)

View file

@ -1,14 +0,0 @@
--- ./doc/Makefile.in.orig 2005-04-25 23:02:47.000000000 +0200
+++ ./doc/Makefile.in 2014-08-31 16:52:48.000000000 +0200
@@ -210,9 +210,9 @@
EXTRA_DIST = $(POD) $(HTML) $(TXT) rrdtool-dump.dtd rrdtool-xport.dtd
# some install rules
-idocdir = $(prefix)/doc
+idocdir = $(prefix)/share/doc/rrdtool/
idoc_DATA = $(POD) $(TXT)
-ihtmldir = $(prefix)/html
+ihtmldir = $(prefix)/share/doc/rrdtool/html
ihtml_DATA = $(HTML)
imandir = $(mandir)/man1
iman_DATA = $(MAN)

View file

@ -0,0 +1,9 @@
--- examples/Makefile.am.orig 2002-02-26 10:21:25 UTC
+++ examples/Makefile.am
@@ -6,5 +6,5 @@
EXTRA_DIST = cgi-demo.cgi.in piped-demo.pl.in shared-demo.pl.in stripes.pl.in bigtops.pl.in minmax.pl.in
-examplesdir = $(prefix)/examples
+examplesdir = $(prefix)/share/examples/rrdtool
examples_SCRIPTS = cgi-demo.cgi piped-demo.pl shared-demo.pl stripes.pl bigtops.pl minmax.pl

View file

@ -1,11 +0,0 @@
--- examples/Makefile.in.orig Sat Jul 23 13:27:58 2005
+++ examples/Makefile.in Sat Jul 23 13:29:30 2005
@@ -188,7 +188,7 @@
target_os = @target_os@
target_vendor = @target_vendor@
EXTRA_DIST = cgi-demo.cgi.in piped-demo.pl.in shared-demo.pl.in stripes.pl.in bigtops.pl.in minmax.pl.in
-examplesdir = $(prefix)/examples
+examplesdir = $(prefix)/share/examples/rrdtool
examples_SCRIPTS = cgi-demo.cgi piped-demo.pl shared-demo.pl stripes.pl bigtops.pl minmax.pl
all: all-am

View file

@ -1,11 +0,0 @@
--- perl-shared/Makefile.PL.in.orig Thu Apr 8 01:04:53 2004
+++ perl-shared/Makefile.PL.in Sun Aug 8 18:11:16 2004
@@ -10,7 +10,7 @@
'NAME' => 'RRDs',
'VERSION_FROM' => '@top_srcdir@/perl-shared/RRDs.pm', # finds $VERSION
'DEFINE' => "-DPERLPATCHLEVEL=$Config{PATCHLEVEL}",
- 'INC' => '-I@top_srcdir@ -I@top_srcdir@/src -I@top_srcdir@/gd1.3',
+ 'INC' => '-I../ -I@top_srcdir@ -I@top_srcdir@/src -I@top_srcdir@/gd1.3',
'CCFLAGS' => "$Config{ccflags} -DHAVE_CONFIG_H",
# where to look for the necessary libraries
# Perl will figure out which one is valid

View file

@ -0,0 +1,10 @@
--- src/Makefile.am.orig 2005-03-12 16:59:41 UTC
+++ src/Makefile.am
@@ -91,7 +91,6 @@ librrd_la_LDFLAGS = -version-inf
include_HEADERS = rrd.h
librrd_private_la_LIBADD = $(RRD_LIBS)
-librrd_private_la_LDFLAGS = -static
bin_PROGRAMS = rrdcgi rrdtool rrdupdate

View file

@ -6,6 +6,7 @@ include/rrd.h
lib/librrd.a
lib/librrd.so
lib/librrd.so.0
lib/librrd.so.0.0.0
%%PERL5_MAN3%%/RRDp.3.gz
%%PERL5_MAN3%%/RRDs.3.gz
%%SITE_PERL%%/RRDp.pm