- Update to version 2009-06-R1
This commit is contained in:
parent
3f10d7d21e
commit
0c136f6926
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=238379
4 changed files with 53 additions and 19 deletions
|
@ -6,14 +6,15 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= spectools
|
PORTNAME= spectools
|
||||||
PORTVERSION= 200710.r2
|
PORTVERSION= 200906.r1
|
||||||
PORTREVISION= 1
|
|
||||||
CATEGORIES= net-mgmt
|
CATEGORIES= net-mgmt
|
||||||
MASTER_SITES= http://www.kismetwireless.net/code/
|
MASTER_SITES= http://www.kismetwireless.net/code/ \
|
||||||
DISTNAME= spectools-2007-10-R2
|
${MASTER_SITE_LOCAL}
|
||||||
|
MASTER_SITE_SUBDIR= brix
|
||||||
|
DISTNAME= spectools-2009-06-R1
|
||||||
|
|
||||||
MAINTAINER= brix@FreeBSD.org
|
MAINTAINER= brix@FreeBSD.org
|
||||||
COMMENT= Tools for the 2.4GHz Wi-Spy spectrum analyzers from MetaGeek LLC
|
COMMENT= Tools for the Wi-Spy spectrum analyzers from MetaGeek LLC
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||||
|
@ -22,7 +23,27 @@ USE_GMAKE= yes
|
||||||
|
|
||||||
PORTDOCS= README
|
PORTDOCS= README
|
||||||
|
|
||||||
OPTIONS= GTK "Enable graphical client" On
|
OPTIONS= GTK "Enable graphical client" On \
|
||||||
|
NCURSES "Enable ncurses client" On
|
||||||
|
|
||||||
|
ALL_TARGET= spectool_net spectool_raw
|
||||||
|
|
||||||
|
.include <bsd.port.options.mk>
|
||||||
|
|
||||||
|
.if defined(WITH_GTK)
|
||||||
|
ALL_TARGET+= spectool_gtk
|
||||||
|
LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
|
||||||
|
PLIST_SUB+= GTK=""
|
||||||
|
.else
|
||||||
|
PLIST_SUB+= GTK="@comment "
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.if defined(WITH_NCURSES)
|
||||||
|
ALL_TARGET+= spectool_curses
|
||||||
|
PLIST_SUB+= NCURSES=""
|
||||||
|
.else
|
||||||
|
PLIST_SUB+= NCURSES="@comment "
|
||||||
|
.endif
|
||||||
|
|
||||||
.include <bsd.port.pre.mk>
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
@ -36,22 +57,15 @@ IGNORE= is unsupported on systems prior to FreeBSD v700027
|
||||||
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
|
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
ALL_TARGET= spectool_net spectool_raw
|
|
||||||
|
|
||||||
.if defined(WITH_GTK)
|
|
||||||
ALL_TARGET+= spectool_gtk
|
|
||||||
LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
|
|
||||||
PLIST_SUB= GTK=""
|
|
||||||
.else
|
|
||||||
PLIST_SUB= GTK="@comment "
|
|
||||||
.endif
|
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/spectool_net ${PREFIX}/bin
|
${INSTALL_PROGRAM} ${WRKSRC}/spectool_net ${PREFIX}/bin
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/spectool_raw ${PREFIX}/bin
|
${INSTALL_PROGRAM} ${WRKSRC}/spectool_raw ${PREFIX}/bin
|
||||||
.if defined(WITH_GTK)
|
.if defined(WITH_GTK)
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/spectool_gtk ${PREFIX}/bin
|
${INSTALL_PROGRAM} ${WRKSRC}/spectool_gtk ${PREFIX}/bin
|
||||||
.endif
|
.endif
|
||||||
|
.if defined(WITH_NCURSES)
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/spectool_curses ${PREFIX}/bin
|
||||||
|
.endif
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
.if !defined(NOPORTDOCS)
|
.if !defined(NOPORTDOCS)
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (spectools-2007-10-R2.tar.gz) = 1796b9c454a624936efdd8d95faf0da1
|
MD5 (spectools-2009-06-R1.tar.gz) = b84c8303416755101b8f1a1b37d77164
|
||||||
SHA256 (spectools-2007-10-R2.tar.gz) = fc79ad4f32276fab2da17c28a7af514085612eb479a59d79b1e7349f1e321756
|
SHA256 (spectools-2009-06-R1.tar.gz) = 0d40c31933b4718c82cdab1c36a42be8fcccec1d642c8438e1aa2ff4868d56f2
|
||||||
SIZE (spectools-2007-10-R2.tar.gz) = 198839
|
SIZE (spectools-2009-06-R1.tar.gz) = 184614
|
||||||
|
|
19
net-mgmt/spectools/files/patch-wispy_hw_dbx.c
Normal file
19
net-mgmt/spectools/files/patch-wispy_hw_dbx.c
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
--- wispy_hw_dbx.c.orig 2009-07-26 13:55:31.000000000 +0200
|
||||||
|
+++ wispy_hw_dbx.c 2009-07-26 13:55:57.000000000 +0200
|
||||||
|
@@ -624,16 +624,12 @@ int wispydbx_usb_getpollfd(wispy_phy *ph
|
||||||
|
return auxptr->sockpair[0];
|
||||||
|
}
|
||||||
|
|
||||||
|
-extern int usb_debug;
|
||||||
|
-
|
||||||
|
int wispydbx_usb_open(wispy_phy *phydev) {
|
||||||
|
int pid_status;
|
||||||
|
struct usb_dev_handle *wispy;
|
||||||
|
wispydbx_usb_aux *auxptr = (wispydbx_usb_aux *) phydev->auxptr;
|
||||||
|
wispydbx_startsweep startcmd;
|
||||||
|
|
||||||
|
- usb_debug = 1024;
|
||||||
|
-
|
||||||
|
/* Make the client/server socketpair */
|
||||||
|
if (socketpair(PF_UNIX, SOCK_DGRAM, 0, auxptr->sockpair) < 0) {
|
||||||
|
snprintf(phydev->errstr, WISPY_ERROR_MAX,
|
|
@ -1,3 +1,4 @@
|
||||||
%%GTK%%bin/spectool_gtk
|
%%GTK%%bin/spectool_gtk
|
||||||
|
%%NCURSES%%bin/spectool_curses
|
||||||
bin/spectool_net
|
bin/spectool_net
|
||||||
bin/spectool_raw
|
bin/spectool_raw
|
||||||
|
|
Loading…
Reference in a new issue