Add "baloofiles" to the list of exported CMake libraries.
In practice, this means linking against "baloofiles" in CMake passes "/full/path/to/libbaloofiles.so" instead of "-lbaloofiles" to the linker. The latter may fail if -L/full/path/to is not passed as well.
This commit is contained in:
parent
a3578aaa47
commit
0c191565eb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=436959
2 changed files with 29 additions and 1 deletions
|
@ -2,7 +2,7 @@
|
|||
|
||||
PORTNAME= baloo
|
||||
PORTVERSION= ${KDE4_VERSION}
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= sysutils kde kde-kde4
|
||||
|
||||
MAINTAINER= kde@FreeBSD.org
|
||||
|
|
28
sysutils/baloo/files/patch-src_file_lib_CMakeLists.txt
Normal file
28
sysutils/baloo/files/patch-src_file_lib_CMakeLists.txt
Normal file
|
@ -0,0 +1,28 @@
|
|||
Backport of the "export baloofiles with the rest of the targets" part.
|
||||
|
||||
This is necessary so that the CMake exports file has an entry for baloofiles,
|
||||
and linking against it passes "/full/path/to/libbaloofiles.so" instead of
|
||||
"-lbaloofiles" to the linker. The latter may fail if -L/full/path/to is not
|
||||
passed as well.
|
||||
|
||||
commit 66068074c64b2a4a68a3dda567904704b0ae1f02
|
||||
Author: Aleix Pol <aleixpol@kde.org>
|
||||
Date: Wed Mar 12 17:51:02 2014 +0100
|
||||
|
||||
Improvements on Baloo's cmake architecture
|
||||
|
||||
Install a file indicating the version
|
||||
Port linking variables into the proper targets
|
||||
Export baloofiles with the rest of the targets
|
||||
|
||||
--- src/file/lib/CMakeLists.txt
|
||||
+++ src/file/lib/CMakeLists.txt
|
||||
@@ -33,7 +33,7 @@ set_target_properties(baloofiles PROPERTIES
|
||||
SOVERSION ${BALOO_VERSION_MAJOR}
|
||||
)
|
||||
|
||||
-install(TARGETS baloofiles ${INSTALL_TARGETS_DEFAULT_ARGS})
|
||||
+install(TARGETS baloofiles EXPORT BalooLibraryTargets ${INSTALL_TARGETS_DEFAULT_ARGS})
|
||||
|
||||
install(FILES
|
||||
file.h
|
Loading…
Reference in a new issue