- Make this port actually working (previous version was not linking binary

core with the kld);
- hand over maintainership to Alexander Matey <matey@cis.ohio-state.edu> - he
  is the author of the driver;
- make sure that the correct version of the driver used for some earler
  version of 4-STABLE (1.1 for 4.1) and refuse to build if OSVERSION < 410002.

Submitted by:		Alexander Matey <matey@cis.ohio-state.edu>
Slightly adjusted by:	sobomax
This commit is contained in:
Maxim Sobolev 2001-01-16 08:54:45 +00:00
parent e23900a733
commit 0c29cb8687
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37241
7 changed files with 27 additions and 19 deletions

View file

@ -7,11 +7,12 @@
PORTNAME= aureal-kmod
PORTVERSION= 1.5
CATEGORIES= misc
PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.cis.ohio-state.edu/~matey/au88x0/
DISTNAME= au88x0-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
MAINTAINER= matey@cis.ohio-state.edu
NO_PACKAGE= package doesn't make any sense, because kld's should be in sync with running kernel to work correctly
@ -25,8 +26,14 @@ MAKE_ENV= WRKSRC="${WRKSRC}"
.if ${OSVERSION} < 400000
BROKEN= "FreeBSD 3.* isn't supported"
.elif ${OSVERSION} < 410002
BROKEN= "Your FreeBSD 4.1 system is too old. Please update it before installing this port"
.elif ${OSVERSION} < 420000
PORTVERSION= 1.1
DISTNAME= au88x0-${PORTVERSION}_1
.elif ${OSVERSION} < 500000
PORTVERSION= 1.3
DISTNAME= au88x0-${PORTVERSION}_1
.endif
pre-build:

View file

@ -1,2 +1,3 @@
MD5 (au88x0-1.3.tar.gz) = fe88b877286aea052af96fc5a37f9af1
MD5 (au88x0-1.1_1.tar.gz) = 50882437af6e79694e0db2f200b30c8a
MD5 (au88x0-1.3_1.tar.gz) = ec49c6e62847f6a0da318fea8c954917
MD5 (au88x0-1.5.tar.gz) = c0e781dde9624eb1213deb84aeb9d099

View file

@ -1,10 +1,10 @@
$FreeBSD$
--- 10/Makefile.orig Mon Jan 15 18:45:58 2001
+++ 10/Makefile Mon Jan 15 18:46:31 2001
--- 10/Makefile.orig Tue Jan 16 10:43:21 2001
+++ 10/Makefile Tue Jan 16 10:43:50 2001
@@ -0,0 +1,4 @@
+KMOD = snd_au8810
+SRCS += asp10.o
+SRCS = ${WRKSRC}/asp10.o
+
+.include <bsd.kmod.mk>

View file

@ -1,10 +1,10 @@
$FreeBSD$
--- 20/Makefile.orig Mon Jan 15 18:45:59 2001
+++ 20/Makefile Mon Jan 15 18:46:34 2001
--- 20/Makefile.orig Tue Jan 16 10:43:21 2001
+++ 20/Makefile Tue Jan 16 10:43:57 2001
@@ -0,0 +1,4 @@
+KMOD = snd_au8820
+SRCS += asp20.o
+SRCS = ${WRKSRC}/asp20.o
+
+.include <bsd.kmod.mk>

View file

@ -1,10 +1,10 @@
$FreeBSD$
--- 30/Makefile.orig Mon Jan 15 18:45:59 2001
+++ 30/Makefile Mon Jan 15 18:46:37 2001
--- 30/Makefile.orig Tue Jan 16 10:43:21 2001
+++ 30/Makefile Tue Jan 16 10:44:04 2001
@@ -0,0 +1,4 @@
+KMOD = snd_au8830
+SRCS += asp30.o
+SRCS = ${WRKSRC}/asp30.o
+
+.include <bsd.kmod.mk>

View file

@ -7,7 +7,7 @@ $FreeBSD$
+.PATH: /sys/dev/sound/pci ${WRKSRC}
+
+KMODDIR = ${PREFIX}/lib/au88x0
+SRCS = device_if.h bus_if.h isa_if.h pci_if.h
+SRCS += device_if.h bus_if.h isa_if.h pci_if.h
+SRCS += au88x0.c
+.if ${OSVERSION} > 500000
+SRCS += ac97_if.h channel_if.h feeder_if.h mixer_if.h

View file

@ -3,19 +3,19 @@ You can load the module by typing (as root of course):
# kldload %%PREFIX%%/lib/au88x0/snd_au88X0.ko
where X is 1, 2 or 3 depending on which Auread chipset do you have - au8810,
au8820 or au8830 correspondingly.
where X is 1, 2 or 3 depending on which Aureal chipset do you have - au8810
(Vortex Advantage), au8820 (Vortex 1) or au8830 (Vortex 2) correspondingly.
Please note that you are also need to have a `snd_pcm.ko' module either already
Please note that you also need to have a `snd_pcm.ko' module either already
loaded or placed into appropriate location for modules on your system (default
is /modules/ on 4-STABLE and /boot/kernel/ on 5-CURRENT). You can compile and
install snd_pcm by doing:
# cd /sys/modules/sound/pcm/ && make all install
Please also note that module for 4-STABLE system is untested, so please use it
with caution and if possible please report if it work for you or not to
Maxim Sobolev <sobomax@FreeBSD.org>.
Please also note that module for 4.1-STABLE system is untested, so please use it
with caution and if possible please report if it works for you to
Alexander Matey <matey@cis.ohio-state.edu>.
Thanks and enjoy!