Update to version 3.2.3c.
PR: 23278 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
parent
d15b341f53
commit
0c8e320e64
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35869
4 changed files with 17 additions and 42 deletions
|
@ -6,14 +6,14 @@
|
|||
#
|
||||
|
||||
PORTNAME= transfig
|
||||
PORTVERSION= 3.2.3
|
||||
PORTVERSION= 3.2.3c
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
|
||||
ftp://www-epb.lbl.gov/xfig/
|
||||
MASTER_SITE_SUBDIR= applications/drawing_tools/transfig
|
||||
DISTNAME= ${PORTNAME}.${PORTVERSION}
|
||||
|
||||
MAINTAINER= chuckr@freebsd.org
|
||||
MAINTAINER= chuckr@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||
RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm
|
||||
|
@ -22,7 +22,4 @@ USE_IMAKE= yes
|
|||
USE_XPM= yes
|
||||
MAN1= fig2dev.1 fig2ps2tex.1 pic2tpic.1 transfig.1
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/fig2dev/Imakefile
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (transfig.3.2.3.tar.gz) = 1cd02e931b9cf7dfb955694369e72c8c
|
||||
MD5 (transfig.3.2.3c.tar.gz) = cefd377ff3c4ec9aa38a42e98944d9b3
|
||||
|
|
|
@ -1,24 +1,24 @@
|
|||
--- fig2dev/Imakefile.orig Fri Jan 14 12:59:04 2000
|
||||
+++ fig2dev/Imakefile Sat Jan 22 09:16:13 2000
|
||||
@@ -27,7 +27,7 @@
|
||||
--- fig2dev/Imakefile.orig Fri Jul 21 01:38:53 2000
|
||||
+++ fig2dev/Imakefile Sat Jul 29 00:55:31 2000
|
||||
@@ -28,7 +28,7 @@
|
||||
XCOMM You should point XFIGLIBDIR to the same directory you did when you compiled
|
||||
XCOMM and installed xfig. This will be made automatic in the future.
|
||||
|
||||
-XFIGLIBDIR = /usr/local/lib/X11/xfig
|
||||
+XFIGLIBDIR = $(LIBDIR)/xfig
|
||||
|
||||
XCOMM ******
|
||||
XCOMM If your system has the strerror() function (doesn't have sys_errlist) then
|
||||
XCOMM comment out NEED_STRERROR with an XCOMM comment.
|
||||
@@ -38,7 +38,7 @@
|
||||
@@ -47,7 +47,7 @@
|
||||
XCOMM inline functions. With the "INLINE" keyword, you should notice that
|
||||
XCOMM the display will be a bit faster in complex figures
|
||||
|
||||
-XCOMM USEINLINE = -DUSE_INLINE
|
||||
+USEINLINE = -DUSE_INLINE
|
||||
|
||||
XCOMM ****************
|
||||
XCOMM Change RGB if necessary, to point to your rgb.txt color database
|
||||
XCOMM file (for X11). This is needed for the -g (background color) option.
|
||||
@@ -54,11 +54,11 @@
|
||||
@@ -67,11 +67,11 @@
|
||||
XCOMM Change XPMINC if necessary to point to the include file for xpm (xpm.h)
|
||||
XCOMM
|
||||
|
||||
|
@ -31,20 +31,20 @@
|
|||
+XPMINC = -I$(INCDIR)/X11
|
||||
#endif
|
||||
|
||||
XCOMM For Linux machines or any machines that have a separate library for
|
||||
@@ -87,8 +87,8 @@
|
||||
XCOMM ****************
|
||||
@@ -91,8 +91,8 @@
|
||||
|
||||
#ifdef USEJPEG
|
||||
#ifdef USEINSTALLEDJPEG
|
||||
-JPEGLIBDIR = /usr/local/lib
|
||||
-JPEGINCDIR = /usr/include/X11
|
||||
+JPEGLIBDIR = %%LOCALBASE%%/lib
|
||||
+JPEGINCDIR = %%LOCALBASE%%/include
|
||||
+JPEGLIBDIR = ${LOCALBASE}/lib
|
||||
+JPEGINCDIR = ${LOCALBASE}/include
|
||||
#else
|
||||
JPEGLIBDIR = ../jpeg
|
||||
JPEGINCDIR = $(JPEGLIBDIR)
|
||||
@@ -127,12 +127,12 @@
|
||||
|
||||
@@ -141,11 +141,11 @@
|
||||
XCOMM ****************
|
||||
XCOMM Uncomment the next line if you want use Japanese (i18n) on xfig.
|
||||
|
||||
-XCOMM #define I18N
|
||||
|
@ -53,18 +53,7 @@
|
|||
#ifdef I18N
|
||||
I18N_DEFS = -DI18N
|
||||
-FIG2DEV_LIBDIR = /usr/local/lib/fig2dev
|
||||
-I18N_DEV_DEFS = $(I18N_DEFS) -DFIG2DEV_LIBDIR='\"/usr/local/lib/fig2dev\"'
|
||||
+FIG2DEV_LIBDIR = $(LIBDIR)/fig2dev
|
||||
+I18N_DEV_DEFS = $(I18N_DEFS) -DFIG2DEV_LIBDIR='\"$(FIG2DEV_LIBDIR)\"'
|
||||
I18N_DEV_DEFS = $(I18N_DEFS) -DFIG2DEV_LIBDIR=\\\"$(FIG2DEV_LIBDIR)\\\"
|
||||
|
||||
install::
|
||||
[ -d $(FIG2DEV_LIBDIR) ] || mkdir $(FIG2DEV_LIBDIR)
|
||||
@@ -177,7 +177,7 @@
|
||||
DUSEJPEG = -DUSE_JPEG
|
||||
|
||||
#ifdef USEINSTALLEDJPEG
|
||||
-JPEGLIBDIR = /usr/local/lib
|
||||
+JPEGLIBDIR = %%LOCALBASE%%/lib
|
||||
JPEGLIB = -L$(JPEGLIBDIR) -ljpeg
|
||||
#else
|
||||
XCOMM this is relative to this directory (transfig/fig2dev)
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- fig2dev/dev/Imakefile.orig Thu Jan 6 03:30:09 2000
|
||||
+++ fig2dev/dev/Imakefile Sat Jan 22 10:15:39 2000
|
||||
@@ -22,7 +22,7 @@
|
||||
XCOMM the party supplying this software to the X Consortium.
|
||||
|
||||
INCLUDES = -I.. -I../..
|
||||
-#ifdef JPEGINCDIR
|
||||
+#ifdef USE_JPEG
|
||||
JPEGINC = -I$(JPEGINCDIR)
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue