Update to 6.0.20 release:

- fix rc.d script on shutdown
- fix package creation
- keep modified config files on deinstall
- other small enhancements and bugfixes

I'll take maintainership on September if nemoliu will not ping.

PR:		ports/129411, ports/136727
Submitted by:	Jonathan Chen <jonc@chen.org.nz>,
		Mike Jakubik <mikej@rogers.com>
Approved by:	maintainer timeout (months)
This commit is contained in:
Alex Dupre 2009-07-29 13:33:19 +00:00
parent 5d91491fcb
commit 0cd198a0b8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=238618
14 changed files with 1244 additions and 1552 deletions

View file

@ -5,11 +5,12 @@
# $FreeBSD$
#
PORTNAME= apache-tomcat
PORTVERSION= 6.0.18
PORTNAME= tomcat
PORTVERSION= 6.0.20
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-6/v${PORTVERSION}/bin
DISTNAME= apache-${PORTNAME}-${PORTVERSION}
MAINTAINER= nemoliu@FreeBSD.org
COMMENT= Open-source Java web server by Apache, 6.x branch
@ -19,40 +20,32 @@ JAVA_VERSION= 1.5+
NO_BUILD= YES
USE_RC_SUBR= tomcat6.sh
SUB_FILES= pkg-install pkg-deinstall
SUB_FILES= pkg-install
MAJOR_VER= ${PORTVERSION:R}
APP_HOME?= ${PREFIX}/${PKGBASE}${PORTVERSION:R}
APP_HOME?= ${PREFIX}/${DISTNAME:R}
LOG_DIR= ${APP_HOME}/logs
APP_TITLE= Apache Tomcat
APP_SHORTNAME= tomcat${MAJOR_VER:S/.//}
APP_SHORTNAME= ${PORTNAME}${MAJOR_VER:S/.//}
TOMCAT_USER?= www
TOMCAT_GROUP?= www
PW?= /usr/sbin/pw
HTTP_PORT?= 8180
SHUTDOWN_PORT?= 8005
AJP_1_3_PORT?= 8009
STDOUT_LOG= ${LOG_DIR}/stdout.log
STDERR_LOG= ${LOG_DIR}/stderr.log
PID_FILE= /var/run/${APP_SHORTNAME}.pid
WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
WRKSRC= ${WRKDIR}/apache-tomcat-${PORTVERSION}
REPLACE_FILES= ${WRKSRC}/conf/server.xml
REPLACE_LIST_TEMP= ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/}
JAR_FILE= bin/bootstrap.jar
PLIST_SUB+= T=${APP_HOME:S/^${PREFIX}\///} WWWOWN=${TOMCAT_USER} WWWGRP=${TOMCAT_GROUP}
LATEST_LINK= ${APP_SHORTNAME}
CONF_FILES= catalina.policy catalina.properties context.xml logging.properties server.xml tomcat-users.xml web.xml
CONF_EXT= sample
PLIST_SUB+= CONF_EXT=${CONF_EXT}
PLIST_SUB= T=${APP_HOME:S/^${PREFIX}\///} CONF_EXT=${CONF_EXT} \
WWWOWN=${TOMCAT_USER} WWWGRP=${TOMCAT_GROUP}
LATEST_LINK= ${APP_SHORTNAME}
SUB_LIST= AJP_1_3_PORT=${AJP_1_3_PORT} \
APP_HOME=${APP_HOME} \
APP_SHORTNAME=${APP_SHORTNAME} \
APP_TITLE="${APP_TITLE}" \
GROUP=${TOMCAT_GROUP} \
HTTP_PORT=${HTTP_PORT} \
JAR_FILE=${JAR_FILE} \
PID_FILE=${PID_FILE} \
SHUTDOWN_PORT=${SHUTDOWN_PORT} \
STDERR_LOG=${STDERR_LOG} \
STDOUT_LOG=${STDOUT_LOG} \
@ -75,14 +68,11 @@ pre-patch:
@${ECHO_MSG} " Logfile stderr: ${STDERR_LOG}"
post-patch:
@${ECHO_MSG} -n ">> Removing unneeded files..."
@${RM} -f `${FIND} ${WRKSRC} -name '*.bat'` `${FIND} ${WRKSRC} -name '*.orig'` `${FIND} ${WRKSRC} -name '*.exe'`
@${ECHO_MSG} " [ DONE ]"
.for file in ${REPLACE_FILES}
@${ECHO_MSG} -n ">> Customizing `basename ${file}`..."
@${SED} ${REPLACE_LIST_TEMP} ${file} > ${WRKDIR}/`basename ${file}`
@${ECHO_MSG} " [ DONE ]"
@${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${WRKSRC}/conf/server.xml
@${RM} -f `${FIND} ${WRKSRC} -name '*.bat'` `${FIND} ${WRKSRC} -name '*.exe'` \
`${FIND} ${WRKSRC} -name '*.orig'` `${FIND} ${WRKSRC} -name '*.bak'`
.for f in ${CONF_FILES}
@${MV} ${WRKSRC}/conf/${f} ${WRKSRC}/conf/${f}.${CONF_EXT}
.endfor
pre-install:
@ -92,27 +82,20 @@ do-install:
@${ECHO_MSG} -n ">> Creating destination directory..."
@${MKDIR} ${APP_HOME}
@${MKDIR} ${LOG_DIR}
@${MKDIR} ${APP_HOME}/endorsed
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} ">> Copying files to destination directory..."
@${CP} ${WRKDIR}/server.xml ${WRKSRC}/conf/
@(cd ${WRKSRC};${FIND} conf -type f | ${SED} -e '/${CONF_EXT}/d') \
| while read a; do \
${MV} ${WRKSRC}/$$a ${WRKSRC}/$$a.${CONF_EXT}; \
if [ ! -e "${APP_HOME}/$$a" ]; then \
${ECHO_MSG} " Installing local configuration file: ${APP_HOME}/$$a"; \
${CP} ${WRKSRC}/$$a.${CONF_EXT} ${WRKSRC}/$$a; \
else \
${ECHO_MSG} " Preserving local configuration file: ${APP_HOME}/$$a"; \
fi; \
done
@${ECHO_MSG} -n ">> Copying files to destination directory..."
@${CP} -R ${WRKSRC}/* ${APP_HOME}
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Creating log files..."
@${INSTALL} -m 664 -o ${TOMCAT_USER} -g ${TOMCAT_GROUP} /dev/null ${STDOUT_LOG}
@${INSTALL} -m 664 -o ${TOMCAT_USER} -g ${TOMCAT_GROUP} /dev/null ${STDERR_LOG}
@${ECHO_MSG} " [ DONE ]"
.for f in ${CONF_FILES}
. if !exists(${APP_HOME}/conf/${f})
@${CP} ${APP_HOME}/conf/${f}.${CONF_EXT} ${APP_HOME}/conf/${f}
. else
@${ECHO_MSG} ">> Preserving local configuration file: ${f} [ DONE ]"
. endif
.endfor
@${ECHO_MSG} -n ">> Creating symlink to tools.jar..."
@${LN} -sf ${JAVA_HOME}/lib/tools.jar ${APP_HOME}/lib/tools.jar
@ -120,14 +103,11 @@ do-install:
@${ECHO_MSG} -n ">> Fixing ownership settings..."
@${CHOWN} -R ${TOMCAT_USER}:${TOMCAT_GROUP} ${APP_HOME}/conf ${APP_HOME}/logs \
${APP_HOME}/temp ${APP_HOME}/work
${APP_HOME}/temp ${APP_HOME}/webapps ${APP_HOME}/work
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Fixing permissions..."
@@${FIND} ${APP_HOME} -type d -print0 | xargs -0 ${CHMOD} 755
@${FIND} ${APP_HOME} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
@${ECHO_MSG} " [ DONE ]"
post-install:
@${ECHO_MSG} "${APP_TITLE} ${PORTVERSION} has been installed in ${APP_HOME}."
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (apache-tomcat-6.0.18.tar.gz) = 8354e156f097158f8d7b699078fd39c1
SHA256 (apache-tomcat-6.0.18.tar.gz) = bbbf01a91587c7133b8555abf415d72610f233c42544dc9f819df7382e7791b2
SIZE (apache-tomcat-6.0.18.tar.gz) = 6142197
MD5 (apache-tomcat-6.0.20.tar.gz) = 5944999abe79d01dc2ee7776d9d57873
SHA256 (apache-tomcat-6.0.20.tar.gz) = a443c1720dc25d0963dd47b299b4c5e81d51462147c351f18e5c59bf7646046e
SIZE (apache-tomcat-6.0.20.tar.gz) = 5998298

View file

@ -9,15 +9,6 @@
<!--APR library loader. Documentation at /docs/apr.html -->
<Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />
@@ -15,7 +15,7 @@
<!-- Global JNDI resources
Documentation at /docs/jndi-resources-howto.html
-->
- <GlobalNamingResources>
+ <GlobalNamingResources>
<!-- Editable user database that can also be used by
UserDatabaseRealm to authenticate users
-->
@@ -47,7 +47,7 @@
APR (HTTP/AJP) Connector: /docs/apr.html
Define a non-SSL HTTP/1.1 Connector on port 8080

View file

@ -1,47 +0,0 @@
#!/bin/sh
#
# This script does the following.
#
# * Checks if the PID file exists. If it does, it kills the
# process and removes the PID file.
#
# * Checks if the '%%USER%%' user exists. If it does, then it displays
# a message.
#
# $FreeBSD$
#
USER=%%USER%%
PID_FILE=%%PID_FILE%%
# Make sure we're in the right stage of the process
if [ "$2" = "DEINSTALL" ]; then
# Kill the process if it is still running
if [ -s ${PID_FILE} ]; then
PID=`cat ${PID_FILE}`
echo -n ">> Killing Tomcat process (${PID})..."
/bin/kill ${PID} > /dev/null 2> /dev/null
if [ $? -eq 0 ]; then
echo " [ DONE ]"
else
echo " [ FAILED ]"
fi
echo -n ">> Removing PID file (${PID_FILE})..."
rm ${PID_FILE} > /dev/null 2> /dev/null
if [ $? -eq 0 ]; then
echo " [ DONE ]"
else
echo " [ FAILED ]"
fi
fi
fi
if [ "$2" = "POST-DEINSTALL" ]; then
# If the user exists, then display a message
if pw usershow "${USER}" 2>/dev/null 1>&2; then
echo "To delete the ${USER} user permanently, use 'pw userdel ${USER}'"
fi
fi
exit 0

View file

@ -73,7 +73,7 @@ tomcat%%TOMCAT_VERSION%%_stop_timeout="${tomcat%%TOMCAT_VERSION%%_stop_timeout:-
name="tomcat%%TOMCAT_VERSION%%"
rcvar=`set_rcvar`
pidfile="%%PID_FILE%%"
pidfile="/var/run/%%APP_SHORTNAME%%.pid"
load_rc_config "${name}"
@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
procname=`ps -o ucomm= $rc_pid`
procname=`ps -o command= -p $rc_pid | cut -f1 -d ' '`
fi
fi
if [ -z "$procname" ]; then
@ -147,7 +147,7 @@ tomcat%%TOMCAT_VERSION%%_stop() {
${java_command} stop
tomcat_wait_max_for_pid ${tomcat%%TOMCAT_VERSION%%_stop_timeout} ${rc_pid}
kill -KILL ${rc_pid} 2> /dev/null && echo "Killed."
echo -n > ${pidfile}
rm -f ${pidfile}
}
tomcat_wait_max_for_pid() {

View file

@ -2,7 +2,7 @@ Apache Tomcat is a web server written in 100% Pure Java.
Apache Tomcat version 6.0 implements the Servlet 2.5 and JavaServer Pages 2.1
specifications from the Java Community Process, and includes many additional
features that make it a useful platform for developing and deploying web app
-lications and web services.
features that make it a useful platform for developing and deploying web
applications and web services.
WWW: http://tomcat.apache.org/

File diff suppressed because it is too large Load diff

View file

@ -5,11 +5,12 @@
# $FreeBSD$
#
PORTNAME= apache-tomcat
PORTVERSION= 6.0.18
PORTNAME= tomcat
PORTVERSION= 6.0.20
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-6/v${PORTVERSION}/bin
DISTNAME= apache-${PORTNAME}-${PORTVERSION}
MAINTAINER= nemoliu@FreeBSD.org
COMMENT= Open-source Java web server by Apache, 6.x branch
@ -19,40 +20,32 @@ JAVA_VERSION= 1.5+
NO_BUILD= YES
USE_RC_SUBR= tomcat6.sh
SUB_FILES= pkg-install pkg-deinstall
SUB_FILES= pkg-install
MAJOR_VER= ${PORTVERSION:R}
APP_HOME?= ${PREFIX}/${PKGBASE}${PORTVERSION:R}
APP_HOME?= ${PREFIX}/${DISTNAME:R}
LOG_DIR= ${APP_HOME}/logs
APP_TITLE= Apache Tomcat
APP_SHORTNAME= tomcat${MAJOR_VER:S/.//}
APP_SHORTNAME= ${PORTNAME}${MAJOR_VER:S/.//}
TOMCAT_USER?= www
TOMCAT_GROUP?= www
PW?= /usr/sbin/pw
HTTP_PORT?= 8180
SHUTDOWN_PORT?= 8005
AJP_1_3_PORT?= 8009
STDOUT_LOG= ${LOG_DIR}/stdout.log
STDERR_LOG= ${LOG_DIR}/stderr.log
PID_FILE= /var/run/${APP_SHORTNAME}.pid
WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
WRKSRC= ${WRKDIR}/apache-tomcat-${PORTVERSION}
REPLACE_FILES= ${WRKSRC}/conf/server.xml
REPLACE_LIST_TEMP= ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/}
JAR_FILE= bin/bootstrap.jar
PLIST_SUB+= T=${APP_HOME:S/^${PREFIX}\///} WWWOWN=${TOMCAT_USER} WWWGRP=${TOMCAT_GROUP}
LATEST_LINK= ${APP_SHORTNAME}
CONF_FILES= catalina.policy catalina.properties context.xml logging.properties server.xml tomcat-users.xml web.xml
CONF_EXT= sample
PLIST_SUB+= CONF_EXT=${CONF_EXT}
PLIST_SUB= T=${APP_HOME:S/^${PREFIX}\///} CONF_EXT=${CONF_EXT} \
WWWOWN=${TOMCAT_USER} WWWGRP=${TOMCAT_GROUP}
LATEST_LINK= ${APP_SHORTNAME}
SUB_LIST= AJP_1_3_PORT=${AJP_1_3_PORT} \
APP_HOME=${APP_HOME} \
APP_SHORTNAME=${APP_SHORTNAME} \
APP_TITLE="${APP_TITLE}" \
GROUP=${TOMCAT_GROUP} \
HTTP_PORT=${HTTP_PORT} \
JAR_FILE=${JAR_FILE} \
PID_FILE=${PID_FILE} \
SHUTDOWN_PORT=${SHUTDOWN_PORT} \
STDERR_LOG=${STDERR_LOG} \
STDOUT_LOG=${STDOUT_LOG} \
@ -75,14 +68,11 @@ pre-patch:
@${ECHO_MSG} " Logfile stderr: ${STDERR_LOG}"
post-patch:
@${ECHO_MSG} -n ">> Removing unneeded files..."
@${RM} -f `${FIND} ${WRKSRC} -name '*.bat'` `${FIND} ${WRKSRC} -name '*.orig'` `${FIND} ${WRKSRC} -name '*.exe'`
@${ECHO_MSG} " [ DONE ]"
.for file in ${REPLACE_FILES}
@${ECHO_MSG} -n ">> Customizing `basename ${file}`..."
@${SED} ${REPLACE_LIST_TEMP} ${file} > ${WRKDIR}/`basename ${file}`
@${ECHO_MSG} " [ DONE ]"
@${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${WRKSRC}/conf/server.xml
@${RM} -f `${FIND} ${WRKSRC} -name '*.bat'` `${FIND} ${WRKSRC} -name '*.exe'` \
`${FIND} ${WRKSRC} -name '*.orig'` `${FIND} ${WRKSRC} -name '*.bak'`
.for f in ${CONF_FILES}
@${MV} ${WRKSRC}/conf/${f} ${WRKSRC}/conf/${f}.${CONF_EXT}
.endfor
pre-install:
@ -92,27 +82,20 @@ do-install:
@${ECHO_MSG} -n ">> Creating destination directory..."
@${MKDIR} ${APP_HOME}
@${MKDIR} ${LOG_DIR}
@${MKDIR} ${APP_HOME}/endorsed
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} ">> Copying files to destination directory..."
@${CP} ${WRKDIR}/server.xml ${WRKSRC}/conf/
@(cd ${WRKSRC};${FIND} conf -type f | ${SED} -e '/${CONF_EXT}/d') \
| while read a; do \
${MV} ${WRKSRC}/$$a ${WRKSRC}/$$a.${CONF_EXT}; \
if [ ! -e "${APP_HOME}/$$a" ]; then \
${ECHO_MSG} " Installing local configuration file: ${APP_HOME}/$$a"; \
${CP} ${WRKSRC}/$$a.${CONF_EXT} ${WRKSRC}/$$a; \
else \
${ECHO_MSG} " Preserving local configuration file: ${APP_HOME}/$$a"; \
fi; \
done
@${ECHO_MSG} -n ">> Copying files to destination directory..."
@${CP} -R ${WRKSRC}/* ${APP_HOME}
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Creating log files..."
@${INSTALL} -m 664 -o ${TOMCAT_USER} -g ${TOMCAT_GROUP} /dev/null ${STDOUT_LOG}
@${INSTALL} -m 664 -o ${TOMCAT_USER} -g ${TOMCAT_GROUP} /dev/null ${STDERR_LOG}
@${ECHO_MSG} " [ DONE ]"
.for f in ${CONF_FILES}
. if !exists(${APP_HOME}/conf/${f})
@${CP} ${APP_HOME}/conf/${f}.${CONF_EXT} ${APP_HOME}/conf/${f}
. else
@${ECHO_MSG} ">> Preserving local configuration file: ${f} [ DONE ]"
. endif
.endfor
@${ECHO_MSG} -n ">> Creating symlink to tools.jar..."
@${LN} -sf ${JAVA_HOME}/lib/tools.jar ${APP_HOME}/lib/tools.jar
@ -120,14 +103,11 @@ do-install:
@${ECHO_MSG} -n ">> Fixing ownership settings..."
@${CHOWN} -R ${TOMCAT_USER}:${TOMCAT_GROUP} ${APP_HOME}/conf ${APP_HOME}/logs \
${APP_HOME}/temp ${APP_HOME}/work
${APP_HOME}/temp ${APP_HOME}/webapps ${APP_HOME}/work
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Fixing permissions..."
@@${FIND} ${APP_HOME} -type d -print0 | xargs -0 ${CHMOD} 755
@${FIND} ${APP_HOME} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
@${ECHO_MSG} " [ DONE ]"
post-install:
@${ECHO_MSG} "${APP_TITLE} ${PORTVERSION} has been installed in ${APP_HOME}."
.include <bsd.port.post.mk>

View file

@ -1,3 +1,3 @@
MD5 (apache-tomcat-6.0.18.tar.gz) = 8354e156f097158f8d7b699078fd39c1
SHA256 (apache-tomcat-6.0.18.tar.gz) = bbbf01a91587c7133b8555abf415d72610f233c42544dc9f819df7382e7791b2
SIZE (apache-tomcat-6.0.18.tar.gz) = 6142197
MD5 (apache-tomcat-6.0.20.tar.gz) = 5944999abe79d01dc2ee7776d9d57873
SHA256 (apache-tomcat-6.0.20.tar.gz) = a443c1720dc25d0963dd47b299b4c5e81d51462147c351f18e5c59bf7646046e
SIZE (apache-tomcat-6.0.20.tar.gz) = 5998298

View file

@ -9,15 +9,6 @@
<!--APR library loader. Documentation at /docs/apr.html -->
<Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />
@@ -15,7 +15,7 @@
<!-- Global JNDI resources
Documentation at /docs/jndi-resources-howto.html
-->
- <GlobalNamingResources>
+ <GlobalNamingResources>
<!-- Editable user database that can also be used by
UserDatabaseRealm to authenticate users
-->
@@ -47,7 +47,7 @@
APR (HTTP/AJP) Connector: /docs/apr.html
Define a non-SSL HTTP/1.1 Connector on port 8080

View file

@ -1,47 +0,0 @@
#!/bin/sh
#
# This script does the following.
#
# * Checks if the PID file exists. If it does, it kills the
# process and removes the PID file.
#
# * Checks if the '%%USER%%' user exists. If it does, then it displays
# a message.
#
# $FreeBSD$
#
USER=%%USER%%
PID_FILE=%%PID_FILE%%
# Make sure we're in the right stage of the process
if [ "$2" = "DEINSTALL" ]; then
# Kill the process if it is still running
if [ -s ${PID_FILE} ]; then
PID=`cat ${PID_FILE}`
echo -n ">> Killing Tomcat process (${PID})..."
/bin/kill ${PID} > /dev/null 2> /dev/null
if [ $? -eq 0 ]; then
echo " [ DONE ]"
else
echo " [ FAILED ]"
fi
echo -n ">> Removing PID file (${PID_FILE})..."
rm ${PID_FILE} > /dev/null 2> /dev/null
if [ $? -eq 0 ]; then
echo " [ DONE ]"
else
echo " [ FAILED ]"
fi
fi
fi
if [ "$2" = "POST-DEINSTALL" ]; then
# If the user exists, then display a message
if pw usershow "${USER}" 2>/dev/null 1>&2; then
echo "To delete the ${USER} user permanently, use 'pw userdel ${USER}'"
fi
fi
exit 0

View file

@ -73,7 +73,7 @@ tomcat%%TOMCAT_VERSION%%_stop_timeout="${tomcat%%TOMCAT_VERSION%%_stop_timeout:-
name="tomcat%%TOMCAT_VERSION%%"
rcvar=`set_rcvar`
pidfile="%%PID_FILE%%"
pidfile="/var/run/%%APP_SHORTNAME%%.pid"
load_rc_config "${name}"
@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
procname=`ps -o ucomm= $rc_pid`
procname=`ps -o command= -p $rc_pid | cut -f1 -d ' '`
fi
fi
if [ -z "$procname" ]; then
@ -147,7 +147,7 @@ tomcat%%TOMCAT_VERSION%%_stop() {
${java_command} stop
tomcat_wait_max_for_pid ${tomcat%%TOMCAT_VERSION%%_stop_timeout} ${rc_pid}
kill -KILL ${rc_pid} 2> /dev/null && echo "Killed."
echo -n > ${pidfile}
rm -f ${pidfile}
}
tomcat_wait_max_for_pid() {

View file

@ -2,7 +2,7 @@ Apache Tomcat is a web server written in 100% Pure Java.
Apache Tomcat version 6.0 implements the Servlet 2.5 and JavaServer Pages 2.1
specifications from the Java Community Process, and includes many additional
features that make it a useful platform for developing and deploying web app
-lications and web services.
features that make it a useful platform for developing and deploying web
applications and web services.
WWW: http://tomcat.apache.org/

File diff suppressed because it is too large Load diff