x11/tilix: Update to 1.9.5

This commit is contained in:
Romain Tartière 2023-04-21 23:05:02 -10:00
parent f2c49a0538
commit 0cfd877749
No known key found for this signature in database
GPG key ID: BA4D1D955112336F
6 changed files with 76 additions and 36 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= tilix
PORTVERSION= 1.9.4
PORTREVISION= 2
PORTVERSION= 1.9.5
CATEGORIES= x11
MAINTAINER= romain@FreeBSD.org
@ -12,13 +11,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= cmake:devel/cmake-core \
po4a-translate:textproc/po4a \
${LOCALBASE}/libdata/pkgconfig/undead.pc:devel/undead \
${LOCALBASE}/libdata/pkgconfig/vted-3.pc:x11-toolkits/gtkd
LIB_DEPENDS= libdruntime-ldc-shared.so:lang/ldc \
libharfbuzz.so:print/harfbuzz \
libsecret-1.so:security/libsecret \
libunwind.so:devel/libunwind
USES= gettext gnome meson pkgconfig shebangfix
USES= desktop-file-utils gettext gnome meson pkgconfig shebangfix
USE_GITHUB= yes
GH_ACCOUNT= gnunn1
USE_GNOME= cairo gdkpixbuf2 librsvg2 vte3

View file

@ -1,3 +1,5 @@
TIMESTAMP = 1640633390
SHA256 (gnunn1-tilix-1.9.4_GH0.tar.gz) = 2a9482770391d11d5edc8351d426c700c2cc6c194a30391ef2ae25bb7095b59b
SIZE (gnunn1-tilix-1.9.4_GH0.tar.gz) = 968142
TIMESTAMP = 1682131118
SHA256 (gnunn1-tilix-1.9.5_GH0.tar.gz) = e25335a3f7ab06779b957d08ffaf7698c966c3b5179d002f82ce41c692fc0b89
SIZE (gnunn1-tilix-1.9.5_GH0.tar.gz) = 1005604
SHA256 (2101.diff) = a9fdc841f9f98a75b6e09ec007556c7e3c074eb24c2cb397a234dd69666bc488
SIZE (2101.diff) = 2169

View file

@ -1,47 +1,23 @@
https://github.com/gnunn1/tilix/pull/2074
https://github.com/gnunn1/tilix/pull/2081
--- data/meson.build.orig 2021-12-27 19:49:46 UTC
--- data/meson.build.orig 2023-04-22 01:48:27 UTC
+++ data/meson.build
@@ -11,7 +11,6 @@ install_data(
# Install the desktop file
desktop_file = i18n.merge_file(
- '@0@.desktop'.format(project_id),
output: '@BASENAME@',
input: 'pkg/desktop/@0@.desktop.in'.format(project_id),
po_dir: meson.source_root() / 'po',
@@ -35,25 +34,24 @@ endif
@@ -32,7 +32,8 @@ endif
# Merge release information into MetaInfo file
tilix_metainfo_name = '@0@.appdata.xml'.format(project_id)
-appstreamcli = find_program('appstreamcli')
-metainfo_with_releases = custom_target('metainfo-news-merge',
+appstreamcli = find_program('appstreamcli', required: false)
+if appstreamcli.found()
+ metainfo_with_releases = custom_target('metainfo-news-merge',
metainfo_with_releases = custom_target('metainfo-news-merge',
input : ['../NEWS', 'metainfo/@0@.in'.format(tilix_metainfo_name)],
output : ['untranslated-@0@.appdata.xml'.format(project_id)],
command : [appstreamcli, 'news-to-metainfo', '--limit=6', '@INPUT0@', '@INPUT1@', '@OUTPUT@']
-)
+ )
@@ -49,7 +50,6 @@ metainfo_file = i18n.merge_file(
)
-# Install the MetaInfo file
-metainfo_file = i18n.merge_file(
- tilix_metainfo_name,
+ # Install the MetaInfo file
+ metainfo_file = i18n.merge_file(
output: tilix_metainfo_name,
input: metainfo_with_releases,
po_dir: meson.source_root() / 'po',
install: true,
install_dir: datadir / 'metainfo'
-)
+ )
-# Validate MetaInfo file
# Validate MetaInfo file
-if appstreamcli.found()
+ # Validate MetaInfo file
test (
'Validate metainfo file',
appstreamcli,

View file

@ -0,0 +1,30 @@
--- meson.build.orig 2022-02-22 16:31:19 UTC
+++ meson.build
@@ -101,6 +101,7 @@ vted_dep = dependency('vted-3', version: '>=3.8.5')
xlib_dep = dependency('x11')
libunwind_dep = dependency('libunwind')
libsecret_dep = dependency('libsecret-1', required: false)
+undead_dep = dependency('undead', version: '>=1.0.9')
subdir('po')
subdir('data')
@@ -113,7 +114,8 @@ executable('tilix',
vted_dep,
xlib_dep,
libunwind_dep,
- libsecret_dep],
+ libsecret_dep,
+ undead_dep],
d_args: d_extra_args,
d_module_versions: ['StdLoggerDisableTrace'],
link_args: d_link_args,
@@ -125,7 +127,8 @@ tilix_test_exe = executable('tilix_test',
include_directories : [sources_dir],
dependencies : [gtkd_dep,
vted_dep,
- xlib_dep],
+ xlib_dep,
+ undead_dep],
d_args: d_extra_args,
link_args: d_link_args,
d_unittest: true

View file

@ -0,0 +1,11 @@
--- source/gx/tilix/prefeditor/prefdialog.d.orig 2023-04-22 04:00:09 UTC
+++ source/gx/tilix/prefeditor/prefdialog.d
@@ -957,7 +957,7 @@ class ShortcutPreferences : Box { (private)
return;
}
- import std.xml: DocumentParser, ElementParser, Element, XMLException;
+ import undead.xml: DocumentParser, ElementParser, Element, XMLException;
try {
DocumentParser parser = new DocumentParser(ui);

View file

@ -1,5 +1,26 @@
bin/tilix
man/man1/tilix.1.gz
man/ca/man1/tilix.1.gz
man/cs/man1/tilix.1.gz
man/de/man1/tilix.1.gz
man/en_GB/man1/tilix.1.gz
man/es/man1/tilix.1.gz
man/fr/man1/tilix.1.gz
man/hr/man1/tilix.1.gz
man/it/man1/tilix.1.gz
man/nb_NO/man1/tilix.1.gz
man/nl/man1/tilix.1.gz
man/oc/man1/tilix.1.gz
man/pl/man1/tilix.1.gz
man/pt/man1/tilix.1.gz
man/pt_BR/man1/tilix.1.gz
man/pt_PT/man1/tilix.1.gz
man/ro/man1/tilix.1.gz
man/ru/man1/tilix.1.gz
man/sr/man1/tilix.1.gz
man/tr/man1/tilix.1.gz
man/uk/man1/tilix.1.gz
man/zh_Hant/man1/tilix.1.gz
share/applications/com.gexperts.Tilix.desktop
share/dbus-1/services/com.gexperts.Tilix.service
share/icons/hicolor/scalable/apps/com.gexperts.Tilix.svg