- Fix broken regression test
PR: 164665 Submitted by: maintainer
This commit is contained in:
parent
28110cef33
commit
0d1c5a9646
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=292664
3 changed files with 27 additions and 1 deletions
|
@ -29,12 +29,16 @@ PORTDOCS= CHANGES.txt LICENSE.txt README.txt
|
|||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|-ldl||' ${BUILD_WRKSRC}/Premake4.make
|
||||
${REINPLACE_CMD} -e 's|debug|release|' ${WRKSRC}/tests/test
|
||||
|
||||
do-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
|
||||
.endif
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/bin/release/premake4 ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/release/premake4 ${PREFIX}/bin
|
||||
|
||||
regression-test: build
|
||||
cd ${WRKSRC}/tests && ./test
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
17
devel/premake4/files/patch-src-base-os.lua
Normal file
17
devel/premake4/files/patch-src-base-os.lua
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- src/base/os.lua.orig 2012-01-31 15:40:25.000000000 +0200
|
||||
+++ src/base/os.lua 2012-01-31 15:42:16.000000000 +0200
|
||||
@@ -33,14 +33,6 @@
|
||||
else
|
||||
formats = { "lib%s.so", "%s.so" }
|
||||
path = os.getenv("LD_LIBRARY_PATH") or ""
|
||||
-
|
||||
- io.input("/etc/ld.so.conf")
|
||||
- if io.input() then
|
||||
- for line in io.lines() do
|
||||
- path = path .. ":" .. line
|
||||
- end
|
||||
- io.input():close()
|
||||
- end
|
||||
end
|
||||
|
||||
table.insert(formats, "%s")
|
5
devel/premake4/files/patch-src-host-scripts.c
Normal file
5
devel/premake4/files/patch-src-host-scripts.c
Normal file
|
@ -0,0 +1,5 @@
|
|||
--- src/host/scripts.c.orig 2010-11-16 13:29:13.000000000 +0200
|
||||
+++ src/host/scripts.c 2012-01-31 16:05:26.000000000 +0200
|
||||
@@ -7 +7 @@
|
||||
- "function os.executef(cmd, ...)\ncmd = string.format(cmd, unpack(arg))\nreturn os.execute(cmd)\nend\nfunction os.findlib(libname)\nlocal path, formats\nif os.is(\"windows\") then\nformats = { \"%s.dll\", \"%s\" }\npath = os.getenv(\"PATH\")\nelse\nif os.is(\"macosx\") then\nformats = { \"lib%s.dylib\", \"%s.dylib\" }\npath = os.getenv(\"DYLD_LIBRARY_PATH\")\nelse\nformats = { \"lib%s.so\", \"%s.so\" }\npath = os.getenv(\"LD_LIBRARY_PATH\") or \"\"\nio.input(\"/etc/ld.so.conf\")\nif io.input() then\nfor line in io.lines() do\npath = path .. \":\" .. line\nend\nio.input():close()\nend\nend\ntable.insert(formats, \"%s\")\npath = (path or \"\") .. \":/lib:/usr/lib:/usr/local/lib\"\nend\nfor _, fmt in ipairs(formats) do\nlocal name = string.format(fmt, libname)\nlocal result = os.pathsearch(name, path)\nif result then return result end\nend\nend\nfunction os.get()\nreturn _OPTIONS.os or _OS\nend\nfunction os.is(id)\nreturn (os.get():lower() == id:lower())\nend\nlocal function domatch(result, mask, wantfiles)\nif mas"
|
||||
+ "function os.executef(cmd, ...)\ncmd = string.format(cmd, unpack(arg))\nreturn os.execute(cmd)\nend\nfunction os.findlib(libname)\nlocal path, formats\nif os.is(\"windows\") then\nformats = { \"%s.dll\", \"%s\" }\npath = os.getenv(\"PATH\")\nelse\nif os.is(\"macosx\") then\nformats = { \"lib%s.dylib\", \"%s.dylib\" }\npath = os.getenv(\"DYLD_LIBRARY_PATH\")\nelse\nformats = { \"lib%s.so\", \"%s.so\" }\npath = os.getenv(\"LD_LIBRARY_PATH\") or \"\"\nend\ntable.insert(formats, \"%s\")\npath = (path or \"\") .. \":/lib:/usr/lib:/usr/local/lib\"\nend\nfor _, fmt in ipairs(formats) do\nlocal name = string.format(fmt, libname)\nlocal result = os.pathsearch(name, path)\nif result then return result end\nend\nend\nfunction os.get()\nreturn _OPTIONS.os or _OS\nend\nfunction os.is(id)\nreturn (os.get():lower() == id:lower())\nend\nlocal function domatch(result, mask, wantfiles)\nif mas"
|
Loading…
Reference in a new issue