- Update to 0.0.5

- Support staging
- Fix options
- Fix build on current
- Convert USE_GMAKE to USES
This commit is contained in:
Dmitry Marakasov 2013-11-08 18:18:08 +00:00
parent 405a343ff6
commit 0d200dda30
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=333253
7 changed files with 25 additions and 63 deletions

View file

@ -2,36 +2,42 @@
# $FreeBSD$
PORTNAME= pire
PORTVERSION= 0.0.4
PORTVERSION= 0.0.5
CATEGORIES= devel
MASTER_SITES= http://cloud.github.com/downloads/dprokoptsev/${PORTNAME}/ \
http://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Perl Incompatible Regular Expressions library
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= dprokoptsev
GH_TAGNAME= release-${PORTVERSION}
GH_COMMIT= 012bedf
LICENSE= LGPL3
USE_AUTOTOOLS= autoconf automake libtool libtoolize
GNU_CONFIGURE= yes
USE_GMAKE= yes
USES= gmake bison
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= amd64 i386 ia64
ONLY_FOR_ARCHS_REASON= not yet ported to big-endian platforms
OPTIONS_DEFINE= UNITTEST
OPTIONS_UNITTEST_DESC= Compile with unittest support
UNITTEST_DESC= Compile with unittest support
NO_STAGE= yes
.include <bsd.port.options.mk>
run-autotools:
@cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -fi
.if ${PORT_OPTIONS:MUNITTEST} || defined(PACKAGE_BUILDING)
BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
CONFIGURE_ARGS= --with-cppunit-prefix=${LOCALBASE}
regression-test:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check || \
(${CAT} ${WRKSRC}/tests/test-suite.log; false)
.endif
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (pire-0.0.4.tar.gz) = 667b3c15580ab5ba4469e857d329c9d1be254d86db0b4ebd7ad408988959847b
SIZE (pire-0.0.4.tar.gz) = 487142
SHA256 (pire-0.0.5.tar.gz) = 0285b90d497e424e2f52ab2608745e03b7e2e2f121993aee08ac5543b2c5a786
SIZE (pire-0.0.5.tar.gz) = 149072

View file

@ -1,11 +0,0 @@
--- pire/glue.cpp.orig 2010-11-16 23:42:09.000000000 +0000
+++ pire/glue.cpp
@@ -60,7 +60,7 @@ public:
size_t finalTableSize = 0;
for (typename yvector<State>::const_iterator i = states.begin(), ie = states.end(); i != ie; ++i)
finalTableSize += RangeLen(Lhs().AcceptedRegexps(i->first)) + RangeLen(Rhs().AcceptedRegexps(i->second));
- SetSc(new Scanner);
+ this->SetSc(new Scanner);
Sc().Init(states.size(), Letters(), finalTableSize, size_t(0), Lhs().RegexpsCount() + Rhs().RegexpsCount());
for (size_t state = 0; state != states.size(); ++state) {

View file

@ -1,20 +0,0 @@
--- pire/stub/saveload.h.orig 2010-11-16 23:42:09.000000000 +0000
+++ pire/stub/saveload.h
@@ -52,7 +52,7 @@ namespace Pire {
if (!Traits::eq_int_type(ret, Traits::eof())) {
m_ch = (Char) ret;
m_read += sizeof(Char);
- setg(&m_ch, &m_ch, &m_ch+1);
+ this->setg(&m_ch, &m_ch, &m_ch+1);
}
return ret;
}
@@ -117,7 +117,7 @@ namespace Pire {
BasicAlignedOutput(std::basic_ostream<Char, Traits>* backend)
: m_streambuf(backend->rdbuf())
{
- rdbuf(&m_streambuf);
+ this->rdbuf(&m_streambuf);
}
void Align(size_t divisor = sizeof(void*))

View file

@ -1,10 +0,0 @@
--- samples/pigrep/pigrep.cpp.orig 2010-11-16 23:42:09.000000000 +0000
+++ samples/pigrep/pigrep.cpp
@@ -29,6 +29,7 @@
#include <string.h>
#include <stdlib.h>
+#include <unistd.h>
#include <string>
#include <stdexcept>
#include <iostream>

View file

@ -1,10 +0,0 @@
--- tools/bench/bench.cpp.orig 2010-11-16 23:42:09.000000000 +0000
+++ tools/bench/bench.cpp
@@ -23,6 +23,7 @@
#include <fcntl.h>
#include <errno.h>
+#include <unistd.h>
#include <sys/stat.h>
#include <sys/mman.h>
#include <sys/time.h>

View file

@ -2,8 +2,10 @@ bin/pigrep
bin/pire_inline
include/pire/align.h
include/pire/any.h
include/pire/config.h
include/pire/defs.h
include/pire/determine.h
include/pire/easy.h
include/pire/encoding.h
include/pire/extra.h
include/pire/fsm.h
@ -11,6 +13,7 @@ include/pire/fwd.h
include/pire/glue.h
include/pire/partition.h
include/pire/pire.h
include/pire/platform.h
include/pire/re_lexer.h
include/pire/re_parser.h
include/pire/run.h
@ -20,10 +23,10 @@ include/pire/scanners/multi.h
include/pire/scanners/pair.h
include/pire/scanners/simple.h
include/pire/scanners/slow.h
include/pire/sse.h
include/pire/static_assert.h
include/pire/stub/defaults.h
include/pire/stub/lexical_cast.h
include/pire/stub/memstreams.h
include/pire/stub/saveload.h
include/pire/stub/singleton.h
include/pire/stub/stl.h
@ -32,6 +35,10 @@ lib/libpire.a
lib/libpire.la
lib/libpire.so
lib/libpire.so.0
lib/libpire_unit.a
lib/libpire_unit.la
lib/libpire_unit.so
lib/libpire_unit.so.0
@dirrm include/pire/stub
@dirrm include/pire/scanners
@dirrm include/pire