Update to 1.27 which works properly on amd64 and does not need the

restricted patches any longer.

PR:		ports/162543
Submitted by:	Hardy Schumacher [hardy.schumacher gmx/de]
Approved by:	maintainer
Feature safe:	yes
This commit is contained in:
Rene Ladan 2011-11-14 19:10:40 +00:00
parent ba8e7029b5
commit 0d58cc145d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285787
7 changed files with 7 additions and 112 deletions

View file

@ -6,50 +6,31 @@
#
PORTNAME= dgen-sdl
PORTVERSION= 1.23
PORTREVISION= 5
PORTVERSION= 1.27
CATEGORIES= emulators
MASTER_SITES= SF/dgen/dgen/sdl-${PORTVERSION} \
http://tamentis.com/projects/dgen/files/ \
http://launchpadlibrarian.net/10817989/:quilt
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
patches.tar.gz:quilt
DIST_SUBDIR= ${PORTNAME}
MASTER_SITES= SF/dgen/dgen/${PORTVERSION}
MAINTAINER= spam@rm-rf.kiev.ua
COMMENT= A wonderful Sega Genesis/MegaDrive emulator
NO_CDROM= License only permits non-commercial use, modified versions of MZ80 are not allowed to be distributed
NO_PACKAGE= ${NO_CDROM}
RESTRICTED= ${NO_CDROM}
RESTRICTED_FILES= patches.tar.gz
USE_SDL= sdl
USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-extra-opt
EXTRA_PATCHES= ${WRKDIR}/patches/fm-do-not-use-long.patch \
${WRKDIR}/patches/mz80-pbPC-pointer-subtract.patch \
${WRKDIR}/patches/mz80-stdint.patch \
${WRKDIR}/patches/mz80init.patch \
${WRKDIR}/patches/ras-emulate-pointer-wraparound.patch \
${WRKDIR}/patches/sdl-use-stdint.patch
PLIST_FILES= bin/dgen \
bin/tobin
MAN1= dgen.1 tobin.1
MAN5= dgenrc.5
post-extract:
@${REINPLACE_CMD} -e 's|^Index: dgen-|Index: ../dgen-sdl-|' ${WRKDIR}/patches/*
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.else
CONFIGURE_ARGS+= --disable-asm
.endif
.include <bsd.port.post.mk>

View file

@ -1,4 +1,2 @@
SHA256 (dgen-sdl/dgen-sdl-1.23.tar.gz) = 44396b3b324433187cf7082d1059cd9f519f02accddd667e627a57ff8514d436
SIZE (dgen-sdl/dgen-sdl-1.23.tar.gz) = 340556
SHA256 (dgen-sdl/patches.tar.gz) = 457c9b3580c199a7873f87c3e7579325f3d5b0fd88d032e6e30419d983ea4cf3
SIZE (dgen-sdl/patches.tar.gz) = 7778
SHA256 (dgen-sdl-1.27.tar.gz) = 8c80d511d70dc5c7c0c7a430e64c349ba35133315e6e0bc5b32c94c9e07af8f6
SIZE (dgen-sdl-1.27.tar.gz) = 432545

View file

@ -1,34 +0,0 @@
Index: configure
@@ -897,12 +897,12 @@
if test x$ADD_OPT \!= xno; then
case $machtype in
- i?86)
+ disabled)
CFLAGS="$CFLAGS -O3 -mpentium -march=pentium -fstrength-reduce -fomit-frame-pointer -frerun-cse-after-loop -funroll-loops -ffast-math -malign-functions=5 -malign-jumps=5 -malign-loops=5 -malign-double -fno-exceptions -fno-rtti"
CXXFLAGS="$CXXFLAGS -O3 -mpentium -march=pentium -fstrength-reduce -fomit-frame-pointer -frerun-cse-after-loop -funroll-loops -ffast-math -malign-functions=5 -malign-jumps=5 -malign-loops=5 -malign-double -fno-exceptions -fno-rtti"
;;
*)
- CFLAGS="$CFLAGS -O3 -ffast-math -fomit-frame-pointer -fno-exceptions -fno-rtti -funroll-loops -frerun-cse-after-loop"
+ CFLAGS="$CFLAGS -O3 -ffast-math -fomit-frame-pointer -fno-exceptions -funroll-loops -frerun-cse-after-loop"
CXXFLAGS="$CXXFLAGS -O3 -ffast-math -fomit-frame-pointer -fno-exceptions -fno-rtti -funroll-loops -frerun-cse-after-loop"
;;
esac
@@ -1779,7 +1779,7 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <SDL/SDL.h>
+#include <SDL.h>
char*
my_strdup (char *str)
@@ -1872,7 +1872,7 @@
#include "confdefs.h"
#include <stdio.h>
-#include <SDL/SDL.h>
+#include <SDL.h>
int main() {
return 0;

View file

@ -1,26 +0,0 @@
Index: rc.cpp
@@ -14,13 +14,13 @@
// CTV names
-char *ctv_names[NUM_CTV] = { "off", "blur", "scanline", "interlace" };
+char const *ctv_names[NUM_CTV] = { "off", "blur", "scanline", "interlace" };
// The table of strings and the keysyms they map to.
// The order is a bit weird, since this was originally a mapping for the SVGALib
// scancodes, and I just added the SDL stuff on top of it.
struct rc_keysym {
- char *name;
+ char const *name;
long keysym;
} keysyms[] = {
{ "ESCAPE", PDK_ESCAPE },
@@ -300,7 +300,7 @@
/* This is a table of all the RC options, the variables they affect, and the
* functions to parse their values. */
struct rc_field {
- char *fieldname;
+ char const *fieldname;
long (*parser)(const char*);
long *variable;
} rc_fields[] = {

View file

@ -1,10 +0,0 @@
Index: rc.h
@@ -16,7 +16,7 @@
#define KEYSYM_MOD_META 0x08000000
// All the CTV engine names, in string form for the RC and message bar
-extern char *ctv_names[];
+extern char const *ctv_names[];
// Provide a prototype to the parse_rc function in rc.cpp
void parse_rc(const char *file);

View file

@ -1,14 +0,0 @@
$FreeBSD$
--- star/star.c.orig Sun Aug 22 22:09:09 2004
+++ star/star.c Sun Aug 22 22:09:20 2004
@@ -1931,7 +1931,7 @@
case aind: case ainc: case adec:
case adsp: case axdp:
usereg();
- default:
+ default: break;
}
}

View file

@ -1,3 +1,3 @@
DGen is a wonderful Sega Genesis/MegaDrive emulator.
WWW: http://tamentis.com/projects/dgen
WWW: http://dgen.sourceforge.net