games/libretro-fbalpha: rename to games/libretro-fbalpha2012 + update to 0.20220327
PR: 274647
This commit is contained in:
parent
f9b11c6a86
commit
0d65836429
9 changed files with 40 additions and 62 deletions
1
MOVED
1
MOVED
|
@ -7971,3 +7971,4 @@ games/libretro-beetle_saturn|games/libretro-mednafen_saturn|2023-10-26|Follow na
|
|||
games/libretro-beetle_supergrafx|games/libretro-mednafen_supergrafx|2023-10-26|Follow naming of libretro-super build script
|
||||
games/libretro-beetle_vb|games/libretro-mednafen_vb|2023-10-26|Follow naming of libretro-super build script
|
||||
games/libretro-beetle_wswan|games/libretro-mednafen_wswan|2023-10-26|Follow naming of libretro-super build script
|
||||
games/libretro-fbalpha|games/libretro-fbalpha2012|2023-10-26|Follow naming of libretro-super build script
|
||||
|
|
|
@ -506,7 +506,7 @@
|
|||
SUBDIR += libretro-desmume2015
|
||||
SUBDIR += libretro-dosbox
|
||||
SUBDIR += libretro-emux
|
||||
SUBDIR += libretro-fbalpha
|
||||
SUBDIR += libretro-fbalpha2012
|
||||
SUBDIR += libretro-fbneo
|
||||
SUBDIR += libretro-fceumm
|
||||
SUBDIR += libretro-fmsx
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
PORTNAME= libretro-fbalpha
|
||||
PORTVERSION= 0.20220405
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Final Burn Alpha port for libretro
|
||||
WWW= https://github.com/libretro/libretro-fbalpha
|
||||
|
||||
# Commercial users must seek permission from copyright holders.
|
||||
LICENSE= FBA
|
||||
LICENSE_NAME= FBA
|
||||
LICENSE_FILE= ${WRKSRC}/src/license.txt
|
||||
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
|
||||
|
||||
USES= compiler:c++11-lib gmake gl
|
||||
USE_LDCONFIG= yes
|
||||
USE_GL= gl
|
||||
|
||||
PLIST_FILES= lib/libretro/fbalpha_libretro.so
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= libretro
|
||||
GH_PROJECT= fbalpha
|
||||
GH_TAGNAME= d584c83
|
||||
|
||||
MAKEFILE= Makefile.freebsd
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
|
||||
${INSTALL_LIB} ${WRKSRC}/fbalpha_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1649324303
|
||||
SHA256 (libretro-fbalpha-0.20220405-d584c83_GH0.tar.gz) = 63eb0e998896b02222756866be94bee45793e9b9ac5c2d5da177a2bf6d8f42d1
|
||||
SIZE (libretro-fbalpha-0.20220405-d584c83_GH0.tar.gz) = 11634909
|
|
@ -1,5 +0,0 @@
|
|||
--- Makefile.freebsd.orig 2020-03-17 22:25:53 UTC
|
||||
+++ Makefile.freebsd
|
||||
@@ -0,0 +1,2 @@
|
||||
+all:
|
||||
+ $(foreach p,performance,${MAKE} -f makefile.libretro profile=$(p);)
|
|
@ -1,20 +0,0 @@
|
|||
--- src/burner/libretro/libretro-common/features/features_cpu.c.orig 2020-08-25 12:19:30 UTC
|
||||
+++ src/burner/libretro/libretro-common/features/features_cpu.c
|
||||
@@ -167,7 +167,7 @@ retro_perf_tick_t cpu_features_get_perf_counter(void)
|
||||
tv_sec = (long)((ularge.QuadPart - epoch) / 10000000L);
|
||||
tv_usec = (long)(system_time.wMilliseconds * 1000);
|
||||
time_ticks = (1000000 * tv_sec + tv_usec);
|
||||
-#elif defined(__linux__) || defined(__QNX__) || defined(__MACH__)
|
||||
+#elif defined(_POSIX_MONOTONIC_CLOCK) || defined(__QNX__) || defined(ANDROID) || defined(__MACH__) || defined(__PSL1GHT__)
|
||||
struct timespec tv = {0};
|
||||
if (ra_clock_gettime(CLOCK_MONOTONIC, &tv) == 0)
|
||||
time_ticks = (retro_perf_tick_t)tv.tv_sec * 1000000000 +
|
||||
@@ -181,7 +181,7 @@ retro_perf_tick_t cpu_features_get_perf_counter(void)
|
||||
time_ticks = (retro_perf_tick_t)a | ((retro_perf_tick_t)d << 32);
|
||||
#elif defined(__ARM_ARCH_6__)
|
||||
__asm__ volatile( "mrc p15, 0, %0, c9, c13, 0" : "=r"(time_ticks) );
|
||||
-#elif defined(__CELLOS_LV2__) || defined(_XBOX360) || defined(__powerpc__) || defined(__ppc__) || defined(__POWERPC__)
|
||||
+#elif defined(__CELLOS_LV2__) || defined(_XBOX360)
|
||||
time_ticks = __mftb();
|
||||
#elif defined(GEKKO)
|
||||
time_ticks = gettime();
|
35
games/libretro-fbalpha2012/Makefile
Normal file
35
games/libretro-fbalpha2012/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
PORTNAME= libretro-fbalpha2012
|
||||
DISTVERSION= 0.20220327
|
||||
CATEGORIES= games
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Final Burn Alpha port for libretro
|
||||
WWW= https://github.com/libretro/fbalpha2012
|
||||
|
||||
# Commercial users must seek permission from copyright holders.
|
||||
LICENSE= FBA
|
||||
LICENSE_NAME= FBA
|
||||
LICENSE_FILE= ${WRKSRC}/src/license.txt
|
||||
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
|
||||
|
||||
USES= compiler:c++11-lib gmake
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
PLIST_FILES= lib/libretro/fbalpha2012_libretro.so
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= libretro
|
||||
GH_PROJECT= fbalpha2012
|
||||
GH_TAGNAME= 7f8860543a81ba79c0e1ce1aa219af44568c628a
|
||||
|
||||
CXXFLAGS+= -Wno-c++11-narrowing
|
||||
|
||||
WRKSRC_SUBDIR= svn-current/trunk
|
||||
MAKEFILE= makefile.libretro
|
||||
MAKE_ARGS= profile=performance
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro
|
||||
${INSTALL_LIB} ${WRKSRC}/fbalpha2012_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro
|
||||
|
||||
.include <bsd.port.mk>
|
3
games/libretro-fbalpha2012/distinfo
Normal file
3
games/libretro-fbalpha2012/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1698314777
|
||||
SHA256 (libretro-fbalpha2012-0.20220327-7f8860543a81ba79c0e1ce1aa219af44568c628a_GH0.tar.gz) = 8de890151718424518b30bdef563a5922d1aa2442fd23a8453503cb7c42e65a7
|
||||
SIZE (libretro-fbalpha2012-0.20220327-7f8860543a81ba79c0e1ce1aa219af44568c628a_GH0.tar.gz) = 4895817
|
Loading…
Reference in a new issue