o Avoid modifying CFLAGS
o Create dsp.so when building with DEVFS in -current. o Pass variables to CONFIGURE_ENV in appropriate style. o Add missing libdvdcss.* to pkg-plist (bumping PORTREVISION). o post-patch hack is to select proper libs (-pthread/-lc_r). o Check XFREE86_VERSION for xvideo.so in pkg-plist. Submitted by: FUJISHIMA Satsuki <sf@FreeBSD.org>
This commit is contained in:
parent
346a05a32d
commit
0dea1d3200
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46122
12 changed files with 153 additions and 15 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= vlc
|
||||
PORTVERSION= 0.2.82
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/${PORTVERSION}/ \
|
||||
ftp://ftp.Awfulhak.org/pub/vlc/ \
|
||||
|
@ -16,12 +17,23 @@ MAINTAINER= brian@Awfulhak.org
|
|||
|
||||
LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PATH_GTKCONFIG="${PREFIX}/bin/gtk12-config" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
USE_GTK= yes
|
||||
USE_GMAKE= yes
|
||||
USE_BZIP2= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
post-patch:
|
||||
${PERL} -pi.orig -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${XFREE86_VERSION} == 4
|
||||
PLIST_SUB= XF4=""
|
||||
.else
|
||||
PLIST_SUB= XF4="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
18
graphics/vlc/files/patch-Makefile.opts.in
Normal file
18
graphics/vlc/files/patch-Makefile.opts.in
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.opts.in.orig Tue Aug 7 19:55:49 2001
|
||||
+++ Makefile.opts.in Sun Aug 12 15:01:13 2001
|
||||
@@ -200,6 +200,7 @@
|
||||
CFLAGS += -fnative-struct -D_OFF_T_ -D_off_t=long
|
||||
endif
|
||||
|
||||
+ifeq ($(MODIFY_CFLAGS),1)
|
||||
ifneq (,$(findstring bsd,$(SYS)))
|
||||
CFLAGS += -pthread
|
||||
endif
|
||||
@@ -235,6 +236,7 @@
|
||||
endif
|
||||
|
||||
#end of optimisations
|
||||
+endif
|
||||
endif
|
||||
|
||||
#
|
14
graphics/vlc/files/patch-configure
Normal file
14
graphics/vlc/files/patch-configure
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- configure.orig Tue Aug 7 19:55:49 2001
|
||||
+++ configure Sun Aug 12 15:36:05 2001
|
||||
@@ -3924,10 +3924,7 @@
|
||||
|
||||
if test x$enable_dsp != xno
|
||||
then
|
||||
- if test -c /dev/dsp
|
||||
- then
|
||||
- PLUGINS="${PLUGINS} dsp"
|
||||
- fi
|
||||
+ PLUGINS="${PLUGINS} dsp"
|
||||
fi
|
||||
|
||||
# Check whether --enable-esd or --disable-esd was given.
|
|
@ -2,12 +2,14 @@ bin/vlc
|
|||
bin/gvlc
|
||||
include/videolan/dvdcss.h
|
||||
lib/libdvdcss.a
|
||||
lib/libdvdcss.so
|
||||
lib/libdvdcss.so.0
|
||||
lib/libdvdcss.so.0.0.2
|
||||
lib/videolan/vlc/dsp.so
|
||||
lib/videolan/vlc/gtk.so
|
||||
lib/videolan/vlc/sdl.so
|
||||
lib/videolan/vlc/x11.so
|
||||
lib/videolan/vlc/xvideo.so
|
||||
%%XF4%%lib/videolan/vlc/xvideo.so
|
||||
share/videolan/default8x16.psf
|
||||
share/videolan/default8x9.psf
|
||||
share/videolan/gnome-vlc.png
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= vlc
|
||||
PORTVERSION= 0.2.82
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/${PORTVERSION}/ \
|
||||
ftp://ftp.Awfulhak.org/pub/vlc/ \
|
||||
|
@ -16,12 +17,23 @@ MAINTAINER= brian@Awfulhak.org
|
|||
|
||||
LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PATH_GTKCONFIG="${PREFIX}/bin/gtk12-config" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
USE_GTK= yes
|
||||
USE_GMAKE= yes
|
||||
USE_BZIP2= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
post-patch:
|
||||
${PERL} -pi.orig -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${XFREE86_VERSION} == 4
|
||||
PLIST_SUB= XF4=""
|
||||
.else
|
||||
PLIST_SUB= XF4="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
18
multimedia/vlc-devel/files/patch-Makefile.opts.in
Normal file
18
multimedia/vlc-devel/files/patch-Makefile.opts.in
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.opts.in.orig Tue Aug 7 19:55:49 2001
|
||||
+++ Makefile.opts.in Sun Aug 12 15:01:13 2001
|
||||
@@ -200,6 +200,7 @@
|
||||
CFLAGS += -fnative-struct -D_OFF_T_ -D_off_t=long
|
||||
endif
|
||||
|
||||
+ifeq ($(MODIFY_CFLAGS),1)
|
||||
ifneq (,$(findstring bsd,$(SYS)))
|
||||
CFLAGS += -pthread
|
||||
endif
|
||||
@@ -235,6 +236,7 @@
|
||||
endif
|
||||
|
||||
#end of optimisations
|
||||
+endif
|
||||
endif
|
||||
|
||||
#
|
14
multimedia/vlc-devel/files/patch-configure
Normal file
14
multimedia/vlc-devel/files/patch-configure
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- configure.orig Tue Aug 7 19:55:49 2001
|
||||
+++ configure Sun Aug 12 15:36:05 2001
|
||||
@@ -3924,10 +3924,7 @@
|
||||
|
||||
if test x$enable_dsp != xno
|
||||
then
|
||||
- if test -c /dev/dsp
|
||||
- then
|
||||
- PLUGINS="${PLUGINS} dsp"
|
||||
- fi
|
||||
+ PLUGINS="${PLUGINS} dsp"
|
||||
fi
|
||||
|
||||
# Check whether --enable-esd or --disable-esd was given.
|
|
@ -2,12 +2,14 @@ bin/vlc
|
|||
bin/gvlc
|
||||
include/videolan/dvdcss.h
|
||||
lib/libdvdcss.a
|
||||
lib/libdvdcss.so
|
||||
lib/libdvdcss.so.0
|
||||
lib/libdvdcss.so.0.0.2
|
||||
lib/videolan/vlc/dsp.so
|
||||
lib/videolan/vlc/gtk.so
|
||||
lib/videolan/vlc/sdl.so
|
||||
lib/videolan/vlc/x11.so
|
||||
lib/videolan/vlc/xvideo.so
|
||||
%%XF4%%lib/videolan/vlc/xvideo.so
|
||||
share/videolan/default8x16.psf
|
||||
share/videolan/default8x9.psf
|
||||
share/videolan/gnome-vlc.png
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= vlc
|
||||
PORTVERSION= 0.2.82
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/${PORTVERSION}/ \
|
||||
ftp://ftp.Awfulhak.org/pub/vlc/ \
|
||||
|
@ -16,12 +17,23 @@ MAINTAINER= brian@Awfulhak.org
|
|||
|
||||
LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PATH_GTKCONFIG="${PREFIX}/bin/gtk12-config" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
USE_GTK= yes
|
||||
USE_GMAKE= yes
|
||||
USE_BZIP2= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
post-patch:
|
||||
${PERL} -pi.orig -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${XFREE86_VERSION} == 4
|
||||
PLIST_SUB= XF4=""
|
||||
.else
|
||||
PLIST_SUB= XF4="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
18
multimedia/vlc/files/patch-Makefile.opts.in
Normal file
18
multimedia/vlc/files/patch-Makefile.opts.in
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- Makefile.opts.in.orig Tue Aug 7 19:55:49 2001
|
||||
+++ Makefile.opts.in Sun Aug 12 15:01:13 2001
|
||||
@@ -200,6 +200,7 @@
|
||||
CFLAGS += -fnative-struct -D_OFF_T_ -D_off_t=long
|
||||
endif
|
||||
|
||||
+ifeq ($(MODIFY_CFLAGS),1)
|
||||
ifneq (,$(findstring bsd,$(SYS)))
|
||||
CFLAGS += -pthread
|
||||
endif
|
||||
@@ -235,6 +236,7 @@
|
||||
endif
|
||||
|
||||
#end of optimisations
|
||||
+endif
|
||||
endif
|
||||
|
||||
#
|
14
multimedia/vlc/files/patch-configure
Normal file
14
multimedia/vlc/files/patch-configure
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- configure.orig Tue Aug 7 19:55:49 2001
|
||||
+++ configure Sun Aug 12 15:36:05 2001
|
||||
@@ -3924,10 +3924,7 @@
|
||||
|
||||
if test x$enable_dsp != xno
|
||||
then
|
||||
- if test -c /dev/dsp
|
||||
- then
|
||||
- PLUGINS="${PLUGINS} dsp"
|
||||
- fi
|
||||
+ PLUGINS="${PLUGINS} dsp"
|
||||
fi
|
||||
|
||||
# Check whether --enable-esd or --disable-esd was given.
|
|
@ -2,12 +2,14 @@ bin/vlc
|
|||
bin/gvlc
|
||||
include/videolan/dvdcss.h
|
||||
lib/libdvdcss.a
|
||||
lib/libdvdcss.so
|
||||
lib/libdvdcss.so.0
|
||||
lib/libdvdcss.so.0.0.2
|
||||
lib/videolan/vlc/dsp.so
|
||||
lib/videolan/vlc/gtk.so
|
||||
lib/videolan/vlc/sdl.so
|
||||
lib/videolan/vlc/x11.so
|
||||
lib/videolan/vlc/xvideo.so
|
||||
%%XF4%%lib/videolan/vlc/xvideo.so
|
||||
share/videolan/default8x16.psf
|
||||
share/videolan/default8x9.psf
|
||||
share/videolan/gnome-vlc.png
|
||||
|
|
Loading…
Reference in a new issue