wxHaskell is a portable and native GUI library for Haskell. It is built
on top of wxWidgets, a comprehensive C++ library that is portable across all major GUI platforms, including GTK, Windows, X11, and MacOS X. This version works with wxWidgets 2.8 only. Distributed under the WXWINDOWS LIBRARY LICENSE. Please see LICENSE file, but note that this is essentially LGPL with an exception allowing binary distribution of proprietary software. This is the same license as wxWidgets itself uses. WWW: http://haskell.org/haskellwiki/WxHaskell Obtained from: FreeBSD Haskell
This commit is contained in:
parent
804b93ca8f
commit
0df28bef5d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=291761
6 changed files with 49 additions and 0 deletions
|
@ -281,6 +281,7 @@ wai-extra_port= www/hs-wai-extra
|
|||
wai-logger_port= www/hs-wai-logger
|
||||
warp_port= www/hs-warp
|
||||
webkit_port= www/hs-webkit
|
||||
wxcore_port= x11-toolkits/hs-wxcore # lib_depends
|
||||
wxdirect_port= x11-toolkits/hs-wxdirect # executable
|
||||
X11_port= x11/hs-X11 # lib_depends
|
||||
X11-xft_port= x11/hs-X11-xft
|
||||
|
|
|
@ -88,6 +88,7 @@
|
|||
SUBDIR += hs-gtksourceview2
|
||||
SUBDIR += hs-pango
|
||||
SUBDIR += hs-vte
|
||||
SUBDIR += hs-wxcore
|
||||
SUBDIR += hs-wxdirect
|
||||
SUBDIR += irrlicht
|
||||
SUBDIR += itk
|
||||
|
|
24
x11-toolkits/hs-wxcore/Makefile
Normal file
24
x11-toolkits/hs-wxcore/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# New ports collection makefile for: hs-wxcore
|
||||
# Date created: January 26, 2012
|
||||
# Whom: haskell@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wxcore
|
||||
PORTVERSION= 0.13.2.1
|
||||
CATEGORIES= x11-toolkits haskell
|
||||
|
||||
MAINTAINER= haskell@FreeBSD.org
|
||||
COMMENT= wxHaskell core
|
||||
|
||||
|
||||
CABAL_SETUP= Setup.hs
|
||||
|
||||
USE_CABAL= parsec stm wxdirect>0.12.1.2
|
||||
|
||||
BUILD_DEPENDS+= wxgtk2-unicode>=2.8:${PORTSDIR}/x11-toolkits/wxgtk28-unicode \
|
||||
wxgtk2-unicode-contrib>=2.8:${PORTSDIR}/x11-toolkits/wxgtk28-unicode-contrib
|
||||
|
||||
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
|
||||
.include <bsd.port.mk>
|
2
x11-toolkits/hs-wxcore/distinfo
Normal file
2
x11-toolkits/hs-wxcore/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (cabal/wxcore-0.13.2.1.tar.gz) = 26a615a594f3733d79205dafd5e3e00649284c6b5a3dcd35b4db5fc1fb4e0d5c
|
||||
SIZE (cabal/wxcore-0.13.2.1.tar.gz) = 539205
|
11
x11-toolkits/hs-wxcore/files/patch-Setup.hs
Normal file
11
x11-toolkits/hs-wxcore/files/patch-Setup.hs
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./Setup.hs.orig 2012-02-07 08:27:09.000000000 +0100
|
||||
+++ ./Setup.hs 2012-02-15 09:35:23.000000000 +0100
|
||||
@@ -56,7 +56,7 @@
|
||||
wx_cfg_parms = if os == "mingw32"
|
||||
then [ "--unicode", "--libs", "gl,stc", "--cppflags" ]
|
||||
else [ "--libs", "std,gl,stc,xrc,richtext,aui,media", "--cppflags" ]
|
||||
- wx <- fmap parseWxConfig (readProcess "wx-config" wx_cfg_parms "")
|
||||
+ wx <- fmap parseWxConfig (readProcess "wxgtk2u-2.8-config" wx_cfg_parms "")
|
||||
lbi <- confHook simpleUserHooks (pkg0, pbi) flags
|
||||
|
||||
let lpd = localPkgDescr lbi
|
10
x11-toolkits/hs-wxcore/pkg-descr
Normal file
10
x11-toolkits/hs-wxcore/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
wxHaskell is a portable and native GUI library for Haskell. It is built
|
||||
on top of wxWidgets, a comprehensive C++ library that is portable across
|
||||
all major GUI platforms, including GTK, Windows, X11, and MacOS X. This
|
||||
version works with wxWidgets 2.8 only. Distributed under the WXWINDOWS
|
||||
LIBRARY LICENSE. Please see LICENSE file, but note that this is
|
||||
essentially LGPL with an exception allowing binary distribution of
|
||||
proprietary software. This is the same license as wxWidgets itself
|
||||
uses.
|
||||
|
||||
WWW: http://haskell.org/haskellwiki/WxHaskell
|
Loading…
Reference in a new issue