math/xlife++: Update 2.0.1 → 2.3
Reported by: portscout
This commit is contained in:
parent
b13d6a6c86
commit
0df7f81ad0
8 changed files with 63 additions and 84 deletions
|
@ -1,9 +1,8 @@
|
|||
PORTNAME= xlife++
|
||||
DISTVERSION= 2.0.1
|
||||
PORTREVISION= 7
|
||||
DISTVERSION= 2.3
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= https://uma.ensta-paristech.fr/soft/XLiFE++/var/files/src/
|
||||
DISTNAME= xlifepp-sources-v${DISTVERSION}-2018-05-09
|
||||
MASTER_SITES= https://uma.ensta-paristech.fr/soft/XLiFE++/downloads/binaries/
|
||||
DISTNAME= xlifepp-sources-v${DISTVERSION}-2022-04-22
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= XLiFE++: eXtended Library of Finite Elements in C++
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1526180007
|
||||
SHA256 (xlifepp-sources-v2.0.1-2018-05-09.tbz) = cebbff15d123b42bb4c6760ab2cf9ba1b2e65a8555bcdca9f786eaa8eb49a0cc
|
||||
SIZE (xlifepp-sources-v2.0.1-2018-05-09.tbz) = 190573097
|
||||
TIMESTAMP = 1688574100
|
||||
SHA256 (xlifepp-sources-v2.3-2022-04-22.tbz) = 1cdec9efb7f74a09f3daaa5df08c0dc74ea8081a936d1e2403c28c495345a986
|
||||
SIZE (xlifepp-sources-v2.3-2022-04-22.tbz) = 136367920
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- CMakeLists.txt.orig 2018-05-13 03:55:31 UTC
|
||||
--- CMakeLists.txt.orig 2022-04-22 18:54:13 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -235,7 +235,7 @@ endif()
|
||||
@@ -334,7 +334,7 @@ endif()
|
||||
set(XLIFEPP_LIBS "")
|
||||
foreach (lib ${libs})
|
||||
file(GLOB_RECURSE libsrcs src/${lib}/*.cpp)
|
||||
- add_library(xlifepp_${lib} STATIC ${libsrcs})
|
||||
+ add_library(xlifepp_${lib} SHARED ${libsrcs})
|
||||
target_compile_features(xlifepp_${lib} PUBLIC cxx_std_11)
|
||||
list(APPEND XLIFEPP_LIBS xlifepp_${lib})
|
||||
endforeach()
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- cmake/xlifepp_cpack_management.cmake.orig 2018-05-09 16:11:45 UTC
|
||||
--- cmake/xlifepp_cpack_management.cmake.orig 2022-04-22 18:54:13 UTC
|
||||
+++ cmake/xlifepp_cpack_management.cmake
|
||||
@@ -11,7 +11,7 @@ install(FILES "${CMAKE_SOURCE_DIR}/VERSI
|
||||
@@ -10,7 +10,7 @@ install(FILES "${CMAKE_SOURCE_DIR}/VERSION.txt"
|
||||
DESTINATION .
|
||||
COMPONENT configuration)
|
||||
install(DIRECTORY "${CMAKE_SOURCE_DIR}/cmake/"
|
||||
|
@ -9,7 +9,7 @@
|
|||
COMPONENT configuration
|
||||
PATTERN lock.cmake EXCLUDE
|
||||
PATTERN guessOS.cmake EXCLUDE
|
||||
@@ -43,7 +43,7 @@ endif()
|
||||
@@ -46,7 +46,7 @@ endif()
|
||||
configure_file(${CMAKE_SOURCE_DIR}/etc/templates/getBinaryConfig.cmake.cmake ${CMAKE_BINARY_DIR}/getBinaryConfig.cmake @ONLY)
|
||||
|
||||
install(FILES ${CMAKE_BINARY_DIR}/getBinaryConfig.cmake
|
||||
|
@ -18,7 +18,7 @@
|
|||
COMPONENT configuration)
|
||||
|
||||
file(GLOB headers "${CMAKE_SOURCE_DIR}/include/*.h")
|
||||
@@ -107,7 +107,7 @@ install(FILES "${CMAKE_SOURCE_DIR}/etc/g
|
||||
@@ -117,7 +117,7 @@ install(FILES "${CMAKE_SOURCE_DIR}/etc/gmsh/xlifepp_ma
|
||||
COMPONENT others)
|
||||
|
||||
install(DIRECTORY "${CMAKE_SOURCE_DIR}/etc/messages/"
|
||||
|
@ -27,7 +27,7 @@
|
|||
USE_SOURCE_PERMISSIONS
|
||||
COMPONENT others)
|
||||
|
||||
@@ -115,15 +115,15 @@ install(FILES "${CMAKE_SOURCE_DIR}/doc/t
|
||||
@@ -125,15 +125,15 @@ install(FILES "${CMAKE_SOURCE_DIR}/doc/tex/user_docume
|
||||
"${CMAKE_SOURCE_DIR}/doc/tex/dev_documentation.pdf"
|
||||
"${CMAKE_SOURCE_DIR}/doc/tex/examples.pdf"
|
||||
"${CMAKE_SOURCE_DIR}/doc/tex/tutorial.pdf"
|
||||
|
@ -45,4 +45,4 @@
|
|||
+ DESTINATION share/examples/xlife++
|
||||
COMPONENT others)
|
||||
|
||||
install(FILES "${CMAKE_SOURCE_DIR}/tools/visuTermVec.m"
|
||||
install(FILES "${CMAKE_SOURCE_DIR}/etc/visuTermVec.m"
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- cmake/xlifepp_user_management.cmake.orig 2019-03-30 12:09:49 UTC
|
||||
+++ cmake/xlifepp_user_management.cmake
|
||||
@@ -14,12 +14,17 @@ configure_file(${CMAKE_SOURCE_DIR}/etc/templates/CMake
|
||||
|
||||
# ask cmake --help to get the list of available generators
|
||||
execute_process(COMMAND ${CMAKE_COMMAND} --help OUTPUT_VARIABLE cmake_help)
|
||||
-string(FIND ${cmake_help} "The following generators are available on this platform:" cmake_generators_start_index)
|
||||
-math(EXPR cmake_generators_start_index ${cmake_generators_start_index}+57)
|
||||
+
|
||||
+# The generators are listed towards the bottom; in CMake 3.14 the
|
||||
+# header above the list of generators changed, so look for **part**
|
||||
+# of the header, and then skip the line that includes that header.
|
||||
+string(FIND ${cmake_help} "The following generators are available on this platform" cmake_generators_start_index)
|
||||
+math(EXPR cmake_generators_start_index ${cmake_generators_start_index})
|
||||
string(SUBSTRING ${cmake_help} ${cmake_generators_start_index} -1 cmake_generators)
|
||||
file(WRITE ${CMAKE_BINARY_DIR}/cmake_generators.txt ${cmake_generators})
|
||||
file(STRINGS ${CMAKE_BINARY_DIR}/cmake_generators.txt cmake_generator_list)
|
||||
file(REMOVE ${CMAKE_BINARY_DIR}/cmake_generators.txt)
|
||||
+list(REMOVE_AT cmake_generator_list 0) # First line, still says "The following..."
|
||||
list(LENGTH cmake_generator_list nbgeneratorlines)
|
||||
math(EXPR nbgeneratorlinesM1 ${nbgeneratorlines}-1)
|
||||
|
||||
@@ -122,6 +127,12 @@ set(isArch "0")
|
||||
foreach (i RANGE ${nbgeneratorlinesM1})
|
||||
list(GET cmake_generator_list ${i} line)
|
||||
if (NOT ${line} STREQUAL "")
|
||||
+ # In CMake 3.14, "* " marks the default generator at beginning of line
|
||||
+ string(SUBSTRING ${line} 0 2 marker)
|
||||
+ if ("* " STREQUAL "${marker}")
|
||||
+ string(SUBSTRING ${line} 2 -1 line)
|
||||
+ endif()
|
||||
+
|
||||
string(FIND ${line} = EQUALINDEX)
|
||||
string(STRIP ${line} buffer)
|
||||
string(SUBSTRING ${buffer} 0 1 firstcharacter)
|
|
@ -1,11 +1,11 @@
|
|||
--- src/utils/Environment.cpp.orig 2018-05-13 04:01:14 UTC
|
||||
--- src/utils/Environment.cpp.orig 2022-04-22 18:54:13 UTC
|
||||
+++ src/utils/Environment.cpp
|
||||
@@ -121,7 +121,7 @@ void Environment::processor()
|
||||
void Environment::setMsgFilePath()
|
||||
{
|
||||
@@ -122,7 +122,7 @@ void Environment::setMsgFilePath()
|
||||
string_t lang="en";
|
||||
if (theLanguage_ != 0) lang=languageString();
|
||||
#ifdef OS_IS_UNIX
|
||||
- thePathToMessageFiles_ = installPath() + "/etc/messages/" + languageString() + "/";
|
||||
+ thePathToMessageFiles_ = installPath() + "/share/xlife++/messages/" + languageString() + "/";
|
||||
- thePathToMessageFiles_ = installPath() + "/etc/messages/" + lang + "/";
|
||||
+ thePathToMessageFiles_ = installPath() + "/share/xlife++/messages/" + lang + "/";
|
||||
#elif defined(OS_IS_WIN)
|
||||
thePathToMessageFiles_ = installPath() + "\\etc\\messages\\" + languageString() + "\\";
|
||||
thePathToMessageFiles_ = installPath() + "\\etc\\messages\\" + lang + "\\";
|
||||
#endif
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- src/utils/memoryUtils.cpp.orig 2019-05-20 17:06:38 UTC
|
||||
+++ src/utils/memoryUtils.cpp
|
||||
@@ -27,8 +27,8 @@ XLiFE++ is an extended library of finite elements writ
|
||||
#include "utils.h"
|
||||
|
||||
#ifdef OS_IS_UNIX
|
||||
-#include <sys/sysctl.h>
|
||||
#include <sys/types.h>
|
||||
+#include <sys/sysctl.h>
|
||||
#include <sys/resource.h>
|
||||
#endif
|
||||
|
|
@ -1,3 +1,4 @@
|
|||
bin/xlifepp_configure.sh
|
||||
include/arpackppSupport/ARGenToStd.hpp
|
||||
include/arpackppSupport/ARInterface.hpp
|
||||
include/arpackppSupport/ArpackProb.hpp
|
||||
|
@ -64,6 +65,7 @@ include/finiteElements/hexahedron/GeomRefHexahedron.hpp
|
|||
include/finiteElements/hexahedron/LagrangeHexahedron.hpp
|
||||
include/finiteElements/hexahedron/NedelecEdgeHexahedron.hpp
|
||||
include/finiteElements/hexahedron/RefHexahedron.hpp
|
||||
include/finiteElements/integration/FilonIM.hpp
|
||||
include/finiteElements/integration/IntegrationMethod.hpp
|
||||
include/finiteElements/integration/Quadrature.hpp
|
||||
include/finiteElements/integration/QuadratureRule.hpp
|
||||
|
@ -90,10 +92,12 @@ include/finiteElements/tetrahedron/LagrangeTetrahedron.hpp
|
|||
include/finiteElements/tetrahedron/NedelecEdgeTetrahedron.hpp
|
||||
include/finiteElements/tetrahedron/NedelecFaceTetrahedron.hpp
|
||||
include/finiteElements/tetrahedron/RefTetrahedron.hpp
|
||||
include/finiteElements/triangle/ArgyrisTriangle.hpp
|
||||
include/finiteElements/triangle/CrouzeixRaviartTriangle.hpp
|
||||
include/finiteElements/triangle/GeomRefTriangle.hpp
|
||||
include/finiteElements/triangle/HermiteTriangle.hpp
|
||||
include/finiteElements/triangle/LagrangeTriangle.hpp
|
||||
include/finiteElements/triangle/MorleyTriangle.hpp
|
||||
include/finiteElements/triangle/NedelecTriangle.hpp
|
||||
include/finiteElements/triangle/RaviartThomasTriangle.hpp
|
||||
include/finiteElements/triangle/RefTriangle.hpp
|
||||
|
@ -103,11 +107,13 @@ include/form/LinearForm.hpp
|
|||
include/geometry.h
|
||||
include/geometry/DomainMap.hpp
|
||||
include/geometry/Extension.hpp
|
||||
include/geometry/Geodesic.hpp
|
||||
include/geometry/GeomDomain.hpp
|
||||
include/geometry/GeomElement.hpp
|
||||
include/geometry/GeomMapData.hpp
|
||||
include/geometry/Geometry.hpp
|
||||
include/geometry/Mesh.hpp
|
||||
include/geometry/OpenCascade/OpenCascade.hpp
|
||||
include/geometry/Parametrization.hpp
|
||||
include/geometry/geometries1D.hpp
|
||||
include/geometry/geometries2D.hpp
|
||||
|
@ -189,21 +195,30 @@ include/largeMatrix/skylineStorage/SkylineStorage.hpp
|
|||
include/largeMatrix/skylineStorage/SymSkylineStorage.hpp
|
||||
include/mathsResources.h
|
||||
include/mathsResources/GaussFormulae.hpp
|
||||
include/mathsResources/OdeSolver.hpp
|
||||
include/mathsResources/combinatorics.hpp
|
||||
include/mathsResources/earcut.hpp
|
||||
include/mathsResources/exactSolutions/exactSolutions.hpp
|
||||
include/mathsResources/fft.hpp
|
||||
include/mathsResources/greenFunctions/Helmholtz2dKernel.hpp
|
||||
include/mathsResources/greenFunctions/Helmholtz3dKernel.hpp
|
||||
include/mathsResources/greenFunctions/Laplace2dKernel.hpp
|
||||
include/mathsResources/greenFunctions/Laplace3dKernel.hpp
|
||||
include/mathsResources/greenFunctions/Maxwell3dKernel.hpp
|
||||
include/mathsResources/polynomialsRoots.hpp
|
||||
include/mathsResources/quadratureMethods.hpp
|
||||
include/mathsResources/randomGenerators.hpp
|
||||
include/mathsResources/specialFunctions/FockFunction.hpp
|
||||
include/mathsResources/specialFunctions/MalyuzhinetsFunction.hpp
|
||||
include/mathsResources/specialFunctions/amosWrapper/amosWrapper.hpp
|
||||
include/mathsResources/specialFunctions/specialFunctions.hpp
|
||||
include/mathsResources/spline.hpp
|
||||
include/operator.h
|
||||
include/operator/DifferentialOperator.hpp
|
||||
include/operator/KernelOperatorOnUnknowns.hpp
|
||||
include/operator/LcKernelOperatorOnUnknowns.hpp
|
||||
include/operator/LcOperatorOnUnknown.hpp
|
||||
include/operator/LcOperatorOnUnknowns.hpp
|
||||
include/operator/Operand.hpp
|
||||
include/operator/OperatorOnFunction.hpp
|
||||
include/operator/OperatorOnKernel.hpp
|
||||
|
@ -248,6 +263,9 @@ include/term/TensorKernel.hpp
|
|||
include/term/Term.hpp
|
||||
include/term/TermMatrix.hpp
|
||||
include/term/TermVector.hpp
|
||||
include/term/computation/Collino.hpp
|
||||
include/term/computation/CollinoIM.hpp
|
||||
include/term/computation/DGMatrixComputation.hpp
|
||||
include/term/computation/DuffyIM.hpp
|
||||
include/term/computation/FEMatrixComputation.hpp
|
||||
include/term/computation/FEOperatorComputation.hpp
|
||||
|
@ -260,6 +278,7 @@ include/term/computation/IESPMatrixComputation.hpp
|
|||
include/term/computation/LenoirSallesIM.hpp
|
||||
include/term/computation/SPMatrixComputation.hpp
|
||||
include/term/computation/SauterSchwabIM.hpp
|
||||
include/term/computation/SauterSchwabSymIM.hpp
|
||||
include/term/computation/otherComputation.hpp
|
||||
include/term/computation/termUtils.hpp
|
||||
include/term/decLinSys.hpp
|
||||
|
@ -272,6 +291,7 @@ include/umfpackSupport/UmfPackWrappers.hpp
|
|||
include/user_typedefs.h
|
||||
include/utils.h
|
||||
include/utils/Algorithms.hpp
|
||||
include/utils/AngleUnit.hpp
|
||||
include/utils/Collection.hpp
|
||||
include/utils/Environment.hpp
|
||||
include/utils/Function.hpp
|
||||
|
@ -285,8 +305,10 @@ include/utils/Parameters.hpp
|
|||
include/utils/Point.hpp
|
||||
include/utils/PrintStream.hpp
|
||||
include/utils/Reals.hpp
|
||||
include/utils/SparseMatrix.hpp
|
||||
include/utils/String.hpp
|
||||
include/utils/SymbolicFunction.hpp
|
||||
include/utils/Tabular.hpp
|
||||
include/utils/ThreadData.hpp
|
||||
include/utils/Timer.hpp
|
||||
include/utils/Trace.hpp
|
||||
|
@ -304,6 +326,25 @@ include/utils/printUtils.hpp
|
|||
include/utils/winUtils.hpp
|
||||
include/xlife++-libs.h
|
||||
include/xlife++.h
|
||||
lib/cmake/getBinaryConfig.cmake
|
||||
lib/cmake/linklibs_OC_win.rsp
|
||||
lib/cmake/modules/FindAMD.cmake
|
||||
lib/cmake/modules/FindCAMD.cmake
|
||||
lib/cmake/modules/FindCCOLAMD.cmake
|
||||
lib/cmake/modules/FindCHOLMOD.cmake
|
||||
lib/cmake/modules/FindCOLAMD.cmake
|
||||
lib/cmake/modules/FindMAGMA.cmake
|
||||
lib/cmake/modules/FindMETIS.cmake
|
||||
lib/cmake/modules/FindOPENMP_FLAGS.cmake
|
||||
lib/cmake/modules/FindUMFPACK.cmake
|
||||
lib/cmake/modules/FindXLIFEPP_OPENCASCADE.cmake
|
||||
lib/cmake/xlifeppUtils.cmake
|
||||
lib/cmake/xlifepp_cpack_management.cmake.orig
|
||||
lib/cmake/xlifepp_findPackage.cmake
|
||||
lib/cmake/xlifepp_libexts.cmake
|
||||
lib/cmake/xlifepp_user_management.cmake
|
||||
lib/libamos.a
|
||||
lib/libxlifepp_eigenSolvers.so
|
||||
lib/libxlifepp_essentialConditions.so
|
||||
lib/libxlifepp_finalize.so
|
||||
lib/libxlifepp_finiteElements.so
|
||||
|
@ -318,20 +359,6 @@ lib/libxlifepp_solvers.so
|
|||
lib/libxlifepp_space.so
|
||||
lib/libxlifepp_term.so
|
||||
lib/libxlifepp_utils.so
|
||||
lib/cmake/getBinaryConfig.cmake
|
||||
lib/cmake/guessCompiler.cmake
|
||||
lib/cmake/modules/FindAMD.cmake
|
||||
lib/cmake/modules/FindCAMD.cmake
|
||||
lib/cmake/modules/FindCCOLAMD.cmake
|
||||
lib/cmake/modules/FindCHOLMOD.cmake
|
||||
lib/cmake/modules/FindCOLAMD.cmake
|
||||
lib/cmake/modules/FindMETIS.cmake
|
||||
lib/cmake/modules/FindOPENMP_FLAGS.cmake
|
||||
lib/cmake/modules/FindUMFPACK.cmake
|
||||
lib/cmake/xlifepp_cpack_management.cmake.orig
|
||||
lib/cmake/xlifepp_findPackage.cmake
|
||||
lib/cmake/xlifepp_libexts.cmake
|
||||
lib/cmake/xlifepp_user_management.cmake
|
||||
%%DATADIR%%/messages/de/dictionary.txt
|
||||
%%DATADIR%%/messages/de/messages.txt
|
||||
%%DATADIR%%/messages/en/dictionary.txt
|
||||
|
|
Loading…
Reference in a new issue