ftp/filezilla: update to 3.15.0.1

- update to 3.15.0.1
- utilize USES=localbase to set correct CFLAGS/LDFLAGS [1]

PR:		206854
Submitted by:	matthew@reztek.cz (maintainer)
Submitted by:   koobs [1]
This commit is contained in:
Ruslan Makhmatkhanov 2016-02-05 17:47:04 +00:00
parent 1b18ba01bf
commit 0e04b930d9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=408240
4 changed files with 35 additions and 29 deletions

View file

@ -1,8 +1,7 @@
# Created by: alepulver
# $FreeBSD$
PORTNAME= filezilla
PORTVERSION= 3.14.1
PORTVERSION= 3.15.0.1
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/FileZilla_Client/${PORTVERSION}
DISTNAME= FileZilla_${PORTVERSION}_src
@ -15,7 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
BUILD_DEPENDS:= ${RUN_DEPENDS}
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
LIB_DEPENDS= libfilezilla.so:${PORTSDIR}/ftp/libfilezilla \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgnutls.so:${PORTSDIR}/security/gnutls \
libidn.so:${PORTSDIR}/dns/libidn \
libpugixml.so:${PORTSDIR}/textproc/pugixml
@ -23,13 +23,10 @@ LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
BROKEN_FreeBSD_9= requires C++14 complier, 9.x lacks C++11 standard library
INSTALLS_ICONS= yes
USES= compiler:c++14-lang gmake pkgconfig tar:bzip2
USE_SQLITE= 3
USES= compiler:c++14-lang gmake localbase pkgconfig sqlite tar:bzip2
USE_WX= 3.0
WX_CONF_ARGS= relative
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= DBUS NLS
@ -46,17 +43,8 @@ NLS_CONFIGURE_OFF= --disable-locales
CONFIGURE_ARGS+= --disable-manualupdatecheck
.endif
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == "gcc"
.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
# needed for __atomic_exchange_8, __atmoic_fetch_add_8, __atomic_store_8
CFLAGS+= -march=i586
.endif
.endif
post-patch:
${REINPLACE_CMD} -Ee 's|(dummy) wxrc|\1 ${WXRC_CMD:T}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (FileZilla_3.14.1_src.tar.bz2) = b10871b6ced5f52062b44deda037edb8a38090b226a018b9b64b1a1feb59d46c
SIZE (FileZilla_3.14.1_src.tar.bz2) = 4411187
SHA256 (FileZilla_3.15.0.1_src.tar.bz2) = 267d3e336a7ecc5277950f759a37016e9747e63d1fc315c6798f18d7fea38463
SIZE (FileZilla_3.15.0.1_src.tar.bz2) = 4405885

View file

@ -0,0 +1,11 @@
--- src/engine/proxy.cpp.orig 2016-02-02 04:43:36 UTC
+++ src/engine/proxy.cpp
@@ -4,6 +4,8 @@
#include <libfilezilla/private/windows.hpp>
#include <winsock2.h>
#include <ws2tcpip.h>
+#else
+ #include <sys/socket.h>
#endif
#include <filezilla.h>
#include "engineprivate.h"

View file

@ -3,15 +3,22 @@ client with lots of useful features and an intuitive interface.
Among others, the features of FileZilla include the following:
* Easy to use.
* Supports FTP, FTP over SSL/TLS (FTPS) and SSH File Transfer Protocol (SFTP).
* Cross-platform. Runs on Windows, Linux, *BSD, OSX and more.
* Available in many languages.
* Supports resume and transfer of large files >4GB.
* Powerful Site Manager and transfer queue.
* Drag & drop support.
* Configurable Speed limits.
* Filename filters.
* Network configuration wizard.
* Supports FTP, FTP over SSL/TLS (FTPS) and SSH File Transfer Protocol (SFTP)
* IPv6 support
* Available in many languages
* Supports resume and transfer of large files >4GB
* Tabbed user interface
* Powerful Site Manager and transfer queue
* Bookmarks
* Drag & drop support
* Configurable transfer speed limits
* Filename filters
* Network configuration wizard
* Remite file editing
* Keep-alive
* HTTP/1.1, SOCKS5 and FTP-Proxy support
* Logging to file
* Synchronized directory browsing
* Remote file search
WWW: http://filezilla-project.org/