Another attempt at fixing the vpopmail-5.4.30 local delivery problem:
fix the upstream Makefile's logic and actually install vusage.conf, while disabling the vusagec/vusaged check since we don't even install vusaged on FreeBSD. Pointed out by: garga PR: 141251 (hopefully for real this time!)
This commit is contained in:
parent
046f259016
commit
0e05139256
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=249478
4 changed files with 25 additions and 3 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= vpopmail
|
||||
PORTVERSION= 5.4.30
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION} \
|
||||
SF/${PORTNAME}/${PORTNAME}-devel/${PORTVERSION}
|
||||
|
|
|
@ -1,13 +1,14 @@
|
|||
Description: Install config files with -dist, do not add -fPIC.
|
||||
Install the config files with a -dist extension.
|
||||
Do not unconditionally add -fPIC, this is done only for shared libs.
|
||||
Actually look for and install the vusagec.conf sample file!
|
||||
Forwarded: not-needed
|
||||
Author: Peter Pentchev <roam@FreeBSD.org>
|
||||
Last-Update: 2010-01-05
|
||||
Last-Update: 2010-02-09
|
||||
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -320,12 +320,11 @@
|
||||
@@ -320,12 +320,12 @@
|
||||
noinst_HEADERS = md5.h vpopmail.h file_lock.h vauth.h vlimits.h maildirquota.h vcdb.h vldap.h vmysql.h voracle.h vpgsql.h vsybase.h vlog.h global.h hmac_md5.h seek.h vutil.h
|
||||
COMMONSOURCES = vpopmail.c md5.c bigdir.c vauth.c file_lock.c vpalias.c seek.c vlimits.c maildirquota.c vutil.c vlistlib.c backfill.c client.c conf.c ippp.c
|
||||
CONFIG_CLEAN_FILES = vauth.c cdb/conf-cc cdb/conf-ld cdb/compile cdb/load
|
||||
|
@ -15,6 +16,7 @@ Last-Update: 2010-01-05
|
|||
-VLIMITS = $(DESTDIR)@vpopmaildir@/etc/vlimits.default
|
||||
+MYSQLCONF = $(DESTDIR)@vpopmaildir@/etc/vpopmail.mysql-dist
|
||||
+VLIMITS = $(DESTDIR)@vpopmaildir@/etc/vlimits.default-dist
|
||||
+VUSAGECCONF = $(DESTDIR)@vpopmaildir@/etc/vusagec.conf-dist
|
||||
noinst_LIBRARIES = libvpopmail.a
|
||||
libvpopmail_a_SOURCES = $(COMMONSOURCES)
|
||||
libvpopmail_a_LIBADD = cdb/*.o
|
||||
|
|
17
mail/vpopmail/files/patch-vusagec.conf
Normal file
17
mail/vpopmail/files/patch-vusagec.conf
Normal file
|
@ -0,0 +1,17 @@
|
|||
Description: Disable vusage.conf since we don't install vusaged at all.
|
||||
Tracked down by: Renato Botelho <garga@FreeBSD.org>
|
||||
Forwarded: not-needed
|
||||
Author: Peter Pentchev <roam@FreeBSD.org>
|
||||
Last-Update: 2010-02-09
|
||||
|
||||
--- a/vusagec.conf
|
||||
+++ b/vusagec.conf
|
||||
@@ -23,7 +23,7 @@
|
||||
True or False
|
||||
*/
|
||||
|
||||
- Disable = False;
|
||||
+ Disable = True;
|
||||
|
||||
/*
|
||||
Daemon is listening on local socket
|
|
@ -77,6 +77,9 @@ vpopmail/etc/vlimits.default-dist
|
|||
%%MYSQL%%@unexec if cmp -s %D/vpopmail/etc/vpopmail.mysql %D/vpopmail/etc/vpopmail.mysql-dist; then rm -f %D/vpopmail/etc/vpopmail.mysql; fi
|
||||
%%MYSQL%%vpopmail/etc/vpopmail.mysql-dist
|
||||
%%MYSQL%%@exec if [ ! -f %D/vpopmail/etc/vpopmail.mysql ] ; then cp -p %D/%F %B/vpopmail.mysql; fi
|
||||
@unexec if cmp -s %D/vpopmail/etc/vusagec.conf %D/vpopmail/etc/vusagec.conf-dist; then rm -f %D/vpopmail/etc/vusagec.conf; fi
|
||||
vpopmail/etc/vusagec.conf-dist
|
||||
@exec if [ ! -f %D/vpopmail/etc/vusagec.conf ] ; then cp -p %D/%F %B/vusagec.conf; fi
|
||||
vpopmail/include/client.h
|
||||
vpopmail/include/conf.h
|
||||
vpopmail/include/config.h
|
||||
|
|
Loading…
Reference in a new issue