Upgrade to 0.8.7, add a patch for KANJI.

PR:		ports/8461
Submitted by:	Nakai@technologist.com
This commit is contained in:
Vanilla I. Shu 1998-10-28 15:50:26 +00:00
parent dc0893cde2
commit 0e26524c6a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=14234
6 changed files with 34 additions and 24 deletions

View file

@ -1,13 +1,13 @@
# New ports collection makefile for: eterm
# Version required: 0.8.6
# Version required: 0.8.7
# Date created: 24 November 1997
# Whom: Murray Stokely <murray@cdrom.com>
#
# $Id: Makefile,v 1.8 1998/09/25 09:52:45 asami Exp $
# $Id: Makefile,v 1.9 1998/10/09 18:05:11 vanilla Exp $
#
DISTNAME= Eterm-0.8.6
PKGNAME= eterm-0.8.6
DISTNAME= Eterm-0.8.7
PKGNAME= eterm-0.8.7
CATEGORIES= x11
MASTER_SITES= ftp://ftp.enlightenment.org/pub/Eterm/ \
http://www.tcserv.com/archive/E/
@ -20,17 +20,18 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
#ALL_TARGET= FreeBSD
MAN1= Eterm.1
pre-patch:
.if ( defined(KANJI) )
${CP} ${FILESDIR}/patch-kanji ${PATCHDIR}
.endif
post-install:
strip ${PREFIX}/bin/Eterm-0.8
chown root.wheel ${PREFIX}/bin/Eterm-0.8
chmod 4755 ${PREFIX}/bin/Eterm-0.8
chown root.wheel ${PREFIX}/bin/Eterm
chmod 4755 ${PREFIX}/bin/Eterm
.ifndef NOPORTDOCS
${INSTALL_DATA} ${WRKSRC}/ReleaseNotes ${PREFIX}/share/Eterm
${INSTALL_DATA} ${WRKSRC}/doc/Eterm.help ${PREFIX}/share/Eterm
${INSTALL_DATA} ${WRKSRC}/doc/Eterm.menu ${PREFIX}/share/Eterm
${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ref ${PREFIX}/share/Eterm
${INSTALL_DATA} ${WRKSRC}/doc/Eterm.tcap ${PREFIX}/share/Eterm
${INSTALL_DATA} ${WRKSRC}/doc/Eterm.ti ${PREFIX}/share/Eterm

View file

@ -1 +1 @@
MD5 (Eterm-0.8.6.tar.gz) = 795d4353a156232fec4283e946573d93
MD5 (Eterm-0.8.7.tar.gz) = 00de2b1fb7d35bff42337a9723195114

View file

@ -0,0 +1,9 @@
--- config.h.in.orig Mon Oct 26 19:34:07 1998
+++ config.h.in Mon Oct 26 19:34:37 1998
@@ -206,3 +206,6 @@
/* Define if you have the Kenny library (-lKenny). */
#undef HAVE_LIBKENNY
+
+/* Define if you want the KANJI mode enable. */
+#define KANJI

View file

@ -1,13 +1,12 @@
--- src/Makefile.in.orig Tue Sep 15 01:05:43 1998
+++ src/Makefile.in Sat Oct 10 01:06:41 1998
@@ -25,6 +25,10 @@
main.h menubar.h misc.h rxvtgrx.h screen.h scrollbar.h options.h \
system.h
--- src/Makefile.in.orig Fri Oct 23 01:09:50 1998
+++ src/Makefile.in Mon Oct 26 18:54:35 1998
@@ -123,6 +123,9 @@
system.h threads.h graphics/Makefile.am graphics/Makefile.in \
graphics/README graphics/data graphics/grxlib.c graphics/grxlib.h \
graphics/qplot.c
+ifeq ($(PORTOBJFORMAT),elf)
+LDFLAGS+=-Wl,-rpath,$(X11BASE)/lib
+endif
+
#
# Distribution variables
#
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h
CONFIG_CLEAN_FILES =

View file

@ -4,6 +4,9 @@ manager and as such places the importance of eyecandy and other aesthetic
qualities slightly above stability. Allows you to use scaled images as your
background for terminal windows, and much more!
If you want the KANJI feature enable, use
make -DKANJI install
http://www.tcserv.com/Eterm
http://www.rasterman.com
ported by murray@cdrom.com

View file

@ -1,6 +1,5 @@
bin/Esetroot
bin/Eterm
bin/Eterm-0.8
share/Eterm/themes/Eterm/Eterm.menu
share/Eterm/themes/Eterm/MAIN
share/Eterm/themes/chooser/MAIN
@ -15,7 +14,6 @@ share/Eterm/themes/tn3270/MAIN
share/Eterm/themes/trans/MAIN
share/Eterm/themes/trans/trans.menu
share/Eterm/Eterm.help
share/Eterm/Eterm.menu
share/Eterm/Eterm.ref
share/Eterm/Eterm.tcap
share/Eterm/Eterm.ti