Namkhai Bourquin 2023-09-01 21:33:39 +02:00 committed by Daniel Engberg
parent 42f2f4cbfa
commit 0e2e2bc035
8 changed files with 344 additions and 66 deletions

View file

@ -1,7 +1,6 @@
PORTNAME= netdata
DISTVERSIONPREFIX= v
DISTVERSION= 1.40.1
PORTREVISION= 1
DISTVERSION= 1.42.2
CATEGORIES= net-mgmt
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
@ -30,10 +29,10 @@ BINARY_ALIAS= ar=llvm-ar ranlib=llvm-ranlib
# Libs that you can't unbundle...
# SQLite3, --exclude database/sqlite/sqlite3*
# (lib)judy, --exclude libnetdata/libjudy
EXTRACT_AFTER_ARGS= --exclude httpd --exclude ml/dlib
EXTRACT_AFTER_ARGS= --exclude ml/dlib --exclude web/server/h2o
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-unit-tests --disable-httpd
CONFIGURE_ARGS= --disable-h2o --disable-unit-tests
INSTALL_TARGET= install-strip
CPPFLAGS+= -D_WANT_VMMETER
@ -51,7 +50,7 @@ PLIST_SUB= NETDATA_CACHE=${NETDATA_CACHE} \
NETDATA_PERST=${NETDATA_PERST}
OPTIONS_DEFINE= CLOUD CUPS DBENGINE FREEIPMI GOPLUGIN LTO ML
OPTIONS_DEFAULT= CLOUD DBENGINE LTO
OPTIONS_DEFAULT= CLOUD DBENGINE LTO ML
OPTIONS_EXCLUDE_riscv64= LTO
OPTIONS_SUB= YES
@ -106,6 +105,8 @@ post-install:
${STAGEDIR}${LOCALBASE}/lib/${PORTNAME}/conf.d/*/*.txt ; do \
${MV} $$fi $$fi".sample"; \
done)
${RM} ${STAGEDIR}${ETCDIR}/netdata-updater.conf
${RM} -r ${STAGEDIR}${PREFIX}/lib/netdata/system
post-install-CLOUD-off:
rm ${STAGEDIR}${PREFIX}/sbin/netdata-claim.sh

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1687890826
SHA256 (netdata-v1.40.1.tar.gz) = cc86172acd5e6ec05bc0fa86a50d967502a264d8adf7f79293923ccd8febb251
SIZE (netdata-v1.40.1.tar.gz) = 43354949
TIMESTAMP = 1693244143
SHA256 (netdata-v1.42.2.tar.gz) = 857108e3076f0d35de4109622847dea3ca750c326400798723a8f45a7842d276
SIZE (netdata-v1.42.2.tar.gz) = 46047621

View file

@ -34,26 +34,8 @@ load_rc_config $name
: ${netdata_enable="NO"}
: ${netdata_conf="%%ETCDIR%%/${name}.conf"}
: ${netdata_pid="%%NETDATA_PERST%%/${name}.pid"}
: # netdata_user set below, it may also be pulled from the netdata_conf file
: ${netdata_stop_maxwait=30}
# read netdata_conf and print the "run as user =" RHS, or print nothing if unset
#
# only permits ASCII letters, digits, dash, underscore - does not permit
# backtick, curly braces, angle brackets, backslash although passwd(5) would
# permit these.
get_user_from_conf() {
$SED -n '/^\[global\]/,/^\[/{s/^[[:space:]]*run as user.*=[[:space:]]*\(.*\)[[:space:]]*$/\1/p;}' "${netdata_conf}" \
| $TR -c -d 'a-zA-Z0-9_-'
}
# check if the rc.conf* file set and netdata_conf agree on the name to run the bundle as
check_user_consistency() {
cfusr=$(get_user_from_conf)
if [ -z "$cfusr" -o "$cfusr" = "${netdata_user}" ] ; then return 0 ; fi
err 1 "${netdata_conf} sets 'run as user = $cfusr', but rc.conf* sets '${netdata_user}'. Both must be consistent."
}
# this is more or less a copy of /etc/rc.subr from 12.1-RELEASE
# around Early April 2020, but with a timeout, killing children,
# and SIGKILL added because sometimes netdata hangs.
@ -103,20 +85,12 @@ stop_postcmd() {
rm -f "${netdata_pid}"
}
# obtain default user, first from configuration, or default to "netdata"
_netdata_user_default=$(get_user_from_conf)
: ${_netdata_user_default:="netdata"}
# and then, if rc.conf* don't set it, use the default
: ${netdata_user="${_netdata_user_default}"}
procname="%%PREFIX%%/sbin/${name}"
command="/usr/sbin/daemon"
command_args="-c -f \"${procname}\" -u \"${netdata_user}\" -P \"${netdata_pid}\" ${netdata_args}"
command_args="-c -f \"${procname}\" -P \"${netdata_pid}\" ${netdata_args}"
required_files="${netdata_conf}"
start_precmd=check_user_consistency
stop_cmd=stop_cmd
stop_postcmd=stop_postcmd # netdata always leaves its pid file behind.

View file

@ -1,6 +1,6 @@
--- Makefile.am.orig 2023-06-17 06:42:31 UTC
+++ Makefile.am
@@ -39,7 +39,6 @@ EXTRA_DIST = \
--- Makefile.am.orig 2023-07-23 18:43:42.030677684 -0600
+++ Makefile.am 2023-07-23 18:44:09.820603732 -0600
@@ -39,7 +39,6 @@
build/m4/ax_c__generic.m4 \
build/m4/ax_compiler_vendor.m4 \
build/m4/ax_cxx_compile_stdcxx.m4 \
@ -8,7 +8,7 @@
README.md \
LICENSE \
REDISTRIBUTED.md \
@@ -256,16 +255,15 @@ ML_FILES += \
@@ -254,16 +253,15 @@
ml/ad_charts.h \
ml/ad_charts.cc \
ml/Config.cc \

View file

@ -1,5 +1,5 @@
--- configure.ac.orig 2023-06-14 15:07:47 UTC
+++ configure.ac
--- configure.ac.orig 2023-07-23 18:34:41.165387302 -0600
+++ configure.ac 2023-07-23 18:42:45.117534306 -0600
@@ -5,11 +5,11 @@
AC_PREREQ(2.60)
@ -16,7 +16,7 @@
AM_MAINTAINER_MODE([disable])
if test x"$USE_MAINTAINER_MODE" = xyes; then
@@ -1261,14 +1261,14 @@ if test "${enable_ml}" = "yes" -a "${have_uuid}" != "y
@@ -1354,15 +1354,15 @@
fi
# Check if submodules have not been fetched. Fail if ML was explicitly requested.
@ -27,6 +27,7 @@
+# if test -f "ml/dlib/dlib/all/source.cpp"; then
+# AC_MSG_RESULT([yes])
have_ml_submodules="yes"
AC_DEFINE([HAVE_DLIB], [1], [dlib availability])
-else
- AC_MSG_RESULT([no])
- have_ml_submodules="no"
@ -38,7 +39,7 @@
if test "${enable_ml}" = "yes" -a "${have_ml_submodules}" = "no"; then
AC_MSG_ERROR([You have explicitly requested --enable-ml functionality but it cannot be built because the required git submodules are missing.])
@@ -1288,8 +1288,8 @@ fi
@@ -1382,8 +1382,8 @@
AM_CONDITIONAL([ENABLE_ML], [test "${build_ml}" = "yes"])
if test "${build_ml}" = "yes"; then
AC_DEFINE([ENABLE_ML], [1], [anomaly detection usability])
@ -49,7 +50,7 @@
fi
@@ -1694,14 +1694,14 @@ AC_SUBST([OPTIONAL_DL_LIBS])
@@ -1788,14 +1788,14 @@
AC_DEFINE_UNQUOTED([NETDATA_USER], ["${with_user}"], [use this user to drop privileged])

View file

@ -0,0 +1,15 @@
--- daemon/analytics.c.orig 2023-08-09 18:44:44.805963000 +0000
+++ daemon/analytics.c 2023-08-09 19:09:09.490652000 +0000
@@ -831,6 +831,12 @@
setenv("NETDATA_UPDATE_EVERY", b, 1);
}
+ netdata_log_error("NETDATA_CACHE_DIR: %s", netdata_configured_cache_dir);
+ netdata_log_error("NETDATA_LIB_DIR: %s", netdata_configured_varlib_dir);
+ netdata_log_error("NETDATA_LOCK_DIR: %s", netdata_configured_lock_dir);
+ netdata_log_error("NETDATA_LOG_DIR: %s", netdata_configured_log_dir);
+ netdata_log_error("HOME: %s", netdata_configured_home_dir);
+
setenv("NETDATA_VERSION", program_version, 1);
setenv("NETDATA_HOSTNAME", netdata_configured_hostname, 1);
setenv("NETDATA_CONFIG_DIR", verify_required_directory(netdata_configured_user_config_dir), 1);

View file

@ -0,0 +1,12 @@
--- daemon/main.c.orig 2023-08-09 19:47:06.833144000 +0000
+++ daemon/main.c 2023-08-09 19:47:43.035728000 +0000
@@ -1108,8 +1108,7 @@
netdata_configured_web_dir = config_get(CONFIG_SECTION_DIRECTORIES, "web", netdata_configured_web_dir);
netdata_configured_cache_dir = config_get(CONFIG_SECTION_DIRECTORIES, "cache", netdata_configured_cache_dir);
netdata_configured_varlib_dir = config_get(CONFIG_SECTION_DIRECTORIES, "lib", netdata_configured_varlib_dir);
- char *env_home=getenv("HOME");
- netdata_configured_home_dir = config_get(CONFIG_SECTION_DIRECTORIES, "home", env_home?env_home:netdata_configured_home_dir);
+ netdata_configured_home_dir = config_get(CONFIG_SECTION_DIRECTORIES, "home", netdata_configured_home_dir);
netdata_configured_lock_dir = initialize_lock_directory_path(netdata_configured_varlib_dir);

View file

@ -51,6 +51,7 @@
@sample(netdata,netdata,0640) lib/netdata/conf.d/health.d/elasticsearch.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/health.d/entropy.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/health.d/exporting.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/health.d/file_descriptors.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/health.d/gearman.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/health.d/geth.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/health.d/go.d.plugin.conf.sample
@ -163,20 +164,6 @@
@sample(netdata,netdata,0640) lib/netdata/conf.d/statsd.d/k6.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/stream.conf.sample
@sample(netdata,netdata,0640) lib/netdata/conf.d/vnodes/vnodes.conf.sample
lib/netdata/system/cron/netdata-updater-daily
lib/netdata/system/freebsd/rc.d/netdata
lib/netdata/system/initd/init.d/netdata
lib/netdata/system/launchd/netdata.plist
lib/netdata/system/logrotate/netdata
lib/netdata/system/lsb/init.d/netdata
lib/netdata/system/openrc/conf.d/netdata
lib/netdata/system/openrc/init.d/netdata
lib/netdata/system/runit/run
lib/netdata/system/systemd/50-netdata.preset
lib/netdata/system/systemd/netdata-updater.service
lib/netdata/system/systemd/netdata-updater.timer
lib/netdata/system/systemd/netdata.service
lib/netdata/system/systemd/netdata.service.v235
libexec/netdata/charts.d/ap.chart.sh
libexec/netdata/charts.d/apcupsd.chart.sh
libexec/netdata/charts.d/example.chart.sh
@ -191,11 +178,12 @@ libexec/netdata/plugins.d/alarm-notify.sh
libexec/netdata/plugins.d/alarm-test.sh
libexec/netdata/plugins.d/alarm.sh
libexec/netdata/plugins.d/anonymous-statistics.sh
@(,netdata,4750) libexec/netdata/plugins.d/apps.plugin
@(root,netdata,4750) libexec/netdata/plugins.d/apps.plugin
libexec/netdata/plugins.d/cgroup-name.sh
libexec/netdata/plugins.d/cgroup-network-helper.sh
libexec/netdata/plugins.d/charts.d.dryrun-helper.sh
libexec/netdata/plugins.d/charts.d.plugin
libexec/netdata/plugins.d/ebpf_thread_function.sh
%%CUPS%%libexec/netdata/plugins.d/cups.plugin
%%FREEIPMI%%libexec/netdata/plugins.d/freeipmi.plugin
libexec/netdata/plugins.d/get-kubernetes-labels.sh
@ -386,8 +374,11 @@ sbin/netdatacli
%%DATADIR%%/web/netdata-swagger.json
%%DATADIR%%/web/netdata-swagger.yaml
%%DATADIR%%/web/old/index.html
%%DATADIR%%/web/precache-manifest.21dcd7c609bff6504512face054c360f.js
%%DATADIR%%/web/precache-manifest.e2d3811ef5e4b7e75e1f56d6ee92ef2c.js
%%DATADIR%%/web/refresh-badges.js
%%DATADIR%%/web/registry-access.html
%%DATADIR%%/web/registry-alert-redirect.html
%%DATADIR%%/web/registry-hello.html
%%DATADIR%%/web/robots.txt
%%DATADIR%%/web/service-worker.js
%%DATADIR%%/web/sitemap.xml
@ -400,9 +391,9 @@ sbin/netdatacli
%%DATADIR%%/web/static/img/netdata-logomark.svg
%%DATADIR%%/web/static/js/10.a5cd7d0e.chunk.js
%%DATADIR%%/web/static/js/10.a5cd7d0e.chunk.js.map
%%DATADIR%%/web/static/js/2.ae48988e.chunk.js
%%DATADIR%%/web/static/js/2.ae48988e.chunk.js.LICENSE
%%DATADIR%%/web/static/js/2.ae48988e.chunk.js.map
%%DATADIR%%/web/static/js/2.62d105c5.chunk.js
%%DATADIR%%/web/static/js/2.62d105c5.chunk.js.LICENSE
%%DATADIR%%/web/static/js/2.62d105c5.chunk.js.map
%%DATADIR%%/web/static/js/3.f137faca.chunk.js
%%DATADIR%%/web/static/js/3.f137faca.chunk.js.map
%%DATADIR%%/web/static/js/4.2dbcd906.chunk.js
@ -418,9 +409,9 @@ sbin/netdatacli
%%DATADIR%%/web/static/js/8.b4161ea2.chunk.js.map
%%DATADIR%%/web/static/js/9.a4363968.chunk.js
%%DATADIR%%/web/static/js/9.a4363968.chunk.js.map
%%DATADIR%%/web/static/js/main.76dfe4de.chunk.js
%%DATADIR%%/web/static/js/main.76dfe4de.chunk.js.LICENSE
%%DATADIR%%/web/static/js/main.76dfe4de.chunk.js.map
%%DATADIR%%/web/static/js/main.e248095a.chunk.js
%%DATADIR%%/web/static/js/main.e248095a.chunk.js.LICENSE
%%DATADIR%%/web/static/js/main.e248095a.chunk.js.map
%%DATADIR%%/web/static/js/runtime-main.08abed8f.js
%%DATADIR%%/web/static/js/runtime-main.08abed8f.js.map
%%DATADIR%%/web/static/media/ibm-plex-sans-latin-100.245539db.woff2
@ -452,8 +443,292 @@ sbin/netdatacli
%%DATADIR%%/web/static/media/ibm-plex-sans-latin-700italic.02954bee.woff2
%%DATADIR%%/web/static/media/ibm-plex-sans-latin-700italic.72e9af40.woff
%%DATADIR%%/web/static/media/material-icons.0509ab09.woff2
%%DATADIR%%/web/switch.html
%%DATADIR%%/web/tv-react.html
%%DATADIR%%/web/tv.html
%%DATADIR%%/web/v0/index.html
%%DATADIR%%/web/v1/index.html
%%DATADIR%%/web/v2/1115.6acb1d00b53342cf4a94.chunk.js
%%DATADIR%%/web/v2/1193.3f76ed755c2417f01c88.chunk.js
%%DATADIR%%/web/v2/1282.f65cc3329e7e3eb8e645.js
%%DATADIR%%/web/v2/161.c33d27d7097fd45f278a.chunk.js
%%DATADIR%%/web/v2/161.c33d27d7097fd45f278a.chunk.js.LICENSE.txt
%%DATADIR%%/web/v2/1655.f1c01cc3ba8b07dd8fae.chunk.js
%%DATADIR%%/web/v2/2008.abd553afe7a6bed8cfc0.chunk.js
%%DATADIR%%/web/v2/2097.d9ade1233ce20401ea8c.chunk.js
%%DATADIR%%/web/v2/2701.89070793921be1288bb5.css
%%DATADIR%%/web/v2/2701.98a4d24406e365a6ddf2.chunk.js
%%DATADIR%%/web/v2/2833.78752757c7ac33d196dc.js
%%DATADIR%%/web/v2/2833.78752757c7ac33d196dc.js.LICENSE.txt
%%DATADIR%%/web/v2/2934.47ca322b2e59e64a0dae.chunk.js
%%DATADIR%%/web/v2/3018.6eb82186a4656d2fce5d.chunk.js
%%DATADIR%%/web/v2/3018.6eb82186a4656d2fce5d.chunk.js.LICENSE.txt
%%DATADIR%%/web/v2/3032.7b4a2db28af84cd77c29.js
%%DATADIR%%/web/v2/3071.91b1f856187aeafde398.chunk.js
%%DATADIR%%/web/v2/3173.aedc1e477983499117c7.js
%%DATADIR%%/web/v2/3173.aedc1e477983499117c7.js.LICENSE.txt
%%DATADIR%%/web/v2/3241.c7a7e5d69626a9fb46d7.chunk.js
%%DATADIR%%/web/v2/3495.7af81a22f9d135da8cbe.js
%%DATADIR%%/web/v2/3495.7af81a22f9d135da8cbe.js.LICENSE.txt
%%DATADIR%%/web/v2/3564.ba0e994ade7f97d72c01.chunk.js
%%DATADIR%%/web/v2/3981.ccb665950325037c0dda.css
%%DATADIR%%/web/v2/3D_PARTY_LICENSES.txt
%%DATADIR%%/web/v2/4193.f5c9a2d9750a5bd2762d.chunk.js
%%DATADIR%%/web/v2/4324.cbc343a58b942aec5218.chunk.js
%%DATADIR%%/web/v2/4480.acae0ad582eb5265622a.js
%%DATADIR%%/web/v2/4523.e41d6aac9a6433f9efb2.js
%%DATADIR%%/web/v2/4523.e41d6aac9a6433f9efb2.js.LICENSE.txt
%%DATADIR%%/web/v2/4532.0b0105ffbdd6db6f5d9a.js
%%DATADIR%%/web/v2/4532.0b0105ffbdd6db6f5d9a.js.LICENSE.txt
%%DATADIR%%/web/v2/4581.a60c1ffca04af99239c9.chunk.js
%%DATADIR%%/web/v2/4744.38c08ef7e8943fa44006.chunk.js
%%DATADIR%%/web/v2/4814.31d804681a19b084daa5.chunk.js
%%DATADIR%%/web/v2/4890.24af5fbe5015c0b06c90.js
%%DATADIR%%/web/v2/4915.245eefea4f250bc84a58.chunk.js
%%DATADIR%%/web/v2/4934.565896e76ef20d10f992.chunk.js
%%DATADIR%%/web/v2/5091.07dfc76b1d5c1623c330.chunk.js
%%DATADIR%%/web/v2/5176.9ecb50692b5be2b8a5e2.js
%%DATADIR%%/web/v2/5176.9ecb50692b5be2b8a5e2.js.LICENSE.txt
%%DATADIR%%/web/v2/5316.0471244afc59c0d0d688.chunk.js
%%DATADIR%%/web/v2/5451.b7da2b924e4d74fa28fc.chunk.js
%%DATADIR%%/web/v2/5575.f2affb99b534dc6b7f3c.chunk.js
%%DATADIR%%/web/v2/5575.f2affb99b534dc6b7f3c.chunk.js.LICENSE.txt
%%DATADIR%%/web/v2/5623.d08ebc475a57a44d926c.js
%%DATADIR%%/web/v2/5765.a33732202b95bbb627db.chunk.js
%%DATADIR%%/web/v2/5969.f77624ecac93d1a600f5.chunk.js
%%DATADIR%%/web/v2/597.f721ec431cd86411331e.chunk.js
%%DATADIR%%/web/v2/6129.b1dace954d671f303383.chunk.js
%%DATADIR%%/web/v2/6143.43acacdf8b2b70da410f.chunk.js
%%DATADIR%%/web/v2/6252.c8a3dda4559b4b1a290f.chunk.js
%%DATADIR%%/web/v2/6264.900c132d66035feb8143.chunk.js
%%DATADIR%%/web/v2/6502.7c1716799823661c447d.chunk.js
%%DATADIR%%/web/v2/6610.af47b6cda809af7dc878.chunk.js
%%DATADIR%%/web/v2/6613.384da655707f4c3b6153.css
%%DATADIR%%/web/v2/6613.b8903cda67bd33100ce4.chunk.js
%%DATADIR%%/web/v2/6613.b8903cda67bd33100ce4.chunk.js.LICENSE.txt
%%DATADIR%%/web/v2/6654.1a629783ec67ee7b2535.chunk.js
%%DATADIR%%/web/v2/6723.c82b4d5b9c7d8207b985.chunk.js
%%DATADIR%%/web/v2/6723.cc9fa5f3bdc0bf3ab2fc.css
%%DATADIR%%/web/v2/6817.a41c740ef4ad290ddc09.chunk.js
%%DATADIR%%/web/v2/7241.dae29a2c5dba9d8b64c6.chunk.js
%%DATADIR%%/web/v2/7359.47dc8a0852f6cefdf8e4.chunk.js
%%DATADIR%%/web/v2/7514.685fae6aee82518a9737.chunk.js
%%DATADIR%%/web/v2/7514.685fae6aee82518a9737.chunk.js.LICENSE.txt
%%DATADIR%%/web/v2/7707.d32bdcf8038b7eebaa97.js
%%DATADIR%%/web/v2/7707.d32bdcf8038b7eebaa97.js.LICENSE.txt
%%DATADIR%%/web/v2/8086.9d0c359423067e788807.chunk.js
%%DATADIR%%/web/v2/8102.0d5c0d9f32667fc42e0c.chunk.js
%%DATADIR%%/web/v2/8282.85c31db36364366177ab.chunk.js
%%DATADIR%%/web/v2/8447.37fff40af8864776d155.chunk.js
%%DATADIR%%/web/v2/8663.defe390dbe87f8ebb98f.chunk.js
%%DATADIR%%/web/v2/8837.c7fd14cf3df616fdcc8f.chunk.js
%%DATADIR%%/web/v2/8977.1e728c5c7e9af0e0089b.chunk.js
%%DATADIR%%/web/v2/9020.afb7f9501284f53ab885.chunk.js
%%DATADIR%%/web/v2/9201.3b4bde3431aac911f02e.chunk.js
%%DATADIR%%/web/v2/9360.eda00d2b12ba6fe04e3e.chunk.js
%%DATADIR%%/web/v2/9510.dfc219c382691661c69a.chunk.js
%%DATADIR%%/web/v2/9851.cd13a054c85cef198291.chunk.js
%%DATADIR%%/web/v2/LICENSE.md
%%DATADIR%%/web/v2/agent.html
%%DATADIR%%/web/v2/allFiles.6.29.0.json
%%DATADIR%%/web/v2/allFiles.6.json
%%DATADIR%%/web/v2/app.0917ff2bf5d3b8b0678d.css
%%DATADIR%%/web/v2/app.7bf3bd12482ad161443d.js
%%DATADIR%%/web/v2/bundlesManifest.6.json
%%DATADIR%%/web/v2/editor.b20cc786651a0c83801c.chunk.js
%%DATADIR%%/web/v2/favicon.ico
%%DATADIR%%/web/v2/index.html
%%DATADIR%%/web/v2/local-agent.html
%%DATADIR%%/web/v2/npm.react.dom.6431597f0353cbef2a34.js
%%DATADIR%%/web/v2/npm.react.dom.6431597f0353cbef2a34.js.LICENSE.txt
%%DATADIR%%/web/v2/registry-access.html
%%DATADIR%%/web/v2/registry-alert-redirect.html
%%DATADIR%%/web/v2/registry-hello.html
%%DATADIR%%/web/v2/runtime.e3716b90b888609b7a5c.js
%%DATADIR%%/web/v2/static/email/img/clea_badge.png
%%DATADIR%%/web/v2/static/email/img/clea_siren.png
%%DATADIR%%/web/v2/static/email/img/community_icon.png
%%DATADIR%%/web/v2/static/email/img/configure_icon.png
%%DATADIR%%/web/v2/static/email/img/crit_badge.png
%%DATADIR%%/web/v2/static/email/img/crit_siren.png
%%DATADIR%%/web/v2/static/email/img/flood_siren.png
%%DATADIR%%/web/v2/static/email/img/full_logo.png
%%DATADIR%%/web/v2/static/email/img/header.png
%%DATADIR%%/web/v2/static/email/img/isotype_600.png
%%DATADIR%%/web/v2/static/email/img/label_critical.png
%%DATADIR%%/web/v2/static/email/img/label_recovered.png
%%DATADIR%%/web/v2/static/email/img/label_warning.png
%%DATADIR%%/web/v2/static/email/img/reachability_siren.png
%%DATADIR%%/web/v2/static/email/img/warn_badge.png
%%DATADIR%%/web/v2/static/email/img/warn_siren.png
%%DATADIR%%/web/v2/static/img/list-style-image.svg
%%DATADIR%%/web/v2/static/img/logos/os/alpine.svg
%%DATADIR%%/web/v2/static/img/logos/os/arch.svg
%%DATADIR%%/web/v2/static/img/logos/os/centos.svg
%%DATADIR%%/web/v2/static/img/logos/os/coreos.svg
%%DATADIR%%/web/v2/static/img/logos/os/debian.svg
%%DATADIR%%/web/v2/static/img/logos/os/docker.svg
%%DATADIR%%/web/v2/static/img/logos/os/fedora.svg
%%DATADIR%%/web/v2/static/img/logos/os/freebsd.svg
%%DATADIR%%/web/v2/static/img/logos/os/freenas.svg
%%DATADIR%%/web/v2/static/img/logos/os/gentoo.svg
%%DATADIR%%/web/v2/static/img/logos/os/kubernetes.svg
%%DATADIR%%/web/v2/static/img/logos/os/linux-small.svg
%%DATADIR%%/web/v2/static/img/logos/os/linux.svg
%%DATADIR%%/web/v2/static/img/logos/os/macos.svg
%%DATADIR%%/web/v2/static/img/logos/os/manjaro.svg
%%DATADIR%%/web/v2/static/img/logos/os/openstack.svg
%%DATADIR%%/web/v2/static/img/logos/os/opensuse.svg
%%DATADIR%%/web/v2/static/img/logos/os/openwrt.svg
%%DATADIR%%/web/v2/static/img/logos/os/oracle.svg
%%DATADIR%%/web/v2/static/img/logos/os/pfsense.svg
%%DATADIR%%/web/v2/static/img/logos/os/placeholder.svg
%%DATADIR%%/web/v2/static/img/logos/os/raspberry-pi.svg
%%DATADIR%%/web/v2/static/img/logos/os/redhat.svg
%%DATADIR%%/web/v2/static/img/logos/os/suse.svg
%%DATADIR%%/web/v2/static/img/logos/os/ubuntu.svg
%%DATADIR%%/web/v2/static/img/logos/services/access-point.svg
%%DATADIR%%/web/v2/static/img/logos/services/activemq.svg
%%DATADIR%%/web/v2/static/img/logos/services/adaptec.svg
%%DATADIR%%/web/v2/static/img/logos/services/alerta.svg
%%DATADIR%%/web/v2/static/img/logos/services/apache.svg
%%DATADIR%%/web/v2/static/img/logos/services/apc.svg
%%DATADIR%%/web/v2/static/img/logos/services/aws-sns.svg
%%DATADIR%%/web/v2/static/img/logos/services/aws.svg
%%DATADIR%%/web/v2/static/img/logos/services/beanstalkd.svg
%%DATADIR%%/web/v2/static/img/logos/services/boinc.svg
%%DATADIR%%/web/v2/static/img/logos/services/btrfs.svg
%%DATADIR%%/web/v2/static/img/logos/services/ceph.svg
%%DATADIR%%/web/v2/static/img/logos/services/chrony.svg
%%DATADIR%%/web/v2/static/img/logos/services/cloud.svg
%%DATADIR%%/web/v2/static/img/logos/services/concul.svg
%%DATADIR%%/web/v2/static/img/logos/services/consul.svg
%%DATADIR%%/web/v2/static/img/logos/services/container.svg
%%DATADIR%%/web/v2/static/img/logos/services/couchdb.svg
%%DATADIR%%/web/v2/static/img/logos/services/cups.svg
%%DATADIR%%/web/v2/static/img/logos/services/data-encryption.svg
%%DATADIR%%/web/v2/static/img/logos/services/ddos.svg
%%DATADIR%%/web/v2/static/img/logos/services/discord.svg
%%DATADIR%%/web/v2/static/img/logos/services/dns.svg
%%DATADIR%%/web/v2/static/img/logos/services/docker.svg
%%DATADIR%%/web/v2/static/img/logos/services/dovecot.svg
%%DATADIR%%/web/v2/static/img/logos/services/elasticsearch.svg
%%DATADIR%%/web/v2/static/img/logos/services/email.svg
%%DATADIR%%/web/v2/static/img/logos/services/exim.svg
%%DATADIR%%/web/v2/static/img/logos/services/fail2ban.svg
%%DATADIR%%/web/v2/static/img/logos/services/flock.svg
%%DATADIR%%/web/v2/static/img/logos/services/fluentd.svg
%%DATADIR%%/web/v2/static/img/logos/services/fping.svg
%%DATADIR%%/web/v2/static/img/logos/services/freeradius.svg
%%DATADIR%%/web/v2/static/img/logos/services/fronius.svg
%%DATADIR%%/web/v2/static/img/logos/services/gnu-freeipmi.svg
%%DATADIR%%/web/v2/static/img/logos/services/golang.svg
%%DATADIR%%/web/v2/static/img/logos/services/grafana.svg
%%DATADIR%%/web/v2/static/img/logos/services/graphite.svg
%%DATADIR%%/web/v2/static/img/logos/services/haproxy.svg
%%DATADIR%%/web/v2/static/img/logos/services/hub.svg
%%DATADIR%%/web/v2/static/img/logos/services/icecast.svg
%%DATADIR%%/web/v2/static/img/logos/services/influxdb.svg
%%DATADIR%%/web/v2/static/img/logos/services/ipfs.svg
%%DATADIR%%/web/v2/static/img/logos/services/irc.svg
%%DATADIR%%/web/v2/static/img/logos/services/isc.svg
%%DATADIR%%/web/v2/static/img/logos/services/kafka.svg
%%DATADIR%%/web/v2/static/img/logos/services/kairosdb.svg
%%DATADIR%%/web/v2/static/img/logos/services/kavenegar.svg
%%DATADIR%%/web/v2/static/img/logos/services/key-file.svg
%%DATADIR%%/web/v2/static/img/logos/services/kubernetes.svg
%%DATADIR%%/web/v2/static/img/logos/services/libreswan.svg
%%DATADIR%%/web/v2/static/img/logos/services/libvirt.svg
%%DATADIR%%/web/v2/static/img/logos/services/lighthttpd.svg
%%DATADIR%%/web/v2/static/img/logos/services/linux.svg
%%DATADIR%%/web/v2/static/img/logos/services/litespeed.svg
%%DATADIR%%/web/v2/static/img/logos/services/lm-sensors.svg
%%DATADIR%%/web/v2/static/img/logos/services/load-balancer.svg
%%DATADIR%%/web/v2/static/img/logos/services/log-file.svg
%%DATADIR%%/web/v2/static/img/logos/services/logstash.svg
%%DATADIR%%/web/v2/static/img/logos/services/lxd.svg
%%DATADIR%%/web/v2/static/img/logos/services/mariadb.svg
%%DATADIR%%/web/v2/static/img/logos/services/memcached.svg
%%DATADIR%%/web/v2/static/img/logos/services/messagebird.svg
%%DATADIR%%/web/v2/static/img/logos/services/mongodb.svg
%%DATADIR%%/web/v2/static/img/logos/services/monit.svg
%%DATADIR%%/web/v2/static/img/logos/services/monitoring.svg
%%DATADIR%%/web/v2/static/img/logos/services/mysql.svg
%%DATADIR%%/web/v2/static/img/logos/services/netfilter.svg
%%DATADIR%%/web/v2/static/img/logos/services/network-protocol.svg
%%DATADIR%%/web/v2/static/img/logos/services/network.svg
%%DATADIR%%/web/v2/static/img/logos/services/nfs.svg
%%DATADIR%%/web/v2/static/img/logos/services/nginx-plus.svg
%%DATADIR%%/web/v2/static/img/logos/services/nginx.svg
%%DATADIR%%/web/v2/static/img/logos/services/notification-bell.svg
%%DATADIR%%/web/v2/static/img/logos/services/nsd.svg
%%DATADIR%%/web/v2/static/img/logos/services/ntpd.svg
%%DATADIR%%/web/v2/static/img/logos/services/nut.svg
%%DATADIR%%/web/v2/static/img/logos/services/nvidia.svg
%%DATADIR%%/web/v2/static/img/logos/services/openldap.svg
%%DATADIR%%/web/v2/static/img/logos/services/opensips.svg
%%DATADIR%%/web/v2/static/img/logos/services/opentsdb.svg
%%DATADIR%%/web/v2/static/img/logos/services/openvpn.svg
%%DATADIR%%/web/v2/static/img/logos/services/openzfs.svg
%%DATADIR%%/web/v2/static/img/logos/services/oracle.svg
%%DATADIR%%/web/v2/static/img/logos/services/pagerduty.svg
%%DATADIR%%/web/v2/static/img/logos/services/php-fpm.svg
%%DATADIR%%/web/v2/static/img/logos/services/placeholder.svg
%%DATADIR%%/web/v2/static/img/logos/services/postfix.svg
%%DATADIR%%/web/v2/static/img/logos/services/postgresql.svg
%%DATADIR%%/web/v2/static/img/logos/services/powerdns.svg
%%DATADIR%%/web/v2/static/img/logos/services/processor.svg
%%DATADIR%%/web/v2/static/img/logos/services/prometheus.svg
%%DATADIR%%/web/v2/static/img/logos/services/prowl.svg
%%DATADIR%%/web/v2/static/img/logos/services/proxysql.svg
%%DATADIR%%/web/v2/static/img/logos/services/puppet.svg
%%DATADIR%%/web/v2/static/img/logos/services/pushbullet.svg
%%DATADIR%%/web/v2/static/img/logos/services/pushover.svg
%%DATADIR%%/web/v2/static/img/logos/services/qos.svg
%%DATADIR%%/web/v2/static/img/logos/services/rabbitmq.svg
%%DATADIR%%/web/v2/static/img/logos/services/raspberry-pi.svg
%%DATADIR%%/web/v2/static/img/logos/services/redis.svg
%%DATADIR%%/web/v2/static/img/logos/services/rethinkdb.svg
%%DATADIR%%/web/v2/static/img/logos/services/retroshare.svg
%%DATADIR%%/web/v2/static/img/logos/services/rocketchat.svg
%%DATADIR%%/web/v2/static/img/logos/services/samba.svg
%%DATADIR%%/web/v2/static/img/logos/services/server-connection.svg
%%DATADIR%%/web/v2/static/img/logos/services/slack.svg
%%DATADIR%%/web/v2/static/img/logos/services/sma.svg
%%DATADIR%%/web/v2/static/img/logos/services/smstools3.svg
%%DATADIR%%/web/v2/static/img/logos/services/solr.svg
%%DATADIR%%/web/v2/static/img/logos/services/spigot.svg
%%DATADIR%%/web/v2/static/img/logos/services/springboot.svg
%%DATADIR%%/web/v2/static/img/logos/services/squid.svg
%%DATADIR%%/web/v2/static/img/logos/services/statsd.svg
%%DATADIR%%/web/v2/static/img/logos/services/stiebel.svg
%%DATADIR%%/web/v2/static/img/logos/services/systemd.svg
%%DATADIR%%/web/v2/static/img/logos/services/telegram.svg
%%DATADIR%%/web/v2/static/img/logos/services/temperature.svg
%%DATADIR%%/web/v2/static/img/logos/services/tomcat.svg
%%DATADIR%%/web/v2/static/img/logos/services/tor.svg
%%DATADIR%%/web/v2/static/img/logos/services/traefik.svg
%%DATADIR%%/web/v2/static/img/logos/services/twilio.svg
%%DATADIR%%/web/v2/static/img/logos/services/unbound.svg
%%DATADIR%%/web/v2/static/img/logos/services/uwsgi.svg
%%DATADIR%%/web/v2/static/img/logos/services/varnish.svg
%%DATADIR%%/web/v2/static/img/logos/services/veritas.svg
%%DATADIR%%/web/v2/static/img/logos/services/xen.svg
%%DATADIR%%/web/v2/static/img/mail/isotype.png
%%DATADIR%%/web/v2/static/img/mail/isotype.svg
%%DATADIR%%/web/v2/static/img/mail/logotype.png
%%DATADIR%%/web/v2/static/img/mail/logotype.svg
%%DATADIR%%/web/v2/static/img/no-filter-results.png
%%DATADIR%%/web/v2/static/img/no-nodes-room.svg
%%DATADIR%%/web/v2/static/img/rack.png
%%DATADIR%%/web/v2/static/site/pages/holding-page-503/holding-page-503.css
%%DATADIR%%/web/v2/static/site/pages/holding-page-503/holding-page-503.svg
%%DATADIR%%/web/v2/static/site/pages/holding-page-503/index.html
%%DATADIR%%/web/v2/static/site/pages/holding-page-503/multiple-logos-group.svg
%%DATADIR%%/web/v2/static/site/pages/holding-page-503/netdata-logo-white.svg
%%DATADIR%%/web/v2/static/site/pages/holding-page-503/reset.svg
%%DATADIR%%/web/v2/static/splash.css
%%DATADIR%%/web/v2/sw.js
%%DATADIR%%/web/version.txt
@mode
@owner