surf is a simple web browser based on WebKit/GTK+. It is able to display
websites and follow links. It supports the XEmbed protocol which makes it possible to embed it in another application. Furthermore, one can point surf to another URI by setting its XProperties. WWW: http://surf.suckless.org PR: ports/141854 Submitted by: Christopher Knaust <jigboe at gmx.de>
This commit is contained in:
parent
4964dea82a
commit
0e36b8d885
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=247144
5 changed files with 92 additions and 0 deletions
|
@ -1523,6 +1523,7 @@
|
|||
SUBDIR += srg
|
||||
SUBDIR += ssserver
|
||||
SUBDIR += suphp
|
||||
SUBDIR += surf
|
||||
SUBDIR += surfraw
|
||||
SUBDIR += swfdec-plugin
|
||||
SUBDIR += swiggle
|
||||
|
|
44
www/surf/Makefile
Normal file
44
www/surf/Makefile
Normal file
|
@ -0,0 +1,44 @@
|
|||
# New ports collection makefile for: surf
|
||||
# Date created: December 21, 2009
|
||||
# Whom: Christopher Knaust <jigboe@gmx.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= surf
|
||||
PORTVERSION= 0.3
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://dl.suckless.org/${PORTNAME}/ \
|
||||
LOCAL/glarkin
|
||||
|
||||
MAINTAINER= jigboe@gmx.de
|
||||
COMMENT= A simple Web browser based on WebKit/Gtk+
|
||||
|
||||
LIB_DEPENDS= webkit-1.0:${PORTSDIR}/www/webkit-gtk2
|
||||
RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu
|
||||
|
||||
USE_GNOME= gtk20 pkgconfig
|
||||
|
||||
MAN1= surf.1
|
||||
PLIST_FILES= bin/surf
|
||||
PORTDOCS= LICENSE README
|
||||
|
||||
pre-everything::
|
||||
@${ECHO_MSG} "You can build surf with your own config.h using the SURF_CONF knob:"
|
||||
@${ECHO_MSG} "make SURF_CONF=/path/to/surf/config.h install clean"
|
||||
|
||||
post-extract:
|
||||
.if defined(SURF_CONF)
|
||||
@${ECHO_MSG} "creating config.h from ${SURF_CONF}"
|
||||
@${CP} ${SURF_CONF} ${WRKSRC}/config.h
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
|
||||
@${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
www/surf/distinfo
Normal file
3
www/surf/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (surf-0.3.tar.gz) = 0b7bbe58f0ca140f1fb7aac09c4319d9
|
||||
SHA256 (surf-0.3.tar.gz) = 652a9ddb0a82a6350fabbc7c8d8a9f852b8c838263f892ac7695dfcdd5b31842
|
||||
SIZE (surf-0.3.tar.gz) = 9838
|
38
www/surf/files/patch-config.mk
Normal file
38
www/surf/files/patch-config.mk
Normal file
|
@ -0,0 +1,38 @@
|
|||
--- config.mk 2009-10-30 13:41:02.000000000 +0100
|
||||
+++ config.mk 2009-12-21 19:25:11.000000000 +0100
|
||||
@@ -4,25 +4,25 @@ VERSION = 0.3
|
||||
# Customize below to fit your system
|
||||
|
||||
# paths
|
||||
-PREFIX = /usr/local
|
||||
-MANPREFIX = ${PREFIX}/share/man
|
||||
+PREFIX?= /usr/local
|
||||
+MANPREFIX = ${PREFIX}/man
|
||||
|
||||
-GTKINC=$(shell pkg-config --cflags gtk+-2.0 webkit-1.0)
|
||||
-GTKLIB=$(shell pkg-config --libs gtk+-2.0 webkit-1.0)
|
||||
+GTKINC!= pkg-config --cflags gtk+-2.0 webkit-1.0
|
||||
+GTKLIB!= pkg-config --libs gtk+-2.0 webkit-1.0
|
||||
|
||||
|
||||
# includes and libs
|
||||
-INCS = -I. -I/usr/include ${GTKINC}
|
||||
-LIBS = -L/usr/lib -lc ${GTKLIB} -lgthread-2.0
|
||||
+INCS = ${GTKINC}
|
||||
+LIBS = ${PTHREAD_LIBS} ${GTKLIB}
|
||||
|
||||
# flags
|
||||
-CPPFLAGS = -DVERSION=\"${VERSION}\"
|
||||
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
|
||||
-LDFLAGS = -s ${LIBS}
|
||||
+CPPFLAGS+= -DVERSION=\"${VERSION}\"
|
||||
+CFLAGS+= -std=c99 ${INCS} ${CPPFLAGS}
|
||||
+LDFLAGS+= ${LIBS}
|
||||
|
||||
# Solaris
|
||||
#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
|
||||
#LDFLAGS = ${LIBS}
|
||||
|
||||
# compiler and linker
|
||||
-CC = cc
|
||||
+CC?= cc
|
6
www/surf/pkg-descr
Normal file
6
www/surf/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
surf is a simple web browser based on WebKit/GTK+. It is able to display
|
||||
websites and follow links. It supports the XEmbed protocol which makes
|
||||
it possible to embed it in another application. Furthermore, one can
|
||||
point surf to another URI by setting its XProperties.
|
||||
|
||||
WWW: http://surf.suckless.org
|
Loading…
Reference in a new issue