Upgrade to 1.2.0.
Changelog at <https://sourceforge.net/project/shownotes.php?release_id=502109>.
This commit is contained in:
parent
2c3998b2ef
commit
0e5ed3160c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=190326
4 changed files with 46 additions and 54 deletions
|
@ -6,8 +6,8 @@
|
|||
#
|
||||
|
||||
PORTNAME= cimg
|
||||
DISTVERSION= 1-19
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.2.0
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -45,6 +45,9 @@ LIB_DEPENDS+= png:${PORTSDIR}/graphics/png \
|
|||
tiff:${PORTSDIR}/graphics/tiff \
|
||||
Magick:${PORTSDIR}/graphics/ImageMagick \
|
||||
fftw3:${PORTSDIR}/math/fftw3
|
||||
ALL_TARGET= oFreeBSD
|
||||
.else
|
||||
ALL_TARGET= dFreeBSD
|
||||
. endif
|
||||
|
||||
DOCBASE= CHANGES.txt README.txt
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (cimg-1.19_2/CImg-1-19.zip) = 19a87b01a88deab20c8cbb0ce4f08980
|
||||
SHA256 (cimg-1.19_2/CImg-1-19.zip) = b4b35208668da3e12abf63a861dffb0db53f5f58adcf007c17e988b115363f5c
|
||||
SIZE (cimg-1.19_2/CImg-1-19.zip) = 3764961
|
||||
MD5 (cimg-1.2.0,1/CImg-1.2.0.zip) = c778850326587c6d3192a1f7bc8772a3
|
||||
SHA256 (cimg-1.2.0,1/CImg-1.2.0.zip) = fd558b7e161f9880bd7d4440feb4d30b04dcbe1952a3ba487daefd4496dba23e
|
||||
SIZE (cimg-1.2.0,1/CImg-1.2.0.zip) = 3988164
|
||||
|
|
|
@ -1,55 +1,31 @@
|
|||
--- examples/Makefile.orig Mon Mar 5 18:56:32 2007
|
||||
+++ examples/Makefile Mon Mar 5 20:52:01 2007
|
||||
@@ -29,10 +29,10 @@
|
||||
inrcast
|
||||
|
||||
--- examples/Makefile.orig Wed Apr 18 15:37:05 2007
|
||||
+++ examples/Makefile Wed Apr 18 23:59:18 2007
|
||||
@@ -37,10 +37,10 @@
|
||||
# Set correct variables and paths
|
||||
-CC = g++
|
||||
-X11PATH = /usr/X11R6
|
||||
-CFLAGS = -Wall -W -ansi -pedantic -ffast-math
|
||||
-LDFLAGS = -lm -lpthread
|
||||
+CC = $(CXX)
|
||||
+#X11PATH = /usr/X11R6
|
||||
+#CFLAGS = -Wall -W -ansi -pedantic -ffast-math
|
||||
+#LDFLAGS = -lm -lpthread
|
||||
#---------------------------------
|
||||
CIMG_VERSION = 1.20
|
||||
-CC = g++
|
||||
-X11PATH = /usr/X11R6
|
||||
-CFLAGS = -Wall -W -ansi -pedantic -ffast-math
|
||||
-LDFLAGS = -lm -lpthread
|
||||
+CC = $(CXX)
|
||||
+#X11PATH = /usr/X11R6
|
||||
+#CFLAGS = -Wall -W -ansi -pedantic -ffast-math
|
||||
+#LDFLAGS = -lm -lpthread
|
||||
|
||||
# Set CImg version number
|
||||
CIMG_VERSION = 1.19
|
||||
@@ -54,19 +54,19 @@
|
||||
CIMG_XRANDR_FLAGS = -Dcimg_use_xrandr -lXrandr
|
||||
#--------------------------------------------------
|
||||
# Set compilation flags allowing to customize CImg
|
||||
@@ -80,6 +80,9 @@
|
||||
# Flags to compile on Solaris
|
||||
CIMG_SOLARIS_FLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
|
||||
|
||||
# Uncomment to enable native support for PNG image files, using the PNG library.
|
||||
-#CIMG_PNG_FLAGS = -Dcimg_use_png -lpng -lz
|
||||
+CIMG_PNG_FLAGS = -Dcimg_use_png -lpng -lz
|
||||
|
||||
# Uncomment to enable native support for JPEG image files, using the JPEG library.
|
||||
-#CIMG_JPEG_FLAGS = -Dcimg_use_jpeg -ljpeg
|
||||
+CIMG_JPEG_FLAGS = -Dcimg_use_jpeg -ljpeg
|
||||
|
||||
# Uncomment to enable native support for TIFF image files, using the TIFF library.
|
||||
-#CIMG_TIFF_FLAGS = -Dcimg_use_tiff -ltiff
|
||||
+CIMG_TIFF_FLAGS = -Dcimg_use_tiff -ltiff
|
||||
|
||||
# Uncomment to enable native support of most classical image file formats, using the Magick++ library.
|
||||
-#CIMG_MAGICK_FLAGS = -Dcimg_use_magick `Magick++-config --cppflags` `Magick++-config --cxxflags` `Magick++-config --ldflags` `Magick++-config --libs`
|
||||
+CIMG_MAGICK_FLAGS = -Dcimg_use_magick `Magick++-config --cppflags` `Magick++-config --cxxflags` `Magick++-config --ldflags` `Magick++-config --libs`
|
||||
|
||||
# Uncomment to enable faster Discrete Fourier Transform computation, using the FFTW3 library
|
||||
-#CIMG_FFTW3_FLAGS = -Dcimg_use_fftw3 -lfftw3
|
||||
+CIMG_FFTW3_FLAGS = -Dcimg_use_fftw3 -lfftw3
|
||||
|
||||
EXTRA_FLAGS = $(CIMG_STRICT_FLAG) $(CIMG_XSHM_FLAGS) $(CIMG_XRANDR_FLAGS) $(CIMG_PNG_FLAGS) $(CIMG_JPEG_FLAGS) $(CIMG_TIFF_FLAGS) $(CIMG_MAGICK_FLAGS) $(CIMG_FFTW3_FLAGS)
|
||||
|
||||
@@ -75,7 +75,7 @@
|
||||
@echo
|
||||
@echo "** Compiling '$* ($(CIMG_VERSION))' with '`$(CC) -v 2>&1 | grep version`'"
|
||||
@echo
|
||||
- $(CC) -o $* $< $(CFLAGS) $(LDFLAGS) $(ARCHFLAGS)
|
||||
+ $(CC) -o $* $< $(CPPFLAGS) -ansi -ffast-math -I$(X11PATH)/include $(EXTRA_FLAGS) -lX11 -L$(X11PATH)/lib $(LDFLAGS)
|
||||
menu:
|
||||
@echo
|
||||
@echo "CImg Library $(CIMG_VERSION) : Examples"
|
||||
@@ -100,7 +100,7 @@
|
||||
+# Flags to compile on FreeBSD
|
||||
+CIMG_FREEBSD_FLAGS = -ansi -ffast-math -I$(X11PATH)/include $(EXTRA_FLAGS) -lX11 -L$(X11PATH)/lib
|
||||
+
|
||||
# Set default compilation flags.
|
||||
# Uncomment lines here, if you want to customize your default configuration
|
||||
CIMG_DEFAULT_FLAGS = $(CIMG_X11_FLAGS) \
|
||||
@@ -135,7 +138,7 @@
|
||||
all: $(CIMG_FILES)
|
||||
|
||||
clean:
|
||||
|
@ -58,3 +34,13 @@
|
|||
|
||||
# Linux/Mac OSX targets
|
||||
linux:
|
||||
@@ -161,3 +164,9 @@
|
||||
Msolaris:
|
||||
make "ARCHFLAGS=-Dcimg_display_type=0 -O3 $(CIMG_ALL_FLAGS)" all
|
||||
|
||||
+# FreeBSD targets
|
||||
+dFreeBSD:
|
||||
+ make "ARCHFLAGS=$(CIMG_FREEBSD_FLAGS) $(CIMG_DEFAULT_FLAGS)" all
|
||||
+
|
||||
+oFreeBSD:
|
||||
+ make "ARCHFLAGS=$(CIMG_FREEBSD_FLAGS) $(CIMG_ALL_FLAGS)" all
|
||||
|
|
|
@ -24,6 +24,7 @@ include/CImg.h
|
|||
%%PORTDOCS%%%%DOCSDIR%%/img/logoODYSSEE.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/img/postcard1.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/img/postcard2.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/img/postcard3.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/img/project-support.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/img/screenshots_item.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/img/ss_blobs.jpg
|
||||
|
@ -171,8 +172,10 @@ include/CImg.h
|
|||
%%PORTDOCS%%%%EXAMPLESDIR%%/cimgmatlab_cannyderiche.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/cimgmatlab_cannyderiche.m
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/dtmri_view.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/edge_explorer.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/fade_images.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/greycstoration.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/greycstoration4gimp.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/greycstoration4integration.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/hough_transform.cpp
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/image2ascii.cpp
|
||||
|
|
Loading…
Reference in a new issue