- Update to version 1.0.2

PR:		ports/63880
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2004-03-07 16:41:00 +00:00
parent abbf5f7915
commit 0ebb8e9194
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103205
7 changed files with 30 additions and 41 deletions

View file

@ -5,21 +5,25 @@
# $FreeBSD$
#
PORTNAME= mtrxmath
PORTVERSION= 0.9.3
PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
PORTNAME= mtrxmath
PORTVERSION= 1.0.2
CATEGORIES= math
MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= ports@FreeBSD.org
COMMENT= A small tool for matrix mathemetics
USE_GETOPT_LONG=yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
USE_GETOPT_LONG= yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PORTDOCS= README
PLIST_FILES= bin/mtrxmath
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mtrxmath ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/README.mtrxmath
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (mtrxmath-0.9.3.tar.gz) = 3cece8368ef32e8fe39a6b7774e2bc14
SIZE (mtrxmath-0.9.3.tar.gz) = 13479
MD5 (mtrxmath-1.0.2.tar.gz) = 7061de720440c470c83c322e7b6d0307
SIZE (mtrxmath-1.0.2.tar.gz) = 15889

View file

@ -1,12 +1,18 @@
--- Makefile.orig Mon Jan 8 08:29:11 2001
+++ Makefile Sun Jul 6 20:09:15 2003
@@ -1,4 +1,4 @@
-CFLAGS=-Wall -g
+CFLAGS+=-Wall -g ${CPPFLAGS}
--- Makefile.orig Mon Apr 9 10:26:51 2001
+++ Makefile Sun Mar 7 12:06:36 2004
@@ -1,10 +1,9 @@
# Edited for Debian GNU/Linux
DESTDIR=
-CFLAGS=-Wall
+CFLAGS+=-Wall ${CPPFLAGS}
IFLAGS=--owner=root --group=root
BASEPATH=${DESTDIR}/usr
BINPATH=${BASEPATH}/bin
-MANPATH=${BASEPATH}/share/man/man1
SRCS=add.c mtrxmath.c mult.c sub.c inverse.c
@@ -8,7 +8,7 @@
@@ -14,7 +13,7 @@
all: ${EXE}
${EXE}: ${OBJS}

View file

@ -1,11 +0,0 @@
--- mtrxmath.c.orig Tue Jan 9 20:44:12 2001
+++ mtrxmath.c Tue Jan 9 20:44:00 2001
@@ -102,7 +102,7 @@
exit(0);
}
if (cmdopt==INVERT) {
- final == inverse(foo);
+ final = inverse(foo);
show_matrix(final);
exit(0);
}

View file

@ -1,10 +0,0 @@
--- mult.c.orig Tue Jan 9 20:40:21 2001
+++ mult.c Tue Jan 9 20:40:28 2001
@@ -11,7 +11,6 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-#include <malloc.h>
#include "mtrxmath.h"
MATRIX_PTR matrix_multiply( MATRIX_PTR first, MATRIX_PTR second)

View file

@ -3,5 +3,7 @@ matrices of any size. It supports addition, subtraction,
multiplication, inversion, division, and will support whatever else is
necessary.
WWW: http://www.angelfire.com/linux/linuxjeff/mtrxmath/
- George Reid
greid@ukug.uk.freebsd.org

View file

@ -1,2 +0,0 @@
bin/mtrxmath
share/README.mtrxmath