- Update to 1.1a

ChangeLog:
    Support for XboX 360 dashboard Fall Update (.avi and .divx now are supported)
    DLNA support is not enabled by default, as not mandatory.
    Some configure script fixes and better support for cross-compilation.
    Fixed network interface discovery on MacOSX.
    Much more complete DLNA support through external libdlna.
    Telnet Control interface.
    Support for FLAC and HDMOV files.
    FreeBSD 64bit and MacOSX build fix.
    Newly written configure script.

PR:		128043
Submitted by:	"Eric L. Chen" <d9364104 at mail dot nchu dot edu dot tw>
Approved by:	Volker Theile <votdev at gmx dot de> (maintainer)
This commit is contained in:
Dmitry Marakasov 2008-10-23 12:39:26 +00:00
parent 00aaea76c7
commit 0ef6e73e2a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=221927
4 changed files with 39 additions and 41 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= ushare
PORTVERSION= 1.0
PORTREVISION= 3
PORTVERSION= 1.1a
CATEGORIES= net
MASTER_SITES= http://ushare.geexbox.org/releases/
@ -15,21 +14,26 @@ MAINTAINER= votdev@gmx.de
COMMENT= A lightweight UPnP (TM) A/V Media Server
LIB_DEPENDS= upnp.3:${PORTSDIR}/devel/upnp
BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
HAS_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_GETTEXT= yes
CONFIGURE_ENV+= CFLAGS="${PTHREAD_LIBS} -I${LOCALBASE}/include -I${WRKSRC}" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}.conf.sample etc/rc.d/${PORTNAME}
MAN1= ${PORTNAME}.1
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= pkgconfig
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}/lib \
--with-libintl-prefix=${LOCALBASE}/lib \
--with-libupnp-prefix=${LOCALBASE}
OPTIONS= LIBDLNA "Enable DLNA (PS3) support" off
.include <bsd.port.pre.mk>
CFLAGS+= ${PTHREAD_LIBS}
.if defined(WITH_LIBDLNA)
LIB_DEPENDS+= dlna:${PORTSDIR}/devel/libdlna
CONFIGURE_ARGS= --enable-dlna
.endif
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin

View file

@ -1,3 +1,3 @@
MD5 (ushare-1.0.tar.bz2) = a6dad95e61ded6f37fc158d9a81358dc
SHA256 (ushare-1.0.tar.bz2) = e788cf0403746f72ab14730a71a8231499f8636d5c82d3456d5f32301ebcd3d1
SIZE (ushare-1.0.tar.bz2) = 180426
MD5 (ushare-1.1a.tar.bz2) = 5bbcdbf1ff85a9710fa3d4e82ccaa251
SHA256 (ushare-1.1a.tar.bz2) = 7b9b85c79968d4f4560f02a99e33c6a33ff58f9d41d8faea79e31cce2ee78665
SIZE (ushare-1.1a.tar.bz2) = 65864

View file

@ -1,12 +0,0 @@
--- src/ushare.c.orig Sun Jul 1 18:57:22 2007
+++ src/ushare.c Wed Oct 3 11:03:45 2007
@@ -386,7 +386,8 @@
unsigned char *ptr;
#if (defined(BSD) || defined(__FreeBSD__))
- int mib[6], len;
+ int mib[6];
+ size_t len;
struct if_msghdr *ifm;
struct sockaddr_dl *sdl;
#else /* Linux */

View file

@ -1,20 +1,30 @@
--- scripts/ushare.orig Sun Feb 25 16:43:51 2007
+++ scripts/ushare Sun Feb 25 20:34:06 2007
@@ -1,74 +1,29 @@
--- scripts/ushare.orig 2008-10-13 13:23:21.000000000 +0800
+++ scripts/ushare 2008-10-13 13:24:47.000000000 +0800
@@ -1,82 +1,29 @@
-#!/bin/sh -e
+#!/bin/sh
#
-# uShare init script
+# ushare.sh for rc.d usage (c) 2007 Volker Theile <votdev@gmx.de>.
#
-### BEGIN INIT INFO
-# Required-Start: $local_fs $syslog
-# Provides: ushare
-# Required-Start: $local_fs $syslog $network
-# Should-Start:
-# Required-Stop:
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: start and stop ushare
-# Description:
-# Should-Stop:
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: uShare
-# Description: uShare UPnP (TM) A/V & DLNA Media Server
-# You should edit configuration in /etc/ushare.conf file
-# See http://ushare.geexbox.org for details
-### END INIT INFO
-
-PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-DAEMON=/usr/bin/ushare
-NAME=ushare
-DESC="uShare UPnP A/V Media Server"
-DESC="uShare UPnP A/V & DLNA Media Server"
-PIDFILE=/var/run/ushare.pid
-CONFIGFILE=/etc/ushare.conf
-
@ -73,11 +83,8 @@
- exit 1
- ;;
-esac
+#!/bin/sh
+#
+# ushare.sh for rc.d usage (c) 2007 Volker Theile <votdev@gmx.de>.
+#
+
-exit 0
+# PROVIDE: ushare
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
@ -100,6 +107,5 @@
+load_rc_config "$name"
+: ${ushare_enable="NO"}
+: ${ushare_flags=""}
-exit 0
+
+run_rc_command "$1"