- Update to 20130325
PR: 177377 Submitted by: Rudolf Cejka <cejkar@fit.vutbr.cz> (maintainer)
This commit is contained in:
parent
94c3b9cf6d
commit
0f09f53d20
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315454
9 changed files with 19 additions and 25 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= tnftpd
|
||||
PORTVERSION= 20100324
|
||||
PORTVERSION= 20130325
|
||||
CATEGORIES= ftp ipv6
|
||||
MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (tnftpd-20100324.tar.gz) = ff6b7c39f1bbdb9686a2c92652a59e8c81f1268dd329ff582db91a8ed76c599c
|
||||
SIZE (tnftpd-20100324.tar.gz) = 511110
|
||||
SHA256 (tnftpd-20130325.tar.gz) = 331006f0bcee593af3f4faaaf1de8db825e2aa60449be1c961916b37d562e147
|
||||
SIZE (tnftpd-20130325.tar.gz) = 518350
|
||||
|
|
|
@ -1,8 +1,13 @@
|
|||
--- configure.ac.orig 2010-03-24 05:31:39.000000000 -0700
|
||||
+++ configure.ac 2012-05-03 15:55:32.000000000 -0700
|
||||
@@ -87,3 +87,4 @@
|
||||
#
|
||||
-AC_PROG_CC
|
||||
+AM_PROG_CC_C_O
|
||||
+AM_PROG_AR
|
||||
AC_PROG_AWK
|
||||
Fix compilation error.
|
||||
|
||||
--- configure.ac.orig 2013-03-25 04:52:48.000000000 +0100
|
||||
+++ configure.ac 2013-03-25 17:03:53.000000000 +0100
|
||||
@@ -22,6 +22,8 @@
|
||||
AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc silent-rules])
|
||||
AM_MAINTAINER_MODE()
|
||||
|
||||
+AM_PROG_AR()
|
||||
+
|
||||
LT_PREREQ([2.4])
|
||||
LT_INIT()
|
||||
|
||||
|
|
|
@ -1,7 +0,0 @@
|
|||
--- libnetbsd/Makefile.am.orig 2010-01-03 21:46:29.000000000 -0800
|
||||
+++ libnetbsd/Makefile.am 2012-05-03 15:58:12.000000000 -0700
|
||||
@@ -6,3 +6,3 @@
|
||||
|
||||
-CPPFLAGS = \
|
||||
+AM_CPPFLAGS = \
|
||||
-I$(srcdir) \
|
|
@ -12,7 +12,7 @@ a build.
|
|||
+ logutmp.c \
|
||||
+ logwtmp.c
|
||||
|
||||
tnftpd_CPPFLAGS = \
|
||||
AM_CPPFLAGS = \
|
||||
-DHAVE_TNFTPD_H=1 \
|
||||
@@ -45,8 +47,6 @@
|
||||
extern.h \
|
||||
|
|
|
@ -1,4 +1,3 @@
|
|||
|
||||
Rewrite utmpx support.
|
||||
|
||||
--- src/ftpd.c.orig 2009-11-07 04:26:48.000000000 +0100
|
||||
|
@ -13,7 +12,7 @@ Rewrite utmpx support.
|
|||
#ifdef SUPPORT_UTMP
|
||||
ftpd_initwtmp();
|
||||
#endif
|
||||
@@ -1319,23 +1316,18 @@
|
||||
@@ -1320,23 +1317,18 @@
|
||||
(void)gettimeofday(&tv, NULL);
|
||||
#endif
|
||||
#ifdef SUPPORT_UTMPX
|
||||
|
@ -42,7 +41,7 @@ Rewrite utmpx support.
|
|||
#endif
|
||||
#ifdef SUPPORT_UTMP
|
||||
if (doutmp) {
|
||||
@@ -1355,17 +1347,23 @@
|
||||
@@ -1356,17 +1348,23 @@
|
||||
logout_utmp(void)
|
||||
{
|
||||
#ifdef SUPPORT_UTMPX
|
||||
|
|
|
@ -1,4 +1,3 @@
|
|||
|
||||
FreeBSD does not have header file util.h, fortunately it is not needed.
|
||||
Add header file time.h for time(). Rewrite utmpx support.
|
||||
|
||||
|
|
|
@ -1,4 +1,3 @@
|
|||
|
||||
FreeBSD does not have header file util.h, fortunately it is not needed. Add
|
||||
header files sys/socket.h and netdb.h for getaddrinfo() and getnameinfo().
|
||||
If host name is longer than UT_HOSTSIZE (16 characters), log numeric
|
||||
|
|
|
@ -1,4 +1,3 @@
|
|||
|
||||
FreeBSD does not have LOGIN_NAME_MAX, but it has MAXLOGNAME instead,
|
||||
so use it as much as possible. Rewrite utmpx support.
|
||||
|
||||
|
|
Loading…
Reference in a new issue