The Fluxbox Background Tool gives you a nice GUI to make background
changing easier in fluxbox/blackbox. It lets you use pixmaps as well as solid colours. It includes a daemon to change the background automatically.
This commit is contained in:
parent
8d93d52966
commit
0f59d8d1a9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=89940
8 changed files with 112 additions and 0 deletions
|
@ -36,6 +36,7 @@
|
|||
SUBDIR += eterm
|
||||
SUBDIR += eweather
|
||||
SUBDIR += fbsd-icons
|
||||
SUBDIR += fluxbg
|
||||
SUBDIR += fspanel
|
||||
SUBDIR += gdkxft
|
||||
SUBDIR += gdm2
|
||||
|
|
33
x11/fluxbg/Makefile
Normal file
33
x11/fluxbg/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: fluxbg
|
||||
# Date created: 30 September 2003
|
||||
# Whom: Adam Weinberger <adamw@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fluxbg
|
||||
PORTVERSION= 0.6
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Background changer for fluxbox/blackbox
|
||||
|
||||
LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_GNOME= gnomehack gnometarget
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|%%X11BASE%%|${X11BASE}|g" \
|
||||
${WRKSRC}/src/fluxbg_conf.cc
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11/fluxbg/distinfo
Normal file
1
x11/fluxbg/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (fluxbg-0.6.tar.gz) = c94c05da0d86ad30aab44af420356c7b
|
28
x11/fluxbg/files/patch-src::fluxbg_conf.cc
Normal file
28
x11/fluxbg/files/patch-src::fluxbg_conf.cc
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- src/fluxbg_conf.cc.orig Sat Aug 9 12:00:29 2003
|
||||
+++ src/fluxbg_conf.cc Tue Sep 30 20:53:24 2003
|
||||
@@ -10,6 +10,8 @@
|
||||
#include <iostream>
|
||||
#include <fstream>
|
||||
#include <stdlib.h>
|
||||
+#include <errno.h>
|
||||
+#include <string.h>
|
||||
|
||||
|
||||
extern "C"{
|
||||
@@ -158,6 +160,16 @@
|
||||
BailOut();
|
||||
|
||||
if (try_access("/usr/local/bin/fbsetbg")==1)
|
||||
+ BailOut();
|
||||
+
|
||||
+/* FreeBSD installs stuff in a Better Place [tm]
|
||||
+ also, the fluxbox-devel port appends "-devel" to binary names */
|
||||
+
|
||||
+if (try_access("%%X11BASE%%/bin/fbsetbg-devel")==1)
|
||||
+ BailOut();
|
||||
+if (try_access("%%X11BASE%%/bin/fbsetbg")==1)
|
||||
+ BailOut();
|
||||
+if (try_access("%%X11BASE%%/bin/bsetbg")==1)
|
||||
BailOut();
|
||||
|
||||
if (write_empty_conf()!=1)
|
32
x11/fluxbg/files/patch-src::fluxbgd.c
Normal file
32
x11/fluxbg/files/patch-src::fluxbgd.c
Normal file
|
@ -0,0 +1,32 @@
|
|||
--- src/fluxbgd.c.orig Tue Sep 30 20:40:39 2003
|
||||
+++ src/fluxbgd.c Tue Sep 30 20:42:40 2003
|
||||
@@ -91,13 +91,14 @@
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
|
||||
- int c;
|
||||
+ int c, line_max, current_line, last_line;
|
||||
int bOptionA = 0;
|
||||
int bError = 0;
|
||||
char * szInputFile = (char *) 0;
|
||||
char * szInterval = (char *) 0;
|
||||
char * eptr; /* seems not to be used */
|
||||
char * next_set[120]; /* maximum line size */
|
||||
+ char * sys_command;
|
||||
/* TODO: next_set could be fixed to any length !*/
|
||||
|
||||
szCommand = argv[0];
|
||||
@@ -206,10 +207,9 @@
|
||||
PrintError("Could not open file");
|
||||
exit(EXIT_FAILURE);
|
||||
}
|
||||
- int line_max = 0;
|
||||
- int current_line = 0;
|
||||
- int last_line = 0;
|
||||
- char *sys_command;
|
||||
+ line_max = 0;
|
||||
+ current_line = 0;
|
||||
+ last_line = 0;
|
||||
/* next while loop is checking how much lines are in the file */
|
||||
|
||||
while (fgets (next_set, sizeof(next_set), fp) != NULL)
|
6
x11/fluxbg/pkg-descr
Normal file
6
x11/fluxbg/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
The Fluxbox Background Tool gives you a nice GUI to make background
|
||||
changing easier in fluxbox/blackbox. It lets you use pixmaps as well
|
||||
as solid colours. It includes a daemon to change the background
|
||||
automatically.
|
||||
|
||||
WWW: http://fluxbg.sourceforge.net
|
8
x11/fluxbg/pkg-message
Normal file
8
x11/fluxbg/pkg-message
Normal file
|
@ -0,0 +1,8 @@
|
|||
|
||||
|
||||
Before you can use fluxbg, you must first run fluxbg_conf.
|
||||
|
||||
Before you can use fluxbg_conf, you must first install boxtools,
|
||||
fluxbox, or fluxbox-devel.
|
||||
|
||||
|
3
x11/fluxbg/pkg-plist
Normal file
3
x11/fluxbg/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/fluxbg
|
||||
bin/fluxbgd
|
||||
bin/fluxbg_conf
|
Loading…
Reference in a new issue