Update to 0.15. Changes include:
* Editing capabilities. "klayout" in it's basic form still operates as pure viewer. However, a mode is available that enables editing capabilities. See Editor mode quickstart manual for a more detailed description * Some RBA extensions: i.e. conversion from "double" type polygons to "integer" type ones. * A default layer table can be configured in the "Application" tab of the setup dialog. This table will be loaded whenever a layout is opened or created. * A installer for Windows is provided now. * Properties are supported on instances now as well. * Code is compatible with gcc 4.3.0 now. * Enhanced compatibility with SunStudio 11 compiler (in particular in RBA). * Various bug fixes (i.e. in GDS reader and OASIS writer).
This commit is contained in:
parent
fa0f7dbc27
commit
0f60c9ed8f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219026
3 changed files with 29 additions and 16 deletions
|
@ -6,8 +6,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= klayout
|
PORTNAME= klayout
|
||||||
PORTVERSION= 0.14
|
PORTVERSION= 0.15
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= cad
|
CATEGORIES= cad
|
||||||
MASTER_SITES= http://www.klayout.de/
|
MASTER_SITES= http://www.klayout.de/
|
||||||
|
|
||||||
|
@ -17,19 +16,24 @@ COMMENT= A Qt-based GDS2 Viewer
|
||||||
USE_GMAKE= yes
|
USE_GMAKE= yes
|
||||||
USE_QT_VER= 4
|
USE_QT_VER= 4
|
||||||
QT_COMPONENTS= corelib gui network moc sql uic rcc qt3support xml
|
QT_COMPONENTS= corelib gui network moc sql uic rcc qt3support xml
|
||||||
PLIST_FILES= bin/klayout
|
PLIST_FILES= bin/klayout \
|
||||||
|
bin/strm2gds \
|
||||||
|
bin/strm2oas \
|
||||||
|
bin/strmclip \
|
||||||
|
bin/strmcmp
|
||||||
|
|
||||||
PLATFORMKEYWORD= freebsd-32-gcc-release
|
PLATFORMKEYWORD= freebsd-32-gcc-release
|
||||||
|
|
||||||
do-build:
|
do-build:
|
||||||
cd ${WRKSRC} \
|
cd ${WRKSRC} && \
|
||||||
&& ${SH} build.sh -platform ${PLATFORMKEYWORD} \
|
${SH} build.sh -platform ${PLATFORMKEYWORD} \
|
||||||
-qtbin ${QT_PREFIX}/bin \
|
-qtbin ${QT_PREFIX}/bin \
|
||||||
-qtinc ${QT_INCDIR} \
|
-qtinc ${QT_INCDIR} \
|
||||||
-qtlib ${QT_LIBDIR}
|
-qtlib ${QT_LIBDIR}
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/bin.${PLATFORMKEYWORD}/klayout \
|
cd ${WRKSRC}/bin.${PLATFORMKEYWORD} && \
|
||||||
|
${INSTALL_PROGRAM} ${PLIST_FILES:S,^bin/,,} \
|
||||||
${PREFIX}/bin
|
${PREFIX}/bin
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (klayout-0.14.tar.gz) = 0c0fa79aabc67ff42dc613cd2ed567cb
|
MD5 (klayout-0.15.tar.gz) = 07dee91db693b9d4d9577f7bc265fbe2
|
||||||
SHA256 (klayout-0.14.tar.gz) = fecbcdf2d9a33627bfa7ee45c8282c5112c9faad37e2ac4727576dd20f5a3cb3
|
SHA256 (klayout-0.15.tar.gz) = 72f69852e116bdeeee7a93cd896f1bc8dd7feaeefe5a17e5c967af51e4b56b71
|
||||||
SIZE (klayout-0.14.tar.gz) = 766242
|
SIZE (klayout-0.15.tar.gz) = 863520
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- build.sh.orig Fri Nov 9 04:31:36 2007
|
--- build.sh.orig 2008-08-17 06:40:32.000000000 +0900
|
||||||
+++ build.sh Sun Jan 6 18:57:53 2008
|
+++ build.sh 2008-08-23 09:47:35.000000000 +0900
|
||||||
@@ -126,11 +126,11 @@
|
@@ -136,11 +136,11 @@
|
||||||
exit 1
|
exit 1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
@ -14,7 +14,16 @@
|
||||||
echo "*** ERROR: unable to locate Qt UIC in $QTBIN"
|
echo "*** ERROR: unable to locate Qt UIC in $QTBIN"
|
||||||
exit 1
|
exit 1
|
||||||
fi
|
fi
|
||||||
@@ -231,12 +231,12 @@
|
@@ -238,7 +238,7 @@
|
||||||
|
mkdir -p $BIN
|
||||||
|
cp $BUILD/main/$EXEC_NAME $BIN
|
||||||
|
for bin in $OTHER_BIN; do
|
||||||
|
- cp $BUILD/$bin $BIN
|
||||||
|
+ cp $BUILD/main/$bin $BIN
|
||||||
|
done
|
||||||
|
for plugin in $PLUGINS; do
|
||||||
|
cp $BUILD/$plugin/*.so $BIN
|
||||||
|
@@ -249,12 +249,12 @@
|
||||||
echo "Build done."
|
echo "Build done."
|
||||||
echo ""
|
echo ""
|
||||||
echo "Final binary is ready in $BIN/$EXEC_NAME."
|
echo "Final binary is ready in $BIN/$EXEC_NAME."
|
||||||
|
|
Loading…
Reference in a new issue