Support CXX/CXXFLAGS/X11BASE/MAKE properly
Supoort install macros Change location of data files from lib/ to share/ Remove redundant MANCOMPRESSED line Fix 'X manpages' error Add WWW: line into pkg/DESCR PR: 21281 Submitted by: Ports Fury
This commit is contained in:
parent
432cbe600f
commit
0f9f87abd7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32708
5 changed files with 639 additions and 601 deletions
|
@ -17,6 +17,5 @@ BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
|
|||
USE_XLIB= yes
|
||||
ALL_TARGET= freebsd
|
||||
MAN6= lincity.6
|
||||
MANCOMPRESSED= no
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,69 +1,108 @@
|
|||
*** Makefile.orig Thu Feb 25 23:17:38 1999
|
||||
--- Makefile Sat Sep 25 17:37:29 1999
|
||||
***************
|
||||
*** 1,32 ****
|
||||
# Makefile for LinCity (c) I J Peters 1995,1996.
|
||||
|
||||
# This is where the binaries for LinCity will be placed.
|
||||
! LC_BINDIR = /usr/local/bin
|
||||
# for solaris you might choose...
|
||||
# LC_BINDIR = /opt/lcity/bin
|
||||
|
||||
# This is where the library/data files will be placed.
|
||||
! LC_LIBDIR = /usr/local/lib/lincity
|
||||
# for solaris you might choose...
|
||||
# LC_LIBDIR = /opt/lcity/lib
|
||||
|
||||
# export LC_LIBDIR
|
||||
|
||||
# This is where the manpage will be placed.
|
||||
! LC_MANDIR = /usr/local/man/man6
|
||||
LC_MANSUF = 6
|
||||
# for solaris you might choose...
|
||||
# LC_LIBDIR = /opt/lcity/man/man6
|
||||
|
||||
|
||||
# CC = egcs
|
||||
! CC = gcc
|
||||
|
||||
! # EXTRA_OPTS = -fomit-frame-pointer -fstrength-reduce -ffast-math
|
||||
# EXTRA_OPTS = -fstrength-reduce -ffast-math
|
||||
WARN_OPTS = -Wall -Wpointer-arith -Wcast-align -Winline
|
||||
# DEBUG_OPTS =-g
|
||||
! CFLAGS = -O2 $(DEBUG_OPTS) $(EXTRA_OPTS) $(WARN_OPTS) -DLIBDIR=\"$(LC_LIBDIR)\"
|
||||
# -fno-strength-reduce
|
||||
# PROFF = -pg
|
||||
# PROFL = -lc
|
||||
--- 1,32 ----
|
||||
# Makefile for LinCity (c) I J Peters 1995,1996.
|
||||
|
||||
# This is where the binaries for LinCity will be placed.
|
||||
! LC_BINDIR = ${PREFIX}/bin
|
||||
# for solaris you might choose...
|
||||
# LC_BINDIR = /opt/lcity/bin
|
||||
|
||||
# This is where the library/data files will be placed.
|
||||
! LC_LIBDIR = ${PREFIX}/lib/lincity
|
||||
# for solaris you might choose...
|
||||
# LC_LIBDIR = /opt/lcity/lib
|
||||
|
||||
# export LC_LIBDIR
|
||||
|
||||
# This is where the manpage will be placed.
|
||||
! LC_MANDIR = ${PREFIX}/man/man6
|
||||
LC_MANSUF = 6
|
||||
# for solaris you might choose...
|
||||
# LC_LIBDIR = /opt/lcity/man/man6
|
||||
|
||||
|
||||
# CC = egcs
|
||||
! # CC = gcc
|
||||
|
||||
! EXTRA_OPTS = -fomit-frame-pointer -fstrength-reduce -ffast-math
|
||||
# EXTRA_OPTS = -fstrength-reduce -ffast-math
|
||||
WARN_OPTS = -Wall -Wpointer-arith -Wcast-align -Winline
|
||||
# DEBUG_OPTS =-g
|
||||
! CFLAGS += $(EXTRA_OPTS) -DLIBDIR=\"$(LC_LIBDIR)\" -I${X11BASE}/include
|
||||
# -fno-strength-reduce
|
||||
# PROFF = -pg
|
||||
# PROFL = -lc
|
||||
--- Makefile.orig Fri Feb 26 13:17:38 1999
|
||||
+++ Makefile Tue Sep 12 02:50:50 2000
|
||||
@@ -1,39 +1,39 @@
|
||||
# Makefile for LinCity (c) I J Peters 1995,1996.
|
||||
|
||||
# This is where the binaries for LinCity will be placed.
|
||||
-LC_BINDIR = /usr/local/bin
|
||||
+LC_BINDIR = ${PREFIX}/bin
|
||||
# for solaris you might choose...
|
||||
# LC_BINDIR = /opt/lcity/bin
|
||||
|
||||
# This is where the library/data files will be placed.
|
||||
-LC_LIBDIR = /usr/local/lib/lincity
|
||||
+LC_LIBDIR = ${PREFIX}/share/lincity
|
||||
# for solaris you might choose...
|
||||
# LC_LIBDIR = /opt/lcity/lib
|
||||
|
||||
# export LC_LIBDIR
|
||||
|
||||
# This is where the manpage will be placed.
|
||||
-LC_MANDIR = /usr/local/man/man6
|
||||
+LC_MANDIR = ${PREFIX}/man/man6
|
||||
LC_MANSUF = 6
|
||||
# for solaris you might choose...
|
||||
# LC_LIBDIR = /opt/lcity/man/man6
|
||||
|
||||
|
||||
# CC = egcs
|
||||
-CC = gcc
|
||||
+CC = ${CXX}
|
||||
|
||||
# EXTRA_OPTS = -fomit-frame-pointer -fstrength-reduce -ffast-math
|
||||
# EXTRA_OPTS = -fstrength-reduce -ffast-math
|
||||
-WARN_OPTS = -Wall -Wpointer-arith -Wcast-align -Winline
|
||||
+# WARN_OPTS = -Wall -Wpointer-arith -Wcast-align -Winline
|
||||
# DEBUG_OPTS =-g
|
||||
-CFLAGS = -O2 $(DEBUG_OPTS) $(EXTRA_OPTS) $(WARN_OPTS) -DLIBDIR=\"$(LC_LIBDIR)\"
|
||||
+CFLAGS = ${CXXFLAGS} $(DEBUG_OPTS) $(EXTRA_OPTS) $(WARN_OPTS) -DLIBDIR=\"$(LC_LIBDIR)\"
|
||||
# -fno-strength-reduce
|
||||
# PROFF = -pg
|
||||
# PROFL = -lc
|
||||
# PROFD = -DCS_PROFILE
|
||||
|
||||
-LC_XFLAGS = $(CFLAGS) -DLC_X11
|
||||
-LC_XLIBS = -lXExExt -lXext -lX11
|
||||
+LC_XFLAGS = $(CFLAGS) -DLC_X11 -I${X11BASE}/include
|
||||
+LC_XLIBS = -lXExExt -lXext -lX11 -L${X11BASE}/lib
|
||||
|
||||
XOBJS = xmain.o xmouse.o xscreen.o xmps.o xtypeinit.o xengine.o\
|
||||
xtransport.o xmarket.o xhelp.o lcx11.o
|
||||
@@ -42,7 +42,7 @@
|
||||
|
||||
# /usr/X11R6/lib/X11/config/ is where Imake.tmpl lives, change the following
|
||||
# line if yours is somewhere else.
|
||||
-LC_IMAKE_ARGS = -DUseInstalled -I/usr/X11R6/lib/X11/config
|
||||
+LC_IMAKE_ARGS = -DUseInstalled -I${X11BASE}/lib/X11/config
|
||||
|
||||
dummy:
|
||||
@echo
|
||||
@@ -91,7 +91,7 @@
|
||||
# all the objects and libraries.
|
||||
xlincity : $(XOBJS)
|
||||
imake -s XMakefile $(LC_IMAKE_ARGS) LC_LIBDIR=$(LC_LIBDIR)
|
||||
- make -f XMakefile
|
||||
+ ${MAKE} -f XMakefile
|
||||
|
||||
solaris :
|
||||
make -f sunosMakefile LC_LIBDIR=$(LC_LIBDIR)
|
||||
@@ -122,28 +122,19 @@
|
||||
# exists, even with the -p flag, hence the '-'. We should still
|
||||
# catch a failure with the chmod hopefully.
|
||||
-mkdir -p $(LC_BINDIR)
|
||||
- chmod 755 $(LC_BINDIR)
|
||||
- -cp lincity $(LC_BINDIR)
|
||||
- -chmod +s $(LC_BINDIR)/lincity
|
||||
- -cp xlincity $(LC_BINDIR)
|
||||
- -chmod 755 $(LC_BINDIR)/xlincity
|
||||
+ ${BSD_INSTALL_PROGRAM} xlincity $(LC_BINDIR)
|
||||
-mkdir -p $(LC_LIBDIR)
|
||||
- chmod 755 $(LC_LIBDIR)
|
||||
- cp -r icons $(LC_LIBDIR)
|
||||
- chmod 755 $(LC_LIBDIR)/icons
|
||||
- cp -r help $(LC_LIBDIR)
|
||||
- chmod 755 $(LC_LIBDIR)/help
|
||||
- cp -r messages $(LC_LIBDIR)
|
||||
- chmod 755 $(LC_LIBDIR)/messages
|
||||
- cp -r opening $(LC_LIBDIR)
|
||||
- chmod 755 $(LC_LIBDIR)/opening
|
||||
- cp colour.pal $(LC_LIBDIR)
|
||||
- chmod -R o+r $(LC_LIBDIR)
|
||||
+ ${BSD_INSTALL_DATA} colour.pal $(LC_LIBDIR)
|
||||
+ -mkdir -p $(LC_LIBDIR)/icons
|
||||
+ ${BSD_INSTALL_DATA} icons/* $(LC_LIBDIR)/icons
|
||||
+ -mkdir -p $(LC_LIBDIR)/help
|
||||
+ ${BSD_INSTALL_DATA} help/* $(LC_LIBDIR)/help
|
||||
+ -mkdir -p $(LC_LIBDIR)/messages
|
||||
+ ${BSD_INSTALL_DATA} messages/* $(LC_LIBDIR)/messages
|
||||
+ -mkdir -p $(LC_LIBDIR)/opening
|
||||
+ ${BSD_INSTALL_DATA} opening/* $(LC_LIBDIR)/opening
|
||||
-mkdir -p $(LC_MANDIR)
|
||||
- cp lincity.man $(LC_MANDIR)/lincity.$(LC_MANSUF)
|
||||
- chmod o+r $(LC_MANDIR)/lincity.$(LC_MANSUF)
|
||||
- chmod o+rx `dirname $(LC_BINDIR)`
|
||||
- chmod o+rx `dirname $(LC_MANDIR)`
|
||||
+ ${BSD_INSTALL_MAN} lincity.man $(LC_MANDIR)/lincity.$(LC_MANSUF)
|
||||
|
||||
uninstall:
|
||||
-rm $(LC_BINDIR)/lincity
|
||||
|
|
8
games/lincity/files/patch-ad
Normal file
8
games/lincity/files/patch-ad
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- Imakefile.orig Sun Feb 14 07:55:02 1999
|
||||
+++ Imakefile Tue Sep 12 02:35:21 2000
|
||||
@@ -15,4 +15,4 @@
|
||||
OBJS = xmain.o xmouse.o xscreen.o xmps.o xtypeinit.o\
|
||||
xengine.o xtransport.o xmarket.o xhelp.o lcx11.o
|
||||
|
||||
-ComplexProgramTarget(xlincity)
|
||||
+ComplexProgramTargetNoMan(xlincity)
|
|
@ -9,12 +9,4 @@ broke and build rockets to escape from a pollution ridden and resource
|
|||
starved planet, it's up to you. Due to the finite resources available in any
|
||||
one place, this is not a game that you can leave for long periods of time.
|
||||
|
||||
The code is (sort of) BETA; it is still under development. However few
|
||||
problems have been reported and the game is more or less complete. It would
|
||||
be nice if you could send me an e-mail (ijp@floot.demon.co.uk) saying
|
||||
'good', 'bad', etc., or any bug reports or ideas. Also, for those who are
|
||||
really keen, I have set up a mailing list. To subscribe, send mail to
|
||||
|
||||
majordomo@floot.demon.co.uk with
|
||||
|
||||
subscribe lincity in the body of your mail.
|
||||
WWW: http://www.floot.demon.co.uk/lincity.html
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue