- Readd gimp-devel
Approved by: portmgr (marcus, kris)
This commit is contained in:
parent
70cd04b258
commit
0fa56c08b1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=175287
17 changed files with 5025 additions and 0 deletions
|
@ -178,6 +178,7 @@
|
|||
SUBDIR += giftrans
|
||||
SUBDIR += gimageview
|
||||
SUBDIR += gimp
|
||||
SUBDIR += gimp-devel
|
||||
SUBDIR += gimp-greycstoration
|
||||
SUBDIR += gimp-help
|
||||
SUBDIR += gimp-manual-html
|
||||
|
|
172
graphics/gimp-app-devel/Makefile
Normal file
172
graphics/gimp-app-devel/Makefile
Normal file
|
@ -0,0 +1,172 @@
|
|||
# New ports collection makefile for: The GIMP
|
||||
# Date created: Mon Nov 18 21:28:43 CST 1996
|
||||
# Whom: erich@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/graphics/gimp-devel/Makefile,v 1.24 2006/10/13 23:42:43 marcus Exp $
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 2.3.9
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
http://gimp.mirrors.hoobly.com/%SUBDIR%/ \
|
||||
http://ftp.gwdg.de/pub/misc/grafik/gimp/%SUBDIR%/ \
|
||||
ftp://ftp.fh-heilbronn.de/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
http://www.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,} \
|
||||
${MASTER_SITE_LOCAL:S|$|ahze/|:S|$|:gut|}
|
||||
MASTER_SITE_SUBDIR= gimp/v${PORTVERSION:R} \
|
||||
ahze:gut
|
||||
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${EXTRA_DISTFILES}
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A GNU Image Manipulation Program development version
|
||||
|
||||
LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
|
||||
poppler-glib.1:${PORTSDIR}/graphics/poppler-gtk \
|
||||
aa.1:${PORTSDIR}/graphics/aalib \
|
||||
mng.1:${PORTSDIR}/graphics/libmng \
|
||||
png.5:${PORTSDIR}/graphics/png \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff
|
||||
|
||||
CONFLICTS= gimp-1.* gimp-2.2.*
|
||||
|
||||
SHLIBVER?= 0
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2 ltverhack
|
||||
WANT_GNOME= yes
|
||||
USE_GCC= 3.4+
|
||||
USE_LDCONFIG= yes
|
||||
INSTALLS_ICONS= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
PLIST_SUB= SHLIBVER="${SHLIBVER}"
|
||||
CONFIGURE_ARGS= --disable-perl \
|
||||
--with-html-dir=${DOCSDIR} \
|
||||
--disable-gtk-doc \
|
||||
--enable-static \
|
||||
--with-gimpprint
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
GIMP_DISTFILE= ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAN1= gimp-2.3.1 gimp-remote-2.3.1 gimptool-2.0.1
|
||||
MAN5= gimprc-2.3.5
|
||||
|
||||
OPTIONS= DEBUG "debugging" off \
|
||||
PYTHON "Python-Fu support" off \
|
||||
RSVG "SVG format support" on \
|
||||
PRINT "Gutenprint plugin" on \
|
||||
GNOMEPRINT "GNOME printing plugin" on \
|
||||
MP "multiple processor support" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
#.if defined(WITHOUT_EXIF)
|
||||
CONFIGURE_ARGS+= --without-libexif
|
||||
#.else
|
||||
#LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
|
||||
#.endif
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PYTHON)
|
||||
USE_PYTHON= yes
|
||||
# we need to manually include this, because USE_PYTHON is defined
|
||||
# # after including bsd.port.pre.mk
|
||||
.include "${PORTSDIR}/Mk/bsd.python.mk"
|
||||
USE_GNOME+= pygtk2
|
||||
CONFIGURE_ARGS+= --enable-python
|
||||
PLIST_SUB+= PYTHON:=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
PLIST_SUB+= PYTHON:="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_RSVG)
|
||||
CONFIGURE_ARGS+= --without-librsvg
|
||||
PLIST_SUB+= SVG="@comment "
|
||||
.else
|
||||
USE_GNOME+= librsvg2
|
||||
PLIST_SUB+= SVG=""
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
LIB_DEPENDS+= gutenprintui2.1:${PORTSDIR}/print/gutenprint
|
||||
EXTRA_DISTFILES+= gimp2-gutenprint-2${EXTRACT_SUFX}:gut
|
||||
GUT_WRKSRC= ${WRKDIR}/gimp2-gutenprint
|
||||
PKGCONFIG?= ${LOCALBASE}/bin/pkg-config
|
||||
GUTENPRINT_CFLAGS= `${PKGCONFIG} --cflags gutenprintui2`
|
||||
GUTENPRINT_LIBS= `${PKGCONFIG} --libs gutenprintui2`
|
||||
GUT_MAKE_ENV= GUTENPRINT_CFLAGS="${GUTENPRINT_CFLAGS}" \
|
||||
GUTENPRINT_LIBS="${GUTENPRINT_LIBS}"
|
||||
PLIST_SUB+= GPRINT=""
|
||||
.else
|
||||
PLIST_SUB+= GPRINT="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GNOMEPRINT)
|
||||
USE_GNOME+= libgnomeprintui
|
||||
PLIST_SUB+= PRINT=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gnomeprint
|
||||
PLIST_SUB+= PRINT="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MP)
|
||||
CONFIGURE_ARGS+= --enable-mp
|
||||
.endif
|
||||
|
||||
.if ${HAVE_GNOME:Mgnomepanel}!=""
|
||||
USE_GNOME+= gnomepanel desktopfileutils gnomehier
|
||||
CONFIGURE_ARGS+= --with-desktop-dir=${LOCALBASE}/share/gnome
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
PKGNAMESUFFIX:= -gnome
|
||||
PLIST_SUB+= GTK="gnome/" GNOMEPANEL:=""
|
||||
GNOME_ENABLED= yes
|
||||
.else
|
||||
PLIST_SUB+= GTK="" GNOMEPANEL:="@comment "
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
CONFIGURE_ARGS+= --without-desktop-dir
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
${RM} -rf ${WRKSRC}/plug-ins/print
|
||||
${MKDIR} ${WRKSRC}/plug-ins/print
|
||||
${CP} -f ${GUT_WRKSRC}/* ${WRKSRC}/plug-ins/print
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|"libpng"|"libpng12"|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|@mandir@|${PREFIX}/man|' \
|
||||
${WRKSRC}/docs/Makefile.in
|
||||
|
||||
post-build:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
|
||||
.endif
|
||||
.if defined(GNOME_ENABLED)
|
||||
@-update-desktop-database
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
6
graphics/gimp-app-devel/distinfo
Normal file
6
graphics/gimp-app-devel/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
MD5 (gimp-2.3.9.tar.bz2) = 4299e81e1824e08a90b50dc8beb46151
|
||||
SHA256 (gimp-2.3.9.tar.bz2) = 64c334f99cc4e5204a1925299b7a1da3d027f0b1c6900e6309f5b8da40aa9f10
|
||||
SIZE (gimp-2.3.9.tar.bz2) = 15183977
|
||||
MD5 (gimp2-gutenprint-2.tar.bz2) = d24f0e7bd1f2e62984395293b5f1a43d
|
||||
SHA256 (gimp2-gutenprint-2.tar.bz2) = 3226cf58210fd796e5748817256d29de425e21b093fb84997b787df050344164
|
||||
SIZE (gimp2-gutenprint-2.tar.bz2) = 15155
|
11
graphics/gimp-app-devel/files/patch-app_main.c
Normal file
11
graphics/gimp-app-devel/files/patch-app_main.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- app/main.c.orig Fri Jun 9 12:02:54 2006
|
||||
+++ app/main.c Fri Jun 9 12:03:28 2006
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <stdio.h>
|
23
graphics/gimp-app-devel/files/patch-configure
Normal file
23
graphics/gimp-app-devel/files/patch-configure
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- configure.orig Sun Mar 6 15:30:12 2005
|
||||
+++ configure Sun Mar 6 15:33:57 2005
|
||||
@@ -25925,6 +25925,7 @@
|
||||
if test "x$enable_gtktest" = "xyes" ; then
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
ac_save_LIBS="$LIBS"
|
||||
+ GTK_LIBS="$GIMP_THREAD_LIBS $GTK_LIBS"
|
||||
CFLAGS="$CFLAGS $GTK_CFLAGS"
|
||||
LIBS="$GTK_LIBS $LIBS"
|
||||
rm -f conf.gtktest
|
||||
@@ -33865,9 +33866,9 @@
|
||||
fi
|
||||
fi;
|
||||
|
||||
-gimpdatadir="$datadir/$PACKAGE/2.0"
|
||||
-gimpplugindir="$libdir/$PACKAGE/2.0"
|
||||
-gimpsysconfdir="$sysconfdir/$PACKAGE/2.0"
|
||||
+gimpdatadir="$datadir/$PACKAGE"
|
||||
+gimpplugindir="$libexecdir/$PACKAGE/2.2"
|
||||
+gimpsysconfdir="$sysconfdir/$PACKAGE/2.2"
|
||||
|
||||
localedir='${prefix}/${DATADIRNAME}/locale'
|
||||
|
30
graphics/gimp-app-devel/files/patch-gimptool-2.0.in
Normal file
30
graphics/gimp-app-devel/files/patch-gimptool-2.0.in
Normal file
|
@ -0,0 +1,30 @@
|
|||
|
||||
$FreeBSD$
|
||||
$MCom: ports/graphics/gimp-devel/files/patch-gimptool-2.0.in,v 1.3 2005/06/28 05:40:04 adamw Exp $
|
||||
|
||||
--- gimptool-2.0.in.orig Tue Jan 15 12:21:05 2002
|
||||
+++ gimptool-2.0.in Fri May 17 20:46:18 2002
|
||||
@@ -215,19 +215,19 @@
|
||||
| --uninstall-script | --uninstall-admin-script )
|
||||
case $1 in
|
||||
--*install-bin)
|
||||
- install_cmd="@INSTALL_PROGRAM@"
|
||||
+ install_cmd="@INSTALL_SCRIPT@"
|
||||
install_dir="$HOME/@gimpdir@/plug-ins"
|
||||
;;
|
||||
--install-bin-strip)
|
||||
- install_cmd="@INSTALL_PROGRAM@ -s"
|
||||
+ install_cmd="@INSTALL_SCRIPT@ -s"
|
||||
install_dir="$HOME/@gimpdir@/plug-ins"
|
||||
;;
|
||||
--*install-admin-bin)
|
||||
- install_cmd="@INSTALL_PROGRAM@"
|
||||
+ install_cmd="@INSTALL_SCRIPT@"
|
||||
install_dir="$gimpplugindir/plug-ins"
|
||||
;;
|
||||
--install-admin-bin-strip)
|
||||
- install_cmd="@INSTALL_PROGRAM@ -s"
|
||||
+ install_cmd="@INSTALL_SCRIPT@ -s"
|
||||
install_dir="$gimpplugindir/plug-ins"
|
||||
;;
|
||||
--*install-script)
|
29
graphics/gimp-app-devel/files/patch-libgimp_gimp.c
Normal file
29
graphics/gimp-app-devel/files/patch-libgimp_gimp.c
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- libgimp/gimp.c.orig Fri Jun 2 08:04:39 2006
|
||||
+++ libgimp/gimp.c Fri Jun 9 11:24:56 2006
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE /* all the sigaction stuff is POSIX */
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <errno.h>
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
+#include <floatingpoint.h>
|
||||
|
||||
#ifdef HAVE_SYS_TIME_H
|
||||
#include <sys/time.h>
|
||||
@@ -292,6 +293,9 @@
|
||||
gimp_env_init (TRUE);
|
||||
|
||||
progname = argv[0];
|
||||
+
|
||||
+ /* Ignore floating point exceptions */
|
||||
+ fpsetmask(0);
|
||||
|
||||
basename = g_path_get_basename (progname);
|
||||
|
19
graphics/gimp-app-devel/pkg-descr
Normal file
19
graphics/gimp-app-devel/pkg-descr
Normal file
|
@ -0,0 +1,19 @@
|
|||
The GIMP is designed to provide an intuitive graphical interface to a
|
||||
variety of image editing operations. Here is a list of the GIMP's
|
||||
major features:
|
||||
|
||||
Image editing
|
||||
-------------
|
||||
|
||||
* Selection tools including rectangle, ellipse, free, fuzzy, bezier
|
||||
and intelligent.
|
||||
* Transformation tools including rotate, scale, shear and flip.
|
||||
* Painting tools including bucket, brush, airbrush, clone, convolve,
|
||||
blend and text.
|
||||
* Effects filters (such as blur, edge detect).
|
||||
* Channel & color operations (such as add, composite, decompose).
|
||||
* Plug-ins which allow for the easy addition of new file formats and
|
||||
new effect filters.
|
||||
* Multiple undo/redo.
|
||||
|
||||
WWW: http://www.gimp.org/
|
2222
graphics/gimp-app-devel/pkg-plist
Normal file
2222
graphics/gimp-app-devel/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
172
graphics/gimp-devel/Makefile
Normal file
172
graphics/gimp-devel/Makefile
Normal file
|
@ -0,0 +1,172 @@
|
|||
# New ports collection makefile for: The GIMP
|
||||
# Date created: Mon Nov 18 21:28:43 CST 1996
|
||||
# Whom: erich@FreeBSD.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/graphics/gimp-devel/Makefile,v 1.24 2006/10/13 23:42:43 marcus Exp $
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 2.3.9
|
||||
PORTREVISION= 2
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
http://gimp.mirrors.hoobly.com/%SUBDIR%/ \
|
||||
http://ftp.gwdg.de/pub/misc/grafik/gimp/%SUBDIR%/ \
|
||||
ftp://ftp.fh-heilbronn.de/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/%SUBDIR%/ \
|
||||
http://www.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
|
||||
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,} \
|
||||
${MASTER_SITE_LOCAL:S|$|ahze/|:S|$|:gut|}
|
||||
MASTER_SITE_SUBDIR= gimp/v${PORTVERSION:R} \
|
||||
ahze:gut
|
||||
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${EXTRA_DISTFILES}
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
COMMENT= A GNU Image Manipulation Program development version
|
||||
|
||||
LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
|
||||
poppler-glib.1:${PORTSDIR}/graphics/poppler-gtk \
|
||||
aa.1:${PORTSDIR}/graphics/aalib \
|
||||
mng.1:${PORTSDIR}/graphics/libmng \
|
||||
png.5:${PORTSDIR}/graphics/png \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff
|
||||
|
||||
CONFLICTS= gimp-1.* gimp-2.2.*
|
||||
|
||||
SHLIBVER?= 0
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GETTEXT= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2 ltverhack
|
||||
WANT_GNOME= yes
|
||||
USE_GCC= 3.4+
|
||||
USE_LDCONFIG= yes
|
||||
INSTALLS_ICONS= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
PLIST_SUB= SHLIBVER="${SHLIBVER}"
|
||||
CONFIGURE_ARGS= --disable-perl \
|
||||
--with-html-dir=${DOCSDIR} \
|
||||
--disable-gtk-doc \
|
||||
--enable-static \
|
||||
--with-gimpprint
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
GIMP_DISTFILE= ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAN1= gimp-2.3.1 gimp-remote-2.3.1 gimptool-2.0.1
|
||||
MAN5= gimprc-2.3.5
|
||||
|
||||
OPTIONS= DEBUG "debugging" off \
|
||||
PYTHON "Python-Fu support" off \
|
||||
RSVG "SVG format support" on \
|
||||
PRINT "Gutenprint plugin" on \
|
||||
GNOMEPRINT "GNOME printing plugin" on \
|
||||
MP "multiple processor support" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
#.if defined(WITHOUT_EXIF)
|
||||
CONFIGURE_ARGS+= --without-libexif
|
||||
#.else
|
||||
#LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
|
||||
#.endif
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PYTHON)
|
||||
USE_PYTHON= yes
|
||||
# we need to manually include this, because USE_PYTHON is defined
|
||||
# # after including bsd.port.pre.mk
|
||||
.include "${PORTSDIR}/Mk/bsd.python.mk"
|
||||
USE_GNOME+= pygtk2
|
||||
CONFIGURE_ARGS+= --enable-python
|
||||
PLIST_SUB+= PYTHON:=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
PLIST_SUB+= PYTHON:="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_RSVG)
|
||||
CONFIGURE_ARGS+= --without-librsvg
|
||||
PLIST_SUB+= SVG="@comment "
|
||||
.else
|
||||
USE_GNOME+= librsvg2
|
||||
PLIST_SUB+= SVG=""
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
LIB_DEPENDS+= gutenprintui2.1:${PORTSDIR}/print/gutenprint
|
||||
EXTRA_DISTFILES+= gimp2-gutenprint-2${EXTRACT_SUFX}:gut
|
||||
GUT_WRKSRC= ${WRKDIR}/gimp2-gutenprint
|
||||
PKGCONFIG?= ${LOCALBASE}/bin/pkg-config
|
||||
GUTENPRINT_CFLAGS= `${PKGCONFIG} --cflags gutenprintui2`
|
||||
GUTENPRINT_LIBS= `${PKGCONFIG} --libs gutenprintui2`
|
||||
GUT_MAKE_ENV= GUTENPRINT_CFLAGS="${GUTENPRINT_CFLAGS}" \
|
||||
GUTENPRINT_LIBS="${GUTENPRINT_LIBS}"
|
||||
PLIST_SUB+= GPRINT=""
|
||||
.else
|
||||
PLIST_SUB+= GPRINT="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_GNOMEPRINT)
|
||||
USE_GNOME+= libgnomeprintui
|
||||
PLIST_SUB+= PRINT=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gnomeprint
|
||||
PLIST_SUB+= PRINT="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_MP)
|
||||
CONFIGURE_ARGS+= --enable-mp
|
||||
.endif
|
||||
|
||||
.if ${HAVE_GNOME:Mgnomepanel}!=""
|
||||
USE_GNOME+= gnomepanel desktopfileutils gnomehier
|
||||
CONFIGURE_ARGS+= --with-desktop-dir=${LOCALBASE}/share/gnome
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
PKGNAMESUFFIX:= -gnome
|
||||
PLIST_SUB+= GTK="gnome/" GNOMEPANEL:=""
|
||||
GNOME_ENABLED= yes
|
||||
.else
|
||||
PLIST_SUB+= GTK="" GNOMEPANEL:="@comment "
|
||||
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
|
||||
CONFIGURE_ARGS+= --without-desktop-dir
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
${RM} -rf ${WRKSRC}/plug-ins/print
|
||||
${MKDIR} ${WRKSRC}/plug-ins/print
|
||||
${CP} -f ${GUT_WRKSRC}/* ${WRKSRC}/plug-ins/print
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|"libpng"|"libpng12"|' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|@mandir@|${PREFIX}/man|' \
|
||||
${WRKSRC}/docs/Makefile.in
|
||||
|
||||
post-build:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(WITHOUT_PRINT)
|
||||
@(cd ${WRKSRC}/plug-ins/print; ${SETENV} ${GUT_MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
|
||||
.endif
|
||||
.if defined(GNOME_ENABLED)
|
||||
@-update-desktop-database
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
6
graphics/gimp-devel/distinfo
Normal file
6
graphics/gimp-devel/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
MD5 (gimp-2.3.9.tar.bz2) = 4299e81e1824e08a90b50dc8beb46151
|
||||
SHA256 (gimp-2.3.9.tar.bz2) = 64c334f99cc4e5204a1925299b7a1da3d027f0b1c6900e6309f5b8da40aa9f10
|
||||
SIZE (gimp-2.3.9.tar.bz2) = 15183977
|
||||
MD5 (gimp2-gutenprint-2.tar.bz2) = d24f0e7bd1f2e62984395293b5f1a43d
|
||||
SHA256 (gimp2-gutenprint-2.tar.bz2) = 3226cf58210fd796e5748817256d29de425e21b093fb84997b787df050344164
|
||||
SIZE (gimp2-gutenprint-2.tar.bz2) = 15155
|
11
graphics/gimp-devel/files/patch-app_main.c
Normal file
11
graphics/gimp-devel/files/patch-app_main.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- app/main.c.orig Fri Jun 9 12:02:54 2006
|
||||
+++ app/main.c Fri Jun 9 12:03:28 2006
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <stdio.h>
|
23
graphics/gimp-devel/files/patch-configure
Normal file
23
graphics/gimp-devel/files/patch-configure
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- configure.orig Sun Mar 6 15:30:12 2005
|
||||
+++ configure Sun Mar 6 15:33:57 2005
|
||||
@@ -25925,6 +25925,7 @@
|
||||
if test "x$enable_gtktest" = "xyes" ; then
|
||||
ac_save_CFLAGS="$CFLAGS"
|
||||
ac_save_LIBS="$LIBS"
|
||||
+ GTK_LIBS="$GIMP_THREAD_LIBS $GTK_LIBS"
|
||||
CFLAGS="$CFLAGS $GTK_CFLAGS"
|
||||
LIBS="$GTK_LIBS $LIBS"
|
||||
rm -f conf.gtktest
|
||||
@@ -33865,9 +33866,9 @@
|
||||
fi
|
||||
fi;
|
||||
|
||||
-gimpdatadir="$datadir/$PACKAGE/2.0"
|
||||
-gimpplugindir="$libdir/$PACKAGE/2.0"
|
||||
-gimpsysconfdir="$sysconfdir/$PACKAGE/2.0"
|
||||
+gimpdatadir="$datadir/$PACKAGE"
|
||||
+gimpplugindir="$libexecdir/$PACKAGE/2.2"
|
||||
+gimpsysconfdir="$sysconfdir/$PACKAGE/2.2"
|
||||
|
||||
localedir='${prefix}/${DATADIRNAME}/locale'
|
||||
|
30
graphics/gimp-devel/files/patch-gimptool-2.0.in
Normal file
30
graphics/gimp-devel/files/patch-gimptool-2.0.in
Normal file
|
@ -0,0 +1,30 @@
|
|||
|
||||
$FreeBSD$
|
||||
$MCom: ports/graphics/gimp-devel/files/patch-gimptool-2.0.in,v 1.3 2005/06/28 05:40:04 adamw Exp $
|
||||
|
||||
--- gimptool-2.0.in.orig Tue Jan 15 12:21:05 2002
|
||||
+++ gimptool-2.0.in Fri May 17 20:46:18 2002
|
||||
@@ -215,19 +215,19 @@
|
||||
| --uninstall-script | --uninstall-admin-script )
|
||||
case $1 in
|
||||
--*install-bin)
|
||||
- install_cmd="@INSTALL_PROGRAM@"
|
||||
+ install_cmd="@INSTALL_SCRIPT@"
|
||||
install_dir="$HOME/@gimpdir@/plug-ins"
|
||||
;;
|
||||
--install-bin-strip)
|
||||
- install_cmd="@INSTALL_PROGRAM@ -s"
|
||||
+ install_cmd="@INSTALL_SCRIPT@ -s"
|
||||
install_dir="$HOME/@gimpdir@/plug-ins"
|
||||
;;
|
||||
--*install-admin-bin)
|
||||
- install_cmd="@INSTALL_PROGRAM@"
|
||||
+ install_cmd="@INSTALL_SCRIPT@"
|
||||
install_dir="$gimpplugindir/plug-ins"
|
||||
;;
|
||||
--install-admin-bin-strip)
|
||||
- install_cmd="@INSTALL_PROGRAM@ -s"
|
||||
+ install_cmd="@INSTALL_SCRIPT@ -s"
|
||||
install_dir="$gimpplugindir/plug-ins"
|
||||
;;
|
||||
--*install-script)
|
29
graphics/gimp-devel/files/patch-libgimp_gimp.c
Normal file
29
graphics/gimp-devel/files/patch-libgimp_gimp.c
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- libgimp/gimp.c.orig Fri Jun 2 08:04:39 2006
|
||||
+++ libgimp/gimp.c Fri Jun 9 11:24:56 2006
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#define _POSIX_SOURCE /* all the sigaction stuff is POSIX */
|
||||
+#define __XSI_VISIBLE /* all the sigaction stuff is POSIX */
|
||||
#define _SVID_SOURCE /* except for SA_RESTART, it seems */
|
||||
|
||||
#include <errno.h>
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/types.h>
|
||||
+#include <floatingpoint.h>
|
||||
|
||||
#ifdef HAVE_SYS_TIME_H
|
||||
#include <sys/time.h>
|
||||
@@ -292,6 +293,9 @@
|
||||
gimp_env_init (TRUE);
|
||||
|
||||
progname = argv[0];
|
||||
+
|
||||
+ /* Ignore floating point exceptions */
|
||||
+ fpsetmask(0);
|
||||
|
||||
basename = g_path_get_basename (progname);
|
||||
|
19
graphics/gimp-devel/pkg-descr
Normal file
19
graphics/gimp-devel/pkg-descr
Normal file
|
@ -0,0 +1,19 @@
|
|||
The GIMP is designed to provide an intuitive graphical interface to a
|
||||
variety of image editing operations. Here is a list of the GIMP's
|
||||
major features:
|
||||
|
||||
Image editing
|
||||
-------------
|
||||
|
||||
* Selection tools including rectangle, ellipse, free, fuzzy, bezier
|
||||
and intelligent.
|
||||
* Transformation tools including rotate, scale, shear and flip.
|
||||
* Painting tools including bucket, brush, airbrush, clone, convolve,
|
||||
blend and text.
|
||||
* Effects filters (such as blur, edge detect).
|
||||
* Channel & color operations (such as add, composite, decompose).
|
||||
* Plug-ins which allow for the easy addition of new file formats and
|
||||
new effect filters.
|
||||
* Multiple undo/redo.
|
||||
|
||||
WWW: http://www.gimp.org/
|
2222
graphics/gimp-devel/pkg-plist
Normal file
2222
graphics/gimp-devel/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue