Remove databases/redis-devel after merge to databases/redis.

This commit is contained in:
Sergey A. Osokin 2010-09-20 18:19:42 +00:00
parent be26b24c92
commit 0fcdb3915b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=261504
8 changed files with 0 additions and 256 deletions

View file

@ -1,69 +0,0 @@
# New ports collection makefile for: redis
# Date created: 03 Jul 2009
# Whom: Sergey Skvortsov <skv@protey.ru>
#
# $FreeBSD$
#
PORTNAME= redis
DISTVERSION= 2.0.1
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE
PKGNAMESUFFIX= -devel
MAINTAINER= osa@FreeBSD.org
COMMENT= A persistent key-value database with built-in net interface
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
CFLAGS+= -I${LOCALBASE}/include
CONFLICTS?= redis-1.*
USE_GMAKE= yes
USE_RC_SUBR= redis.sh
BIN_FILES= redis-benchmark redis-check-aof redis-check-dump \
redis-cli redis-server
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-install
PKGMESSAGE= ${WRKDIR}/pkg-message
REDIS_USER?= redis
REDIS_UID?= 535
REDIS_GROUP?= redis
REDIS_GID?= 535
REDIS_DBDIR?= /var/db/redis
REDIS_RUNDIR?= /var/run/redis
REDIS_LOGDIR?= /var/log/redis
SUB_FILES= pkg-message pkg-install
SUB_LIST+= PORTNAME="${PORTNAME}" \
REDIS_USER="${REDIS_USER}" \
REDIS_UID="${REDIS_UID}" \
REDIS_GROUP="${REDIS_GROUP}" \
REDIS_GID="${REDIS_GID}" \
REDIS_LOGDIR="${REDIS_LOGDIR}" \
REDIS_DBDIR="${REDIS_DBDIR}" \
REDIS_RUNDIR="${REDIS_RUNDIR}"
PATTERN= '16d;119d;15s|$$$$(ARCH) ||'
.if !defined(WITH_DEBUG)
PATTERN:= ${PATTERN:S/'$/;5s|^|\#|'/}
.endif
post-patch:
${REINPLACE_CMD} ${PATTERN} ${WRKSRC}/Makefile
post-build:
${SED} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${WRKSRC}/redis.conf > ${WRKDIR}/redis.conf
do-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
${INSTALL_PROGRAM} ${BIN_FILES:C!^!${WRKSRC}/!} ${PREFIX}/bin/
${INSTALL_DATA} ${WRKDIR}/redis.conf ${PREFIX}/etc/redis.conf.sample
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (redis-2.0.1.tar.gz) = 7c0fd3521bbee3ba777b195dedeac5c4
SHA256 (redis-2.0.1.tar.gz) = 4a20e667fe4267e1eb743d9b929a3662f7d5e211ef036c8dd4a7280f51a3b169
SIZE (redis-2.0.1.tar.gz) = 347301

View file

@ -1,34 +0,0 @@
--- redis.conf.orig 2010-07-02 16:00:49.000000000 +0400
+++ redis.conf 2010-07-02 16:01:46.000000000 +0400
@@ -14,11 +14,11 @@
# By default Redis does not run as a daemon. Use 'yes' if you need it.
# Note that Redis will write a pid file in /var/run/redis.pid when daemonized.
-daemonize no
+daemonize yes
# When running daemonized, Redis writes a pid file in /var/run/redis.pid by
# default. You can specify a custom pid file location here.
-pidfile /var/run/redis.pid
+pidfile %%REDIS_RUNDIR%%/redis.pid
# Accept connections on the specified port, default is 6379
port 6379
@@ -42,7 +42,7 @@
# Specify the log file name. Also 'stdout' can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
-logfile stdout
+logfile %%REDIS_LOGDIR%%/redis.log
# Set the number of databases. The default database is DB 0, you can select
# a different one on a per-connection basis using SELECT <dbid> where
@@ -86,7 +86,7 @@
# Also the Append Only File will be created inside this directory.
#
# Note that you must specify a directory here, not a file name.
-dir ./
+dir %%REDIS_DBDIR%%/
################################# REPLICATION #################################

View file

@ -1,85 +0,0 @@
#!/bin/sh
# $FreeBSD$
PATH=/bin:/usr/bin:/usr/sbin
USER="%%REDIS_USER%%"
USER_ID="%%REDIS_UID%%"
GROUP="%%REDIS_GROUP%%"
GROUP_ID="%%REDIS_GID%%"
RUNTIME_DIRS="%%REDIS_LOGDIR%% %%REDIS_DBDIR%% %%REDIS_RUNDIR%%"
case $2 in
PRE-INSTALL)
if [ `id -u` -ne 0 ]; then
echo; echo "You must be root to run this step!"; echo; echo
exit 1
fi
RES=`pw groupshow -n ${GROUP} 2>/dev/null`
if [ $? -eq 0 ]; then
echo "You already have a group \"${GROUP}\", so we will use it."
else
RES=`pw groupshow -g ${GROUP_ID} 2>/dev/null`
if [ $? -ne 0 ]; then
_GID="-g ${GROUP_ID}"
else
_GID=''
fi
if pw groupadd -n ${GROUP} ${_GID}; then
echo "Added group \"${GROUP}\"."
else
echo "Adding group \"${GROUP}\" failed..."
exit 1
fi
fi
RES=`id -u ${USER} 2>/dev/null`
if [ $? -ne 0 ]; then
RES=`id -un ${USER_ID} 2>/dev/null`
if [ $? -ne 0 ]; then
_UID="-u ${USER_ID}"
else
_UID=''
fi
if pw useradd -n ${USER} ${_UID} -g ${GROUP} \
-w no -s /usr/sbin/nologin; then
echo "Added user \"${USER}\"."
else
echo "Adding user \"${USER}\" failed..."
exit 1
fi
fi
;;
POST-INSTALL)
for DIR in ${RUNTIME_DIRS}; do
mkdir -p ${DIR}
chown -R ${USER}:${GROUP} ${DIR}
chmod -R 755 ${DIR}
done
;;
DEINSTALL)
if [ -z ${UPGRADE_PORT} ] ; then
echo
echo "If you do not intend to reinstall \"%%PORTNAME%%\" you should manually"
echo "remove user '${USER}' (uid='${USER_ID}') and group '${GROUP}' (gid='${USER_ID}')."
echo
echo "Also you may want to remove the no longer required directoris:"
echo ${RUNTIME_DIRS}
echo
fi
esac

View file

@ -1,8 +0,0 @@
===> CONFIGURATION NOTE:
To setup "%%PORTNAME%%" you need to edit the configuration file:
%%PREFIX%%/etc/%%PORTNAME%%.conf
To run redis from startup, add %%PORTNAME%%_enable="YES"
in your /etc/rc.conf.

View file

@ -1,35 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: redis
# REQUIRE: LOGIN
# BEFORE: securelevel
# KEYWORD: shutdown
# Add the following line to /etc/rc.conf to enable `redis':
#
#redis_enable="YES"
#
. /etc/rc.subr
name="redis"
rcvar=`set_rcvar`
extra_commands="reload"
command="%%PREFIX%%/bin/redis-server"
config_file="%%PREFIX%%/etc/$name.conf"
command_args="${config_file}"
pidfile="%%REDIS_RUNDIR%%/$name.pid"
required_files="${config_file}"
# read configuration and set defaults
load_rc_config "$name"
: ${redis_enable="NO"}
: ${redis_user="%%REDIS_USER%%"}
: ${redis_flags=""}
run_rc_command "$1"

View file

@ -1,14 +0,0 @@
Redis is a key-value database. It is similar to memcached but the
dataset is not volatile, and values can be strings, exactly like in
memcached, but also lists and sets with atomic operations to push/pop
elements.
In order to be very fast but at the same time persistent the whole
dataset is taken in memory and from time to time and/or when a number of
changes to the dataset are performed it is written asynchronously on
disk. You may lost the last few queries that is acceptable in many
applications but it is as fast as an in memory DB (Redis supports
non-blocking master-slave replication in order to solve this problem by
redundancy).
WWW: http://code.google.com/p/redis/

View file

@ -1,8 +0,0 @@
bin/redis-benchmark
bin/redis-check-aof
bin/redis-check-dump
bin/redis-cli
bin/redis-server
@unexec (cmp -s %D/etc/redis.conf %D/etc/redis.conf.sample && rm -f %D/etc/redis.conf) || true
etc/redis.conf.sample
@exec [ -f %B/redis.conf ] || cp %B/%f %B/redis.conf