Add prokyon3, a multithreaded MP3 manager and tag editor for Linux.
It was written in C++ using the Qt3 widget set and the MySQL database. Files can be played using XMMS. PR: ports/52132 Submitted by: Kay Lehmann <kay_lehmann@web.de> Approved by: adamw (mentor)
This commit is contained in:
parent
aac8b657f7
commit
1068be7e1a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94963
7 changed files with 109 additions and 0 deletions
|
@ -238,6 +238,7 @@
|
|||
SUBDIR += play
|
||||
SUBDIR += playmidi
|
||||
SUBDIR += portaudio
|
||||
SUBDIR += prokyon3
|
||||
SUBDIR += py-ao
|
||||
SUBDIR += py-cddb
|
||||
SUBDIR += py-eyed3
|
||||
|
|
35
audio/prokyon3/Makefile
Normal file
35
audio/prokyon3/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: prokyon3
|
||||
# Date created: 11 November 2002
|
||||
# Whom: Kay Lehmann
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= prokyon3
|
||||
PORTVERSION= 0.9.1.r1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-r/}
|
||||
|
||||
MAINTAINER= kay_lehmann@web.de
|
||||
COMMENT= Prokyon3 is a multithreaded MP3 manager and tag editor
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin
|
||||
LIB_DEPENDS= id3-3.8:${PORTSDIR}/audio/id3lib \
|
||||
vorbis.2:${PORTSDIR}/audio/libvorbis
|
||||
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
USE_QT_VER= 3
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_REINPLACE= yes
|
||||
CONFIGURE_ARGS+= --with-qtdir=${X11BASE} --with-id3-libs=${LOCALBASE}\
|
||||
--with-ogg-libs=${LOCALBASE} --with-vorbis-libs=${LOCALBASE}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-g -O2|${CFLAGS}|; s|-lqt-mt|-lqt-mt ${PTHREAD_LIBS}|' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/prokyon3/distinfo
Normal file
1
audio/prokyon3/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (prokyon3-0.9.1-r1.tar.gz) = 767f849e9ba4c5c4ec114f64ecf1824b
|
18
audio/prokyon3/files/patch-src-getopt.h
Normal file
18
audio/prokyon3/files/patch-src-getopt.h
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- src/getopt.h.orig Sun Dec 8 19:29:14 2002
|
||||
+++ src/getopt.h Mon Nov 24 21:07:44 2003
|
||||
@@ -15,9 +15,6 @@
|
||||
along with this program; if not, write to the Free Software
|
||||
Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
|
||||
|
||||
-#ifndef _GETOPT_H
|
||||
-#define _GETOPT_H 1
|
||||
-
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
#endif
|
||||
@@ -125,5 +122,3 @@
|
||||
#ifdef __cplusplus
|
||||
}
|
||||
#endif
|
||||
-
|
||||
-#endif /* _GETOPT_H */
|
11
audio/prokyon3/files/patch-src-tagger_mp3.cpp
Normal file
11
audio/prokyon3/files/patch-src-tagger_mp3.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/tagger_mp3.cpp.orig Mon Feb 17 00:01:44 2003
|
||||
+++ src/tagger_mp3.cpp Mon Nov 24 21:00:58 2003
|
||||
@@ -448,7 +448,7 @@
|
||||
if(mp3->id3.comment[28] == '\0') {
|
||||
mp3->id3.track[0] = mp3->id3.comment[29];
|
||||
}
|
||||
- mp3->file.readBlock(&(char)mp3->id3.genre[0], 1);
|
||||
+ mp3->file.readBlock((char*)&mp3->id3.genre[0], 1);
|
||||
unpad(mp3->id3.title);
|
||||
unpad(mp3->id3.artist);
|
||||
unpad(mp3->id3.album);
|
10
audio/prokyon3/pkg-descr
Normal file
10
audio/prokyon3/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
prokyon3 is a multithreaded MP3 manager and tag editor for Linux.
|
||||
It was written in C++ using the Qt3 widget set and the MySQL database.
|
||||
prokyon3 can access MP3 files on harddisk, CDROM, SMB and NFS. Files
|
||||
can be played using XMMS, and can even be played when the files are on
|
||||
CD as prokyon3 identifies CDs by content. The files view is customizable
|
||||
and favorite artists are supported. prokyon3 also offers an editor for
|
||||
ID3 tags and has been designed to support tagging for multiple files en
|
||||
masse.
|
||||
|
||||
WWW: http://prokyon3.sourceforge.net/
|
33
audio/prokyon3/pkg-plist
Normal file
33
audio/prokyon3/pkg-plist
Normal file
|
@ -0,0 +1,33 @@
|
|||
bin/prokyon3
|
||||
share/prokyon3/images/action_append.png
|
||||
share/prokyon3/images/action_connect.png
|
||||
share/prokyon3/images/action_createdb.png
|
||||
share/prokyon3/images/action_discard.png
|
||||
share/prokyon3/images/action_disconnect.png
|
||||
share/prokyon3/images/action_quit.png
|
||||
share/prokyon3/images/action_readtags.png
|
||||
share/prokyon3/images/action_remove.png
|
||||
share/prokyon3/images/action_settings.png
|
||||
share/prokyon3/images/action_switchbottom.png
|
||||
share/prokyon3/images/action_switchleft.png
|
||||
share/prokyon3/images/action_switchright.png
|
||||
share/prokyon3/images/action_synchronize.png
|
||||
share/prokyon3/images/action_updateonly.png
|
||||
share/prokyon3/images/action_writetags.png
|
||||
share/prokyon3/images/action_xmms.png
|
||||
share/prokyon3/images/help.png
|
||||
share/prokyon3/images/lvi_album.png
|
||||
share/prokyon3/images/lvi_artist.png
|
||||
share/prokyon3/images/lvi_artist_favourite.png
|
||||
share/prokyon3/images/lvi_cdrom.png
|
||||
share/prokyon3/images/lvi_changed.png
|
||||
share/prokyon3/images/lvi_hdd.png
|
||||
share/prokyon3/images/lvi_nfs.png
|
||||
share/prokyon3/images/lvi_playlist.png
|
||||
share/prokyon3/images/lvi_smb.png
|
||||
share/prokyon3/images/madsmiley.png
|
||||
share/prokyon3/images/pink_marble.png
|
||||
share/prokyon3/images/smiley.png
|
||||
share/prokyon3/images/splash4.png
|
||||
@dirrm share/prokyon3/images
|
||||
@dirrm share/prokyon3
|
Loading…
Reference in a new issue